btrfsck SIGSEGVs in find_first_block_group

Bug #601877 reported by Chris Halse Rogers on 2010-07-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
btrfs-tools (Ubuntu)
Medium
Surbhi Palande

Bug Description

Binary package hint: btrfs-tools

A follow on bug from bug #601874.

After boot, the first time I run btrfsck it crashes with bug #601874. The second time I run it, it crashes in find_first_block_group.

It sometimes also dies with an abort. I haven't yet got a backtrace for that; I'll file another bug when I do.

Backtrace attached.

Related branches

Chris Halse Rogers (raof) wrote :
Changed in btrfs-tools (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Surbhi Palande (csurbhi) on 2010-07-27
Changed in btrfs-tools (Ubuntu):
assignee: nobody → Surbhi Palande (csurbhi)
Surbhi Palande (csurbhi) on 2010-07-28
Changed in btrfs-tools (Ubuntu):
status: Confirmed → In Progress

I guess you'd probably like me to keep this disc image around for
testing fixes or hypotheses.

I'd like to replace it with a filesystem less broken, but btrfs-image
*also* segfaults with similar messages, so I'll keep this filesystem
around until you tell me it's no longer going to be useful :).

Surbhi Palande (csurbhi) wrote :

Hi Chris Halse Rogers,

Thanks a lot for your consideration and help :) I have kept a test ppa of btrfs-tools at https://launchpad.net/~csurbhi/+archive/ppa
Can you please let me know if this fixes things for you? I am not able to reproduce the same bug here.

Chris Halse Rogers (raof) wrote :

Well, it no longer segfaults. It now aborts in btrfs_lookup_extent_info!

Backtrace attached.

Chris Halse Rogers (raof) wrote :

I'd love to give you a btrfs image, but that segfaults; backtrace attached.

Surbhi Palande (csurbhi) wrote :

Chris Halse Rogers, did you have a system crash or had to force poweroff your machine? In that case, by any chance do you have the dmesg/kernel log of the crash and/or first boot after the crash?

Chris Halse Rogers (raof) wrote :

*giggle*.

Sorry - I've had to uncleanly kill this machine quite frequently, for a variety of reasons (most of which to do with X). I don't have those logs that far back.

I could possibly play around with powering off my machine while under IO load if that would be helpful.

Surbhi Palande (csurbhi) wrote :

I guess, btrfs aborting due to a corrupted fs is expected behavior as of now. I think, a safe way is to take snapshots regularly of your btrfs and then reverting back to the previous snapshots when something goes wrong. I will also find out more on this and update here if I do find out something more.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers