external btrfs partitions won't mount as different devices

Bug #518638 reported by Rocko on 2010-02-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
btrfs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: btrfs-tools

I have formatted an external drive as btrfs. The first time I mount it, eg as /dev/sdb1, it mounts fine. But after that, it will only remount as /dev/sdb1

The test case is:

* Mount the btrfs drive.
* Unmount and unplug the btrfs drive
* Plug another external drive in so it takes over as /dev/sdb1
* Plug the btrfs drive back in so it becomes /dev/sdc1
* Try to mount the btrfs drive.

It always fails to mount, either from nautilus or from the command line (eg sudo mount /dev/sdc1 /some_folder). The error indicates that the system cannot read the superblock.

If I reverse the process so that the btrfs drive once again is /dev/sdb1, it mounts correctly, so it appears to be caching the /dev/sdb1 information somewhere.

If I reboot so that the the second drive is /dev/sdb1 and the btrfs drive is /dev/sdc1, the btrfs drive mounts correctly.

The same occurs if the btrfs drive is initially mounted as another device, eg /dev/sde1; after this it will only mount as /dev/sde1.

Version info:

* I've tried on Ubuntu 9.10 with kernel 2.6.33 and btrfs-tools v 0.19-5ubuntu0.3+git20091112ubuntu1

* I've tried Ubuntu 10.04 with kernel 2.6.32 and btrfs-tools v 0.19.3

TheBeaver (banche) wrote :

I have it on 10.04 with kernel 2.6.32-22-generic-pae and btrfs-tools v. 0.19-8

I made a FS on an LVM volume. It mounted fine and I put data on it. After that, I renamed the logical volume and it would not mount. After I renamed it back to it's original name it did mount fine.

The error indicates that the system cannot read the superblock too.

I did NOT try to reboot after renaming, to see if it's just some system caching or whatever... I will try it and let you know.

Thank you.

Ken Sharp (kennybobs) on 2015-01-20
tags: added: karmic lucid
Rocko (rockorequin) wrote :

I'm pretty sure this is fixed in the kernels used in Trusty and onwards.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers