btrfs-convert executable is not included in btrfs-progs

Bug #1774794 reported by Juergen Scholz on 2018-06-02
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
btrfs-progs (Ubuntu)
Undecided
Unassigned

Bug Description

The current version (btrfs-progs_4.15.1-1build1_amd64.deb) of the package btrfs-progs does not include the btrfs-convert tool. However the man page for btrfs-convert is included.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in btrfs-progs (Ubuntu):
status: New → Confirmed
Autocracy (jeff-storyinmemo) wrote :
Autocracy (jeff-storyinmemo) wrote :

Also would need https://patchwork.kernel.org/patch/10281327/ applied in order to compile.

Autocracy (jeff-storyinmemo) wrote :

4.16.1 source from Cosmic builds in the Bionic release. Suggest upping the version as a bugfix is appropriate, though I don't understand how that fits into the packaging philosophy.

The attachment "Remove the "--disable-convert" flag" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
kkm (m88ez2fnn72x) wrote :

FWIW, it looks like btrfs-convert is being dropped upstream. I just compiled mine from source, and it crashed after some heavy churning. The package description should be changed though (it explicitly mentions btrfs-convert). Here's a relevant thread:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=854489

referring to the note in https://btrfs.wiki.kernel.org/index.php/Conversion_from_Ext3:

“Warning: As of 4.0 kernels this feature is not often used or well tested anymore, and there have been some reports that the conversion doesn't work reliably. Feel free to try it out, but make sure you have backups.”

My backtrace was different, but also related to btrfs_reserve_extent(). I also attempted ext4 -> btrfs. I'll post the BT but it's hardly helpful:

# btrfs-convert /dev/sdc1
create btrfs filesystem:
        blocksize: 4096
        nodesize: 16384
        features: extref, skinny-metadata (default)
creating ext2 image file
Unable to find block group for 0
Unable to find block group for 0
Unable to find block group for 0
extent-tree.c:2764: alloc_tree_block: BUG_ON `ret` triggered, value -28
btrfs-convert(+0x1c4f6)[0x558cfb6c54f6]
btrfs-convert(btrfs_alloc_free_block+0x1ff)[0x558cfb6cabaf]
btrfs-convert(+0x14d63)[0x558cfb6bdd63]
btrfs-convert(btrfs_search_slot+0x2af)[0x558cfb6bec8f]
btrfs-convert(btrfs_csum_file_block+0x48f)[0x558cfb6d0c1f]
btrfs-convert(+0xd944)[0x558cfb6b6944]
btrfs-convert(main+0x19d1)[0x558cfb6b5df1]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7)[0x7f75d48fcb97]
btrfs-convert(_start+0x2a)[0x558cfb6b64da]
Aborted

Autocracy (jeff-storyinmemo) wrote :

I found with some experimentation that btrfs_reserve_extent() fails due to free space fragmentation. If you don't have a large enough contiguous block on the filesystem you're trying to convert, that incurs the problem. It's poor error messaging.

Adam Borowski (kilobyte) wrote :

Just brought it back; -progs 5.1-1 are in Debian experimental and eoan-proposed.

As btrfs-convert underwent a major rewrite, plus a series of fixes later, old crashes very likely no longer apply, replaced with new shiny ones. Please report if you meet any show stoppers.

Changed in btrfs-progs (Ubuntu):
status: Confirmed → Fix Committed
Adam Borowski (kilobyte) on 2019-06-11
Changed in btrfs-progs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.