-b option is not working

Bug #1576641 reported by Erwan Prioul on 2016-04-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bsd-mailx (Debian)
Fix Released
Unknown
bsd-mailx (Ubuntu)
Undecided
Unassigned

Bug Description

I sent an email using the -b option to add a bcc address.

$ mail -b <email address hidden> <email address hidden>
Subject: a subject
bla bla bla
bla bla bla
.
EOT

It sent the email to <email address hidden> but it sent nothing to <email address hidden>.
It's like the -b option is ignored.

$ lsb_release -rd
Description: Ubuntu 15.10
Release: 15.10
$ apt-cache policy bsd-mailx
bsd-mailx:
  Installed: 8.1.2-0.20150408cvs-1
  Candidate: 8.1.2-0.20150408cvs-1
  Version table:
 *** 8.1.2-0.20150408cvs-1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ wily/main amd64 Packages
        100 /var/lib/dpkg/status

description: updated
Changed in bsd-mailx (Debian):
status: Unknown → New
Changed in bsd-mailx (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bsd-mailx - 8.1.2-0.20160123cvs-3

---------------
bsd-mailx (8.1.2-0.20160123cvs-3) unstable; urgency=medium

  * Make the `-b' option work again: update 03-Base-fixes-2.patch to revert
    the `comment out bcc code' change introduced in 1:8.1.1-10.2. The change
    is no longer needed after upstream switched to using the `-t' option
    of sendmail in 8.1.2-0.20150408cvs-1 (closes: #823412, LP: #1576641).
    Many thanks to Frederic Bonnard for finding the cause of the issue.
  * debian/control:
    + refer to s-nail package in the description instead of transitional
      heirloom-mailx (closes: #775766);
    + drop ancient Breaks/Replaces;
    + switch Vcs-Browser to cgit, and Vcs-Git to https;
    + bump Standards-Version to 3.9.8.

 -- Robert Luberda <email address hidden> Sat, 07 May 2016 09:33:20 +0200

Changed in bsd-mailx (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.