Comment 0 for bug 1795077

Jeremy Bicha (jbicha) wrote :

Note to SRU Team
================
This update adds a new binary package: libbrotli1

We need libbrotli1 and libbrotli-dev promoted to main. python-brotli and python3-brotli can remain in universe.

The approved MIR which mentions this will be done is LP: #1737053

Impact
======
webkit2gtk 2.20 released in March 2018 dropped its embedded brotli and woff2 libraries to use the system libraries. Because that version is a security update, webkit2gtk has not had support for woff2 web fonts since then in Ubuntu 16.04 LTS.

The version of brotli in Ubuntu 16.04 LTS is too old to support webkit2gtk so we are backporting the version from Ubuntu 18.04 LTS

Test Case
=========
1. Test that woff2 is able to build successfully against brotli.

2. Build webkit2gtk against woff2 and verify that woff2 fonts appear to work on web sites.

Regression Potential
====================
brotli has no reverse dependencies in Ubuntu 16.04 LTS.

The new version is substantially more usable since it now offers a C library instead of just the Python bindings.

Other Info
==========
brotli is also used by apache2 in Ubuntu 18.10.

The woff2 SRU for Ubuntu 16.04 LTS is LP: #