Circular dependency on package brother-cups-wrapper-laser

Bug #1083649 reported by Chris Schoonbee on 2012-11-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
brother-lpr-drivers-laser (Ubuntu)
Undecided
Unassigned

Bug Description

With recent previous releases of Ubuntu (12.04, 11.10) to get my Brother MFC7420 printer to work I needed to install the package `brother-cups-wrapper-laser`. This had a given dependency on brother-lpr-drivers-laser (eg using the command `aptitude show brother-cups-wrapper-laser`) which was then automatically installed. The status of both packages after installation was that they were correctly and completely installed as seen for example by a command such as
$ aptitude search brother
However in Ubuntu 12.10, the `brother-cups-wrapper-laser` still has a dependency on the brother-lpr-drivers-laser package but now examining the latter package with `aptitude show` shows that this now is now dependent on the cups-wrapper package in turn.
The package installation still works in the sense that the printer can be configured through the System settings but package management tools such as aptitude show that both packages are broken.

This is likely to cause other problems with package management down the line.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: brother-lpr-drivers-laser 2.0.1-3-0ubuntu5
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic i686
ApportVersion: 2.6.1-0ubuntu6
Architecture: i386
Date: Tue Nov 27 17:35:40 2012
InstallationDate: Installed on 2012-11-27 (0 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.2)
MarkForUpload: True
SourcePackage: brother-lpr-drivers-laser
UpgradeStatus: No upgrade log present (probably fresh install)

Chris Schoonbee (cmschoonbee) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers