brPrintList should only be in -common

Bug #264509 reported by Saivann Carignan on 2008-09-03
8
Affects Status Importance Assigned to Milestone
brother-lpr-drivers-common (Ubuntu)
Medium
FriedChicken
brother-lpr-drivers-laser1 (Ubuntu)
Medium
FriedChicken

Bug Description

Binary package hint: brother-lpr-drivers-common

usr/Brother/inf/brPrintList is missing for -laser package, and this file already exist in -laser1 package with different printer models.

This file needs to be updated and added to brother-lpr-drivers-common, and removed from brother-lpr-drivers-laser1.

We also have to make sure that brother-lpr-drivers-laser and brother-lpr-drivers-laser1 depends on brother-lpr-drivers-common.

Changed in brother-lpr-drivers-laser1:
importance: Undecided → Medium
status: New → Confirmed
Changed in brother-lpr-drivers-common:
importance: Undecided → Medium
status: New → Confirmed
Saivann Carignan (oxmosys) wrote :

FriedChicken : I reviewed the packages currently in your PPA, this is nice job! However, there is still things to fix before we can upload it :

1. Base your work on new intrepid packages : I recently uploaded a newer package to intrepid. Source packages can be downloaded here : http://packages.ubuntu.com/search?keywords=brother-lpr-drivers&searchon=names&suite=intrepid&section=all

2. Direct changes in the source : brother-lpr-drivers-common now contains /usr/local/Brother/inf/brPrintList. However, you didn't include this change in the .orig.tar.gz tarball, so that means that the .diff.gz contains changes applied outside of debian folder. With common debian packaging, we try to avoid direct modification on the source. The orig.tar.gz file should contains the source, and the .diff.gz should only contains changes in debian folder. If the package must apply changes on the source, this should be done with a patch system inside debian folder. However, in this case, we're the creator of this source package so we can update it at anytime.

What you need to do for this is simply to add brPrintList to the orig.tar.gz tarball, and then rename the tarball so it have a new upstream version (current is 1.0.0-3, so you can use 1.0.0-4). Don't forget to update your debian changelog to have the save upstream version number (since this is a new "upstream" version, the ubuntu version number should get back to "ubuntu1".

3. (LP: #264509) in changelog. Please add this LP syntax to close this bug report when your package will be uploaded.

4. debian/postinst missing in changelog : The package now have debian/postinst to fix permissions, however this change is not mentionned in changelog. Don't forget to write every changes in changelog ;-) .

Once this is done, can you build and test your package, and attach a debdiff for brother-lpr-drivers-laser1 and the complete source package for brother-lpr-drivers-common (including orig.tar.gz, diff.gz, dsc and changes files in one single compressed file)?

Thank you very much for the time you spent to improve the brother packages. If you can't do it for intrepid, don't hesitate to let me doing it for you.

FriedChicken (domlyons) wrote :

Saïvann, thank you for your feedback.
I think I can do that.

Changed in brother-lpr-drivers-common:
status: Confirmed → In Progress
Changed in brother-lpr-drivers-laser1:
status: Confirmed → In Progress
Saivann Carignan (oxmosys) wrote :

I assign the bug to you, to reflect reality. If you think that you'll not be able to do it before BetaFreeze https://wiki.ubuntu.com/IntrepidReleaseSchedule , please write a note about it so I can take care of it. Thanks again!!

Changed in brother-lpr-drivers-common:
assignee: nobody → domlyons
Changed in brother-lpr-drivers-laser1:
assignee: nobody → domlyons
Saivann Carignan (oxmosys) wrote :

FriedChicken : Any news on this bug report?

FriedChicken (domlyons) wrote :

Yes, I've attached the necessary files that you can review them.

FriedChicken (domlyons) wrote :
Saivann Carignan (oxmosys) wrote :

FriedChicken : Thanks for working on this! Your debdiff for -laser1 is perfect! However there are still some things to fix in your -common package :

1. You made a native package (without .orig.tar.gz and .diff.gz tarballs). Can you attach a package that contains :
brother-lpr-drivers-common_1.0.0-4.orig.tar.gz : This file contains the source files (including brPrintList).
brother-lpr-drivers-common_1.0.0-4-0ubuntu1.diff.gz : This file contains the ubuntu-specific changes (debian folder).
brother-lpr-drivers-common_1.0.0-4-0ubuntu1.dsc
brother-lpr-drivers-common_1.0.0-4-0ubuntu1_source.changes

2. In your source, you accidentally renamed COPYING to copying ;-)

3. There is (LP: #206365) in the debian/changelog for postinst change, but this bug report is already fixed. I would say that it's not necessary to close a LP bug report here since there are no specific bug opened for this issue.

Can you add these last changes to your package and upload again your work in the bug report?

Saivann Carignan (oxmosys) wrote :

To fix 1 , I suggest that you take a look at how current -common package is made. Normally, you should simply :

1. Create the orig.tar.gz tarball (exactly the same as the old one, except that you add brPrintList and change the version number to 1.0.0-4)
2. Extract the orig.tar.gz
3. Add debian folder in the extracted folder
4. Launch "dpkg-buildpackage -S -sa -rfakeroot" to create .diff.gz, .dsc and .changes files.

Saivann Carignan (oxmosys) wrote :

I just found another problem to fix :

4. Wrong file permissions in source package : all files in your source package currently have 755 permissions, this is wrong because some files should not have write permission. In order to fix this, I suggest what I suggested above, to base your work on the existing package. This way, you will not apply any change to the existing permissions which are correct.

Current files that should have 644 permissions :

/usr/Brother/inf/paperinf
/usr/Brother/Printer/brio*

Thanks for your feedback, I will fix this.
I guess it was no good idea to transfer the files from one pc to another
using an usb-stick with NTFS ...

Saivann Carignan (oxmosys) wrote :

Thanks, I'm ready to review your work again. Oh yes, most probably that these problems are mostly caused by a temporary transfert on a un-compatible filesystem :) . Sometime you can avoid these problems by making a tar.gz containing your files, this is a way to keep correct file names and permissions. However, using the same filesystem is always the best solution to avoid problems.

FriedChicken (domlyons) wrote :

I hope everything is correct now. I've packed everything in one file to make it easier to attach it.

All is OK now. I am uploading the new packages currently. Bug will close in a few minutes.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brother-lpr-drivers-common - 1.0.0-4-0ubuntu1

---------------
brother-lpr-drivers-common (1.0.0-4-0ubuntu1) intrepid; urgency=low

  * debian/postinst: added postinst script to fix permissions
  * Added /usr/Brother/inf/brPrintList (moved from brother-lpr-drivers-laser1
    and added devices from brother-lpr-drivers-laser) (LP: #264509)

 -- Dominic Lyons <email address hidden> Mon, 22 Sep 2008 00:09:19 +0200

Changed in brother-lpr-drivers-common:
status: In Progress → Fix Released

Uploaded also the brother-lpr-drivers-laser1, this task will close soon, too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brother-lpr-drivers-laser1 - 1.0.0-3-0ubuntu4

---------------
brother-lpr-drivers-laser1 (1.0.0-3-0ubuntu4) intrepid; urgency=low

  * debian/rules: Remove /usr/Brother/inf/brPrintList (moved to
    brother-lpr-drivers-common) (LP: #264509)

 -- Dominic Lyons <email address hidden> Sun, 21 Sep 2008 14:10:00 +0200

Changed in brother-lpr-drivers-laser1:
status: In Progress → Fix Released
Saivann Carignan (oxmosys) wrote :

FriedChiken : Thanks again for your great work on this!

Till Kamppeter : Thanks for this so fast verification and upload.

FriedChicken (domlyons) wrote :

Thank you, Till, for uploading.

And special thanks to you, Saïvann, for your great help and your hints.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers