Add support of new printers

Bug #425172 reported by Alex_xxx on 2009-09-06
66
This bug affects 11 people
Affects Status Importance Assigned to Milestone
brother-cups-wrapper-extra (Ubuntu)
Undecided
Unassigned
brother-cups-wrapper-laser (Ubuntu)
Undecided
Unassigned
brother-lpr-drivers-extra (Ubuntu)
Undecided
Unassigned
brother-lpr-drivers-laser (Ubuntu)
Undecided
Unassigned

Bug Description

Brother printer drivers seem to be outdated, Brother company provided many new drivers at http://solutions.brother.com/linux/en_us/download_prn.html, which are not included in the package.

Alex_xxx (alex-x1980) wrote :

For example, drivers for DCP-375CW and DCP-387C

Marius B. Kotsbak (mariusko) wrote :

Confirm that drivers for the above models are available at the URL above but not included in the packages in Natty.

Changed in brother-cups-wrapper-extra (Ubuntu):
status: New → Confirmed
Marius B. Kotsbak (mariusko) wrote :

Same for Brother dcp-7040 and dcp-365cn.

Changed in brother-cups-wrapper-laser (Ubuntu):
status: New → Confirmed
Changed in brother-lpr-drivers-extra (Ubuntu):
status: New → Confirmed
Changed in brother-lpr-drivers-laser (Ubuntu):
status: New → Confirmed
Bill Risch (brisch) wrote :
Download full text (3.6 KiB)

I have contacted brother concerning updated drivers.
Here is the solution they provided:
bill@bill-GA-MA78GM-US2H:~/Desktop$ sudo bash linux-brprinter-installer-1.0.3-1 Brother DCP-7040

wget http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html
You are going to install following packages.
   dcp1000lpr-1.1.2-1.i386.deb
   cupswrapperDCP1000-1.0.2-1.i386.deb
OK? [y/N] ->y
I will include the remainder of the output.
What is important is that these are i386 drivers and will not install on amd64 systems.
This is true for ubuntu natty, openSUSE, and Debian. All of which use the same underlying printer configuration code.
I have contacted brother again and supplied the output of the install process.
I will duplicate it below:

Reading package lists... Done
dpkg -x dcp1000lpr-1.1.2-1.i386.deb /
dpkg -x cupswrapperDCP1000-1.0.2-1.i386.deb /
dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
dpkg: regarding dcp1000lpr-1.1.2-1.i386.deb containing dcp1000lpr:i386:
 brother-lpr-drivers-laser1 conflicts with dcp1000lpr
  dcp1000lpr:i386 (version 1.1.2-1) is to be installed.
dpkg: warning: ignoring conflict, may proceed anyway!
(Reading database ... 412901 files and directories currently installed.)
Preparing to replace dcp1000lpr:i386 1.1.2-1 (using dcp1000lpr-1.1.2-1.i386.deb) ...
Unpacking replacement dcp1000lpr:i386 ...
Replaced by files in installed package brother-lpr-drivers-laser1 ...
start: Unknown job: lpd
dpkg: warning: subprocess old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
start: Unknown job: lpd
dpkg: error processing dcp1000lpr-1.1.2-1.i386.deb (--install):
 subprocess new post-removal script returned error exit status 1
start: Unknown job: lpd
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Errors were encountered while processing:
 dcp1000lpr-1.1.2-1.i386.deb
dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
dpkg: regarding cupswrapperDCP1000-1.0.2-1.i386.deb containing cupswrapperdcp1000:i386:
 brother-cups-wrapper-laser1 conflicts with cupswrapperdcp1000
  cupswrapperdcp1000:i386 (version 1.0.2-1) is to be installed.
dpkg: warning: ignoring conflict, may proceed anyway!
(Reading database ... 412901 files and directories currently installed.)
Preparing to replace cupswrapperdcp1000:i386 1.0.2-1 (using cupswrapperDCP1000-1.0.2-1.i386.deb) ...
cups stop/waiting
cups start/running, process 2347
restart
Unpacking replacement cupswrapperdcp1000:i386 ...
dpkg: cupswrapperdcp1000:i386: dependency problems, but configuring anyway as you requested:
 cupswrapperdcp1000:i386 depends on libc6 (>= 2.2.5).
Setting up cupswrapperdcp1000:i386 (1.0.2-1) ...
rm -f /usr/lib/cups/filter/brlpdwrapperDCP1000
cp: `/usr/lib/cups/filter/brlpdwrapperDCP1000' and `/usr/lib64/cups/filter/brlpdwrapperDCP1000' are the same file
stop
cups stop/waiting
cups start/running, process 2392
restart
Package `dcp1000lpr' is not installed.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg ...

Read more...

Bruce Miller (brm0423) wrote :

I have reported to Brother Canada the problems using their drives on natty

greenmoss (ktyubuntu) wrote :

Another vote for adding more Brother printer drivers here. I spent over an hour working my way through installation of my Brother HL-2270DW. Inexperienced users would have given up.

FWIW, here are the manual steps:
- download the two deb files from http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#HL-2270DW
- install both deb files using "dpkg -i"
- configure a new printer in Ubuntu
- specify a custom driver: /usr/share/cups/model/HL2270DW.ppd

greenmoss (ktyubuntu) wrote :

Forgot to mention my Ubuntu version: 12.04.1 LTS (precise)

tags: added: precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers