MFC-260C driver not working properly

Bug #334222 reported by Sam Liddicott on 2009-02-25
6
Affects Status Importance Assigned to Milestone
brother-cups-wrapper-extra (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: brother-cups-wrapper-extra

On Jaunty, the brother deb's (all installed) do not provide drivers for my MFC-260C.
On a fresh intrepid install, they do provide drivers for my MFC-260C.

I have jaunty with:
brother-cups-wrapper-common
brother-cups-wrapper-extra
brother-lpr-drivers-common
brother-lpr-drivers-extra

brother-cups-wrapper-extra claims to support the MFC-260C, but when the printer is installed it fails miserably to provide a driver and when I browse the brother driver list, the MFC-260C is not listed.

If I manually add a printer it does choose the DCP-110C as the driver - I don't know if that is correct but it least it picks a driver and it does print, but the vertical alignment is wrong and the top of the page is cut off.

(I think the test page should print the driver being used, like windows test page does.)

$ apt-cache policy brother-cups-wrapper-extra
brother-cups-wrapper-extra:
  Installed: 1.2.1-0ubuntu3
  Candidate: 1.2.1-0ubuntu3
  Version table:
 *** 1.2.1-0ubuntu3 0
        500 http://gb.archive.ubuntu.com jaunty/multiverse Packages
        100 /var/lib/dpkg/status

Sam Liddicott (sam-liddicott) wrote :

I had another try today, this time MFC260C was listed in brother drivers - maybe it was before and I just kept missing it?

However CUPS still reported when the printer was connected that it couldn't find a driver.

Sam Liddicott (sam-liddicott) wrote :

Still a bug;

1. I delete all printers, and then re-connect my Broterh MFC-260C
2. Cups complains it can't find a driver
3. I select one as Brother, MFC-260C and printer a test page
4. test page doesn't print, the system claims the printer is not connected.

Sam Liddicott (sam-liddicott) wrote :

I can make the printer work again by following the steps here:
http://ubuntuforums.org/showthread.php?t=849146

>This could be Debian bug #383091.
>
>I had the same problem on Hardy 32-bit. To fix it, I had to add the following line to the file /etc/cups/cupsd.conf:
>
>Code:
>
>FileDevice Yes
>
>After this, I went to localhost:631 with my browser and changed the device URI of the printer to
>
>file:/dev/usb/lp0
>
>That did it for me!

Which makes me think that it is because the device node wasn't set up correctly.

However the top of the page is still chopped off - and yes the MFC-260C driver is selected

Marius B. Kotsbak (mariusko) wrote :

I see the printer in the list after installing the mentioned package (new start of the printer config program might be needed).

I changed the name of the bug since you confirmed that the driver is in the list. About the error with the test page, can you verify that the paper size is correctly configured, it is two places in the printer config you must set it. If you use A4, the default set is letter. Also try upgrading to Natty.

Changed in brother-cups-wrapper-extra (Ubuntu):
status: New → Incomplete
summary: - MFC-260C not provided for
+ MFC-260C driver not working properly
Sam Liddicott (sam-liddicott) wrote :

I no longer have this printer.

Marius B. Kotsbak (mariusko) wrote :

Marking as invalid since reporter is not able to supply more information about this bug.

Changed in brother-cups-wrapper-extra (Ubuntu):
status: Incomplete → Invalid
Sam Liddicott (sam-liddicott) wrote :

I'm marking this valid because
1. it is a valid bug
2
. marking it as invalid is an insult to the reporter
3. insulting reporters will have a tendancy to discourage repots

I'd like to mark this bug "too slow" because the average launchpad response time seems quite close to the average hardware lifetime - but there isn't a "too slow" option.

Changed in brother-cups-wrapper-extra (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions