broadcom-sta 6.30.223.271-3~16.04.2 ADT test failure with linux-hwe-edge 4.15.0-23.25~16.04.1

Bug #1777444 reported by Marcelo Cerri on 2018-06-18
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
broadcom-sta (Ubuntu)
Undecided
Marcelo Cerri
Xenial
Undecided
Marcelo Cerri

Bug Description

[Impact]

Currently the DKMS package fails to install on supported custom
kernels that are based on 4.15. That includes the current 4.15
hwe-edge and some of the custom and cloud kernels as well.

[Test Case]

Install the broadcom-sta package with the 4.15 hwe-edge
kernel. The package installation should proceed without any
errors.

[Regression Potential]

Although new patches were added, the regression risk is very low since the new
changes are conditionally compiled based on the kernel version.

Besides that, the new package was tested with the following kernels in an amd64
environment:

- linux-generic 4.4
- linux-hwe 4.13
- linux-hwe-edge 4.15
- linux-azure 4.15

[Original Description]

Testing failed on:
    amd64: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/b/broadcom-sta/20180528_193746_5dad9@/log.gz
    i386: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/i386/b/broadcom-sta/20180528_195126_5dad9@/log.gz

Marcelo Cerri (mhcerri) wrote :
tags: added: kernel-adt-failure
Marcelo Cerri (mhcerri) on 2018-06-18
description: updated
tags: added: patch
Marcelo Cerri (mhcerri) on 2018-06-19
Changed in broadcom-sta (Ubuntu):
assignee: nobody → Marcelo Cerri (mhcerri)
status: New → In Progress
Tyler Hicks (tyhicks) wrote :

Thanks! I've sponsored this upload to xenial.

Changed in broadcom-sta (Ubuntu Xenial):
status: New → Fix Committed
assignee: nobody → Marcelo Cerri (mhcerri)
Changed in broadcom-sta (Ubuntu):
status: In Progress → Invalid

Hello Marcelo, or anyone else affected,

Accepted broadcom-sta into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/broadcom-sta/6.30.223.271-3~16.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
Marc Peña (pachulo) wrote :

Installed it and the compilation of the module went OK. WiFi is working after restart with kernel 4.15.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Stan Varlamov (stanubuntu) wrote :

broadcom-sta-dkms: Installed: 6.30.223.271-3~16.04.3
4.15.0-24-generic
tags: added: verification-done verification-done-xenial

Philip Cunningham (mcfilib) wrote :

BCM4360 WiFi working again with this version. Many thanks.

manmanman (soininvaara) wrote :

BCM43142 also works with this. Thank you!

S Stewart (medusa193) wrote :

I've added the recommended patch but don't yet know if it has fixed my problem. I'll post results when I know them.

Thomas Ritter (th-ritter) wrote :

BCM43228: Works.

Marina (wertushka) wrote :

BCM4313 also works with this. Thank you!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package broadcom-sta - 6.30.223.271-3~16.04.3

---------------
broadcom-sta (6.30.223.271-3~16.04.3) xenial; urgency=medium

  * Backport to xenial for kernel 4.14 and 4.15 support. (LP: #1777444)
    - 20-linux414.patch
    - 21-linux415.patch

 -- Marcelo Henrique Cerri <email address hidden> Mon, 18 Jun 2018 17:32:31 +0000

Changed in broadcom-sta (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for broadcom-sta has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Christian Silva (chris-silva) wrote :

Hello Everybody!

Can anyone tell me please "Step by Step" how to install the patch or package?

I do not have a clue how to do it as I am not an IT expert and I am a new Ubuntu 16.04 user, but still need to solve this wifi issue!

Thank You So Much!

CSilva.

Saini (as133) wrote :

@CSilva

I am a newbie too. Sorry -- didn't take notes :(

The main steps that I used were:

Removed the existing driver: sudo apt-get purge bcmwl-kernel-source

Enabled proposed archive: To enable the proposed archive for Ubuntu 16.04 and later use the Software & Updates program and ensure that Pre-released updates (xenial-proposed) is ticked in the Developer Options tab. (Source: https://wiki.ubuntu.com/Testing/EnableProposed)

Install: sudo apt-get install broadcom-sta-dkms/xenial-proposed (Source: Stan's comment above for the package name)

Christian Silva (chris-silva) wrote :

@Saini

Yes!!! that was exactly what I needed.

I followed your comprehensive explanation and very easy steps and now it works!. wherever you are you are thank you so much my friend Saini!

Best Regards.

martinely95 (martinely95) wrote :

@CSilva

One more thanks from me also! Worked like a charm!

Zsolt Horvath (hzsbud) wrote :

Yes,

This two commands solved my problem:

sudo apt-get purge bcmwl-kernel-source
sudo apt-get install broadcom-sta-dkms

Big THX!

Yevhen (onegin-ua) wrote :

Yes! This two commands also solved my problem with wi-fi after update from kernel 4.13.0 to 4.15.0 (hwe update) for Ubuntu 16.04.

Thank You All!

Yes!!!
sudo apt-get purge bcmwl-kernel-source
sudo apt-get install broadcom-sta-dkms
It works!!!
Thank You All!!!!!!

Все заработало, вай фай нашелся.

mami (t-ani) wrote :

sudo apt-get purge bcmwl-kernel-source
sudo apt-get install broadcom-sta-dkms

It works for me as well. Ubunbtu 16.04. DELL

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments