BCM4350 needs to be unloaded/loaded on suspend to not crash

Bug #1765036 reported by Carl-Erik Kopseng on 2018-04-18
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
broadcom-sta (Ubuntu)
Undecided
Unassigned

Bug Description

The driver for Broadcom BCM4350 works fine using the stock brcmfmac driver, except when going into suspend or hibernation. On resume it will crash and only a reboot seems to fix it.

After much chagrin and trying various driver packages (like the wl driver) without any success (lots of complaining about firmware, etc in dmesg), I managed to get the stock brcmfmac driver working perfectly by instructing the pm-* set of commands to unload and subsequently load it when doing any kind of power management.

Essentially, some package should execute
echo 'SUSPEND_MODULES="brcmfmac"' | sudo tee -a /etc/pm/config.d/config

for this to work for most Dell XPS machines.

Hardware info attached.

Expected: wifi driver to keep working after suspend or hibernation
Actual: brcmfmac driver crashes.

Carl-Erik Kopseng (carlerik) wrote :
Carl-Erik Kopseng (carlerik) wrote :

All relevant info has been attached by using the utility script https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info.

I tried marking package as "I don't know", but somehow still ended up tagging the broadcom-sta package, which I think is wrong (different drivers). Not sure how to do anything about that, though.

I think the package should be the general linux-kernel, as I can find the driver source in /usr/src/linux-headers-4.15.0-13/drivers/net/wireless/broadcom/brcm80211/brcmfmac

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in broadcom-sta (Ubuntu):
status: New → Confirmed
Cris (crism60) wrote :

Hi. I have Ubuntu 20.04 running on a Macboook PRO 2016 (with touchbar). I'm experiencing the same issue, but unloading brcmfmac module before suspend did not help. I also tried reloading the module and NetworkManager when the laptop wakes up, but not helpful as well.

For making wifi work on my macbook I had to put this txt file inside /lib/firmware/brcm https://gist.github.com/cristianmiranda/ba9d64b4324f0803d9422d765de62252

I observed that after rebooting (which is the only fix so far) I can connect to 5G networks instantly, but after suspend/resume it tries to connect for a long time (if it gets to see them anyway) and fails.

Any progress on this issue?
Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments