udevd warnings in /lib/udev/rules.d/85-brltty.rules

Bug #491775 reported by dino99 on 2009-12-03
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
BRLTTY
Invalid
Undecided
Unassigned
brltty (Debian)
Fix Released
Unknown
brltty (Ubuntu)
Medium
Steve Langasek
Lucid
Medium
Steve Langasek

Bug Description

Binary package hint: udev

Lucid testing

daemon.log flooded by these messages:

oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/56-hpmud_support.rules:10
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:8
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:9
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:10
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:13
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:14
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:15
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:16
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:17
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:18
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:19
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:20
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:21
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:22
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:23
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:24
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:25
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:26
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:27
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:28
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:29
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:30
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:31
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:32
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:35
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:36
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:39
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:40
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:41
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:44
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:48
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:51
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:54
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:57
Dec 3 08:48:04 oem-desktop udevd[530]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/85-brltty.rules:60

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 0e856621e764f27871668a8d860c3158
CheckboxSystem: edda5d4f616ca792bf437989cb597002
CustomUdevRuleFiles: 56-hpmud_support.rules
Date: Thu Dec 3 09:09:34 2009
DistroRelease: Ubuntu 10.04
MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
NonfreeKernelModules: nvidia
Package: udev 148~-1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-6-generic root=UUID=f23f677d-7a16-4190-a2fa-c668e9e0a3ac ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-6.8-generic
SourcePackage: udev
Tags: lucid
Uname: Linux 2.6.32-6-generic i686
dmi.bios.date: 07/10/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2801
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5W DH Deluxe
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2801:bd07/10/2008:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5W DH Deluxe
dmi.product.version: System Version
dmi.sys.vendor: ASUSTEK COMPUTER INC

Related branches

dino99 (9d9) wrote :
dino99 (9d9) wrote :
Download full text (3.5 KiB)

syslog give some more info:

oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.0/usb2
Dec 3 08:38:33 oem-desktop udev-configure-printer: Failed to get parent
Dec 3 08:38:33 oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.0/usb2/2-0:1.0
Dec 3 08:38:33 oem-desktop udev-configure-printer: parent devpath is /devices/pci0000:00/0000:00:1d.0/usb2
Dec 3 08:38:33 oem-desktop udev-configure-printer: Device vendor/product is 1D6B:0001
Dec 3 08:38:33 oem-desktop udev-configure-printer: invalid or missing IEEE 1284 Device ID
Dec 3 08:38:33 oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.1/usb3
Dec 3 08:38:33 oem-desktop udev-configure-printer: Failed to get parent
Dec 3 08:38:33 oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.1/usb3/3-0:1.0
Dec 3 08:38:33 oem-desktop udev-configure-printer: parent devpath is /devices/pci0000:00/0000:00:1d.1/usb3
Dec 3 08:38:33 oem-desktop udev-configure-printer: Device vendor/product is 1D6B:0001
Dec 3 08:38:33 oem-desktop udev-configure-printer: invalid or missing IEEE 1284 Device ID
Dec 3 08:38:33 oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.2/usb4/4-0:1.0
Dec 3 08:38:33 oem-desktop udev-configure-printer: parent devpath is /devices/pci0000:00/0000:00:1d.2/usb4
Dec 3 08:38:33 oem-desktop udev-configure-printer: Device vendor/product is 1D6B:0001
Dec 3 08:38:33 oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.2/usb4
Dec 3 08:38:33 oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.3/usb5/5-0:1.0
Dec 3 08:38:33 oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.7/usb1/1-0:1.0
Dec 3 08:38:33 oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.7/usb1/1-7/1-7:1.0
Dec 3 08:38:33 oem-desktop udev-configure-printer: invalid or missing IEEE 1284 Device ID
Dec 3 08:38:33 oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.7/usb1/1-7
Dec 3 08:38:33 oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.7/usb1
Dec 3 08:38:33 oem-desktop udev-configure-printer: add /devices/pci0000:00/0000:00:1d.3/usb5
Dec 3 08:38:33 oem-desktop udev-configure-printer: Failed to get parent
Dec 3 08:38:33 oem-desktop udev-configure-printer: parent devpath is /devices/pci0000:00/0000:00:1d.7/usb1
Dec 3 08:38:33 oem-desktop udev-configure-printer: Device vendor/product is 1D6B:0002
Dec 3 08:38:33 oem-desktop udev-configure-printer: invalid or missing IEEE 1284 Device ID
Dec 3 08:38:33 oem-desktop udev-configure-printer: parent devpath is /devices/pci0000:00/0000:00:1d.7/usb1/1-7
Dec 3 08:38:33 oem-desktop udev-configure-printer: Device vendor/product is 05E3:0606
Dec 3 08:38:33 oem-desktop udev-configure-printer: invalid or missing IEEE 1284 Device ID
Dec 3 08:38:33 oem-desktop udev-configure-printer: Failed to get parent
Dec 3 08:38:33 oem-desktop udev-configure-printer: parent devpath is /devices/pci0000:00/0000:00:1d.3/usb5
Dec 3 08:38:33 oem-desktop udev-configure-printer: Device vendor/product is 1D6B:0001
Dec 3 08:38:33 oem-desktop udev-configure-printer: invalid or missing IEEE 1284 D...

Read more...

affects: udev (Ubuntu) → brltty (Ubuntu)
arky (arky) wrote :

Results of 'sudo restart udev'

OS:
Ubuntu lucid (development branch)
Release: 10.04

$ apt-cache policy brltty
brltty:
  Installed: 4.0-8ubuntu2
  Candidate: 4.0-8ubuntu2
  Version table:
 *** 4.0-8ubuntu2 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

Fixed in Debian's 4.1-2

Thierry Carrez (ttx) wrote :

Those warnings are also displayed when booting the Lucid alpha 1 server ISO, resulting in the installer boot process to take ages on slow consoles.

Changed in brltty (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
summary: - udevd errors in /lib/udev/rules.d/85-brltty.rules
+ udevd warnings in /lib/udev/rules.d/85-brltty.rules
Neil Perry (nperry) on 2009-12-09
tags: added: iso-testing
Steve Langasek (vorlon) on 2009-12-09
Changed in brltty (Ubuntu Lucid):
assignee: nobody → Steve Langasek (vorlon)
Changed in brltty (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brltty - 4.1-2ubuntu1

---------------
brltty (4.1-2ubuntu1) lucid; urgency=low

  * Merge from Debian testing, remaining changes:
    - Add brltty-setup, installed in both the udeb and the normal system.
    - Add initramfs integration to run brltty-setup if necessary before
      usplash starts.
    - Add ubiquity integration to propagate any brltty configuration to the
      target system.
    - Put udev rules file in /lib/udev/rules.d.
    - Add udev rules and /lib/brltty/brltty.sh to the normal (non-udeb)
      package as well.
    - Enable brltty if /etc/default/brltty has RUN_BRLTTY=yes, which is set
      by the installer if brltty is configured; add a NEWS entry for
      upgraders.
    - Don't install /etc/brltty.conf in the package
    - Install udev rules with the same name (85-brltty.rules) in the udeb as
      in the deb.
    - Disable BrlTTY grabbing devices that use the FTDI USB-to-serial chip.
    - Remove the dh-lisp build-dependency, remove the cl-brlapi package, and
      adjust the brltty package description accordingly. dh-lisp is not
      in main.
    - Build for all python versions (python 2.6), not just the current
      version.
    - Build against openjdk in Ubuntu.
    - Enable brltty at startup on the target system if the alternate installer
      is used.
  * udev rules have been switched to use ATTRS{} instead of the deprecated
    SYSFS{}. LP: #491775.

brltty (4.1-2) unstable; urgency=high

  * High-urgency upload for bug fix for d-i alpha release.
  * debian/brltty-udeb.udev.rules: Fix udev 148-2 warnings cluttering
  debian-installer (Closes: Bug#559564).
 -- Steve Langasek <email address hidden> Thu, 10 Dec 2009 02:39:03 -0800

Changed in brltty (Ubuntu Lucid):
status: Confirmed → Fix Released
MilchFlasche (robertus0617) wrote :

After doing a "aptitude full-upgrade" in tty1 (because I can't even boot into desktop environment) and updated brltty, and after rebooting, I still get one line message

udevd[325]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /lib/udev/rules.d/56-hpmud_support.rules:10

so I guess it may be conflicting with hplip package?

MilchFlasche (robertus0617) wrote :

Oh forgot to mention, after that one line, tty7 still hangs and stop normal booting procedure.

Steve Langasek (vorlon) wrote :

The deprecation messages are TTBOMK unrelated to any boot-time hangs; please file a separate bug report for any issue you're having there. The hplip issue should also be filed as a separate bug.

Bulat Nigmatullin (bulatka) wrote :

I've tryied current 14 Dec release, but i'm still experiencing this bug.

I see messages on screen1.jpg, then see scree2.jpg, then monitor start blinking until I press power off button.

Bulat Nigmatullin (bulatka) wrote :
Edwin Grubbs (edwin-grubbs) wrote :

Can we get rid of these deprecation messages from the console? They are very disconcerting when you are trying to debug problems booting.

Apr 2 11:03:47 macubu udevd[379]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/025_logitechmouse.rules:1
Apr 2 11:03:47 macubu udevd[379]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/025_logitechmouse.rules:5

Steve Langasek (vorlon) wrote :

The deprecation messages are there because you have udev rules whose behavior will change in a future release. If not on the console, where should they be shown?

Note that all such rules shipped in Ubuntu are believed to be fixed, so your udev rules will only be fixed if you fix them manually. (The file /etc/udev/rules.d/025_logitechmouse.rules is not included in any package in any currently supported release of Ubuntu.)

Charlie Kravetz (charlie-tca) wrote :

This is not a valid upstream or package

Changed in brltty:
status: New → Invalid
Jussi Pakkanen (jpakkane) wrote :

On my machine /etc/udev/rules.d/025_logitechmouse.rules is a symlink to /etc/udev/logitechmouse.rules, and

dpkg -S /etc/udev/logitechmouse.rules

says

kcontrol: /etc/udev/logitechmouse.rules

Tormod Volden (tormodvolden) wrote :

After upgrading from 8.04 to 10.04, the /etc/udev/rules.d/85-brltty.rules is not removed even if it has not been modified by the user.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.