package brltty 5.0-2ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1365054 reported by Charly on 2014-09-03
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
brltty (Ubuntu)
High
Unassigned

Bug Description

/usr/bin/dpkg returned an error code (1)

upgrade from 14.04 to 14.10

ProblemType: Package
DistroRelease: Ubuntu 14.10
Package: brltty 5.0-2ubuntu3
ProcVersionSignature: Ubuntu 3.13.0-34.60-generic 3.13.11.4
Uname: Linux 3.13.0-34-generic i686
ApportVersion: 2.14.1-0ubuntu3.3
AptOrdering: brltty: Configure
Architecture: i386
Date: Wed Sep 3 12:06:13 2014
DuplicateSignature: package:brltty:5.0-2ubuntu3:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2014-08-13 (21 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20140417)
SourcePackage: brltty
Title: package brltty 5.0-2ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to utopic on 2014-09-03 (0 days ago)

Charly (rafis3) wrote :
tags: removed: need-duplicate-check

Well, yes, brltty needs mountkernfs, like a lot of software actually. Having it disabled seems the culprit here, not brltty.

so how do u remove it to do the upgrade

On 9/3/14, Samuel thibault <email address hidden> wrote:
> Well, yes, brltty needs mountkernfs, like a lot of software actually.
> Having it disabled seems the culprit here, not brltty.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1365054
>
> Title:
> package brltty 5.0-2ubuntu3 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> Status in “brltty” package in Ubuntu:
> New
>
> Bug description:
> /usr/bin/dpkg returned an error code (1)
>
> upgrade from 14.04 to 14.10
>
> ProblemType: Package
> DistroRelease: Ubuntu 14.10
> Package: brltty 5.0-2ubuntu3
> ProcVersionSignature: Ubuntu 3.13.0-34.60-generic 3.13.11.4
> Uname: Linux 3.13.0-34-generic i686
> ApportVersion: 2.14.1-0ubuntu3.3
> AptOrdering: brltty: Configure
> Architecture: i386
> Date: Wed Sep 3 12:06:13 2014
> DuplicateSignature: package:brltty:5.0-2ubuntu3:subprocess installed
> post-installation script returned error exit status 1
> ErrorMessage: subprocess installed post-installation script returned error
> exit status 1
> InstallationDate: Installed on 2014-08-13 (21 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386
> (20140417)
> SourcePackage: brltty
> Title: package brltty 5.0-2ubuntu3 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
> UpgradeStatus: Upgraded to utopic on 2014-09-03 (0 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/brltty/+bug/1365054/+subscriptions
>

Charly (rafis3) wrote :

can i do the upgrade to mate caz i really like to try mate of 14.10
without loosing my files n settings

On 9/3/14, Rafi <email address hidden> wrote:
> so how do u remove it to do the upgrade
>
> On 9/3/14, Samuel thibault <email address hidden> wrote:
>> Well, yes, brltty needs mountkernfs, like a lot of software actually.
>> Having it disabled seems the culprit here, not brltty.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1365054
>>
>> Title:
>> package brltty 5.0-2ubuntu3 failed to install/upgrade: subprocess
>> installed post-installation script returned error exit status 1
>>
>> Status in “brltty” package in Ubuntu:
>> New
>>
>> Bug description:
>> /usr/bin/dpkg returned an error code (1)
>>
>> upgrade from 14.04 to 14.10
>>
>> ProblemType: Package
>> DistroRelease: Ubuntu 14.10
>> Package: brltty 5.0-2ubuntu3
>> ProcVersionSignature: Ubuntu 3.13.0-34.60-generic 3.13.11.4
>> Uname: Linux 3.13.0-34-generic i686
>> ApportVersion: 2.14.1-0ubuntu3.3
>> AptOrdering: brltty: Configure
>> Architecture: i386
>> Date: Wed Sep 3 12:06:13 2014
>> DuplicateSignature: package:brltty:5.0-2ubuntu3:subprocess installed
>> post-installation script returned error exit status 1
>> ErrorMessage: subprocess installed post-installation script returned
>> error
>> exit status 1
>> InstallationDate: Installed on 2014-08-13 (21 days ago)
>> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386
>> (20140417)
>> SourcePackage: brltty
>> Title: package brltty 5.0-2ubuntu3 failed to install/upgrade:
>> subprocess
>> installed post-installation script returned error exit status 1
>> UpgradeStatus: Upgraded to utopic on 2014-09-03 (0 days ago)
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/ubuntu/+source/brltty/+bug/1365054/+subscriptions
>>
>

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in brltty (Ubuntu):
status: New → Confirmed
Nick Andrik (andrikos) wrote :

I think the proper solution is a versioned dependency on initscripts (of the version that provides mountkernfs)

Nick Andrik (andrikos) wrote :

@Charly:

Try to upgrade your initscripts package first and then upgrade the brltty package.
This worked for me

Piotr Rybałtowski (piotr.r) wrote :

Doing apt-get dist-upgrade instead of apt-get upgrade helped in my case.

Erik-bjareholt (erik-bjareholt) wrote :

Updating the initscripts package first did indeed solve the problem for me.

Changed in brltty (Ubuntu):
importance: Undecided → High

I am seeing this the very first time, sorry I'm not able to add something useful. This is obviously an incomplete update from 14.04 to 14.10 and now I take the chance to upgrade to 15.04. Good luck may be with me!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers