Slow login to kde5 waiting on breeze splash

Bug #1584604 reported by Con Kolivas on 2016-05-23
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
breeze (Ubuntu)
High
Unassigned

Bug Description

I still get the slow login as happened with kubuntu 15.10 now on a fresh install of kubuntu 16.04 on multiple systems.

The pause is identical to as happened in this bug which is marked as closed, but it does not appear to be bluetooth related this time: https://bugs.launchpad.net/bugs/1509334 Other people have tried to report the same bug as an addendum but it was closed, hence why I'm opening a new bug.

The kde throbber reaches 100% very quickly and then there is a pause where there is no activity and then the desktop finally appears many seconds later. A systemd analyze blame shows the following as top10:
          5.997s NetworkManager-wait-online.service
          2.469s postgresql@9.3-main.service
          2.457s postgresql@9.4-main.service
          2.365s postgresql@9.5-main.service
           646ms networking.service
           558ms ModemManager.service
           534ms accounts-daemon.service
           520ms systemd-logind.service
           436ms grub-common.service
           423ms ondemand.service

Switching to xfce4 there is no delay at all on login.

Martin (martinitram) wrote :

Hi,

I have the same problems (Kubuntu 16.10, SDDM, network-manager, notebook with Skylake Core-i3-6100U with external HDMI-Monitor both 1920x1080px). I did some experiments to find the cause:

1. create a new user test2
2. reboot
3. login as test2
4. --> Fast login to the Plasma --> Since network-manager and plasma-applet is running this does not seem to cause the 30s delay

Now I tried out some adjustments in the system setting like
a) Plasma theme
b) start with a empty session
c) show no options in the exit dialogue
and rebooted after each adjustment. The login was fast after them! So, there does not seem to be a general problem with saving Plasma settings.

Then I tried to chase the bug:

5. In system setting I set my external monitor as primary display and disabled the internal notebook monitor.
6. reboot
7. Login as test2 and there is the 30s-delay!
8. Change the display back to internal notebook
9. reboot
7. Login as test2 and there is still the 30s-delay!

Thus, the delay seems not to be caused by network-manager but of the display stuff. But I could not find anything in ~./xsession-erros or /var/log/X.org.log.

Do you know how to debug it?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-nm (Ubuntu):
status: New → Confirmed
Con Kolivas (kernel-kolivas) wrote :

I checked on my desktop PC as well which has the login lag and systemd-analyze blame gave me these top 10 with the same first candidate:

          7.851s NetworkManager-wait-online.service
           303ms apt-daily.service
           239ms dev-sda2.device
           223ms upower.service
           214ms systemd-fsck@dev-disk-by\x2duuid-d697538e\x2d78ed\x2d48f4\x2da3c2\x2d30b660f072ff.service
           169ms media-archer.mount
            88ms networking.service
            88ms systemd-udev-trigger.service
            80ms grub-common.service
            71ms ModemManager.service

Martin (martinitram) wrote :

Hi have similar durations but network-manager does not seem to be the problem (see my comment #1):

          5.978s NetworkManager-wait-online.service
          3.531s apt-daily.service
          2.433s swapspace.service
           490ms dev-sdb6.device
           244ms systemd-fsck@dev-disk-by\x2duuid-6e37a172\x2d531f\x2d4398\x2daa33\x2d12c289e40e7d.service
           204ms networking.service
           192ms accounts-daemon.service
           147ms ofono.service
           146ms systemd-logind.service
           138ms thermald.service
           138ms NetworkManager.service

Martin (martinitram) wrote :

And I even deinstalled all network-manager (including plasma widget), rebootet, but the 30s problem still existed.

Con Kolivas (kernel-kolivas) wrote :

I'm not sure what other debugging info I can add then to help find the cause.

Hannes Koller (hannes-koller) wrote :

I also have the same symptoms (Kubuntu 16.04, all packages up to date):

Upon login the progress bar fills quickly (3-4 seconds to reach 100%) and then there is a long pause (>20 seconds) before the desktop finally appears. However, when I run systemd-analyze blame there is no obvious culprit:

           876ms systemd-rfkill.service
           338ms dev-sda1.device
           222ms networking.service
           199ms ModemManager.service
           195ms accounts-daemon.service
           171ms gpu-manager.service
           162ms thermald.service
           161ms NetworkManager.service
           145ms upower.service
           145ms grub-common.service
           143ms plymouth-quit.service
           134ms systemd-logind.service
           129ms avahi-daemon.service
           105ms irqbalance.service
           104ms preload.service
            92ms apport.service

I would be happy to provide more information, to help get rid of this annoyance.

summary: - Slow login to kde5 waiting on networkmanager
+ Slow login to kde5 waiting on ?networkmanager

Hi,

I have the same problem. It wasn't there in the beginning (upgrade from 14.04) but started after some days.

Indeed, it seems to be related to display stuff as @martinitram wrote in comment #1. At least I notice some display flickering within the ~30s delay.

Mike (skwawks) wrote :

Same issue here. I notice that I can alt+tab and see the desktop, but when i release it remaints at splash. Additionally, I can use key-triggers to load apps, hit the SUPER key, etc. as normal; but the splash screen just remains in the foreground.

Same issue for me as well. Staring KDE used to take a few seconds, now it's 30. systemd-analyze critical-chain gives the following:

graphical.target @7.949s
└─multi-user.target @7.948s
  └─apache2.service @6.821s +1.127s
    └─network-online.target @6.810s
      └─NetworkManager-wait-online.service @965ms +5.845s
        └─NetworkManager.service @822ms +126ms
          └─dbus.service @793ms
            └─basic.target @769ms
              └─sockets.target @769ms
                └─snapd.socket @761ms +909us
                  └─sysinit.target @757ms
                    └─apparmor.service @699ms +57ms
                      └─local-fs.target @697ms
                        └─run-user-118.mount @1.507s
                          └─local-fs-pre.target @309ms
                            └─systemd-remount-fs.service @288ms +16ms
                              └─system.slice @170ms
                                └─-.slice @168ms

Kubuntu 16.04 (64-bit)
KDE Plasma 5.5.5
Qt 5.5.1
Kernel: 4.4.0-28-generic
Hardware: Lenovo Thinkpad E560, with HD panel

Mike (skwawks) wrote :

latest kernel seems to have solved this issue for me. No longer have a splash screen:

4.4.0-28-generic

Looking into my syslog, I get a whole lot of messages like this while loading KDE, but also after. Maybe that is related to the problem?

org.kde.KScreen[1375] kscreen: Primary output changed from KScreen::Output(Id: 67 , Name: "eDP1" ) ( "eDP1" ) to KScreen::Output(Id: 67 , Name: "eDP1" ) ( "eDP1" )

It seems that kscreen is constantly resetting my screen with itself as the default output.

Hannes Koller (hannes-koller) wrote :

Unfortunately the latest kernel (4.4.0-28-generic) has not fixed the issue on my machine.

Kubuntu 16.04 (64-bit)
Qt: 5.5.1
KDE Frameworks: 5.18.0
Kernel: 4.4.0-28-generic
Hardware: Lenovo Ideapad Y580

Hannes Koller (hannes-koller) wrote :

I just discovered a simple workaround for the problem: disable the splash screen (System Settings -> Workspace Theme -> Splash Screen -> Set Theme to "None").

Now the KDE Desktop shows instantly after I login and everything is working immediately (including the network). Could this be a problem with the Breeze Splash Screen Theme?

Martin (martinitram) wrote :

Setting the Splash Screen from "Breeze" to "None" solved my problem, too! So, it is not the problem of network manager (to which this bug is currently assigned to). Do we want to move this bug report to Breeze?

no longer affects: plasma-nm (Ubuntu)
summary: - Slow login to kde5 waiting on ?networkmanager
+ Slow login to kde5 waiting on breeze splash
no longer affects: breeze-qt4 (Ubuntu)
Con Kolivas (kernel-kolivas) wrote :

Confirmed this fixes it for me too. I've removed plasma-nm from the affected packages and added breeze.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in breeze (Ubuntu):
status: New → Confirmed
Hervé Le Roy (hleroy) wrote :

Hannes Koller workaround is working for me too.

Switching off the splash screen has the same effect here. Plasma is ready to use within seconds.

tags: added: xenial
Changed in breeze (Ubuntu):
importance: Undecided → High
sciubarba (daniele-barbarossa) wrote :

I tried to execute this shell script at startup

sleep 5

echo 'password' | sudo -S pkill sddm-greeter

I wanted to see the splahscreen animation but kill that process after a 5 seconds delay, but i got no effect.

I'm not shure if that is the correct process name...

dusoft (dusoft-staznosti) wrote :

Still happening with Plasma 5.5.5 and Breeze splash screen seems to be the issue as switching to 'None' takes no time to login.

Jan Kalmar (mr-pytagoras) wrote :

I get this on ubuntu 16.04 with plasma 5.8 and also on opensuse tumbleweed with plasma 5.9.2, so it is a general KDE plasma5 problem. Setting the splash to none solved it for now.

Martin (martinitram) wrote :

bug is fixed for some time

Changed in breeze (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers