Not exiting properly? "An instance of Brasero is already running, exiting"

Bug #907311 reported by Martin Brook on 2011-12-21
158
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Medium
brasero (Arch Linux)
New
Undecided
Unassigned
brasero (Ubuntu)
Undecided
Unassigned

Bug Description

After successfully burning an ISO file (by clicking on it in nautilus) I am unable to burn any more. Double-clicking ISO files has no effect. Running brasero from the launcher does nothing. If I open a terminal to run brasero, I get:

$ brasero

** (brasero:4117): WARNING **: An instance of Brasero is already running, exiting

The only solution is to

$ killall brasero

(Edit to add: there is no icon in the dock(?) indicating that brasero is running, and alt-tab does not show it, so I can't switch to it).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: brasero 3.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic-pae 3.0.9
Uname: Linux 3.0.0-14-generic-pae i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Wed Dec 21 12:14:15 2011
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: brasero
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (67 days ago)

Martin Brook (martin.brook) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in brasero (Ubuntu):
status: New → Confirmed
Cefn (6-launchpad-net-cefn-com) wrote :

This is very serious, as for most users it would mean CD burning is entirely impossible.

It seems to be associated with either...
* having run Brasero to burn a CD with the windowed client within the same session
* allowing automount behaviour to trigger Brasero with the Nautilus-embedded client

I suspect it's to do with the automount behaviour, which is presumably an 'instance' of Brasero which someone thinks is more easy to use than the client itself (by dragging and dropping files). This doesn't cut it for burning ISOs though.

tags: added: precise quantal
Jérôme Poulin (jeromepoulin) wrote :

Also affects ArchLinux and Ubuntu Raring

Jérôme Poulin (jeromepoulin) wrote :

Forgot the URL for ArchLinux, https://bugs.archlinux.org/task/32503

Len Ovens (len-ovenwerks) wrote :

Here we see the problem with marking bugs as duplicates. It may be helpful to see the comments in the duplicate bug reports. This is something that happens when brasero is started as context. (as stated above) The problem is that the dialog that then opens expects that it was opened from the main window and so doesn't exit when it closes... but there is no main window open to exit from. There needs to be a wrapper around context use that does that... sort of an invisible main window that exits brasero when the context dialog exits.

Mike Ferreira (mafoelffen) wrote :

I am one of those "duplicates" joining this bug as directed, because someone pointed my bug report as a duplicate to this one.

Of note- I have a work-around. I noticed that after I run Brasero and exit, the process is still running. That is why it is not starting a "new" instance of Brasero.

So my fix is to bring up a terminal session <cntrl><alt<T>... Type in:

pidof Brasero

It will return the process ID of four digits long. For example: 8573. If the returned process ID where 8573, then you would type in:

kill 8573

to end that process. Once that process is killed, Brasero will run again.

Note that this is a work-around. You have to kill the process manually, because brasero is not really exiting "gracefully." In fact since it still has a process ID, itis really "not exiting..." Therefore the problem.

emptythevoid (emptythevoid) wrote :

I've been dealing with this bug since 12.04. I just freshly installed 13.04 64-bit on my main machine and if I double-click on an ISO and Brasero opens to burn it, even if I just cancel out of that window, brasero remains running and does not exit on it's own. This prevents being able to open brasero again until one kills the running instance. This is a show-stopper. Seriously needs to be fixed, or change the default app for burning ISOs.

rooijan (rrossouw) wrote :

emtythevoid: Have you tried what I suggested here:
https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/1078928

Not sure if it fix later versions but it worked for me in 12.10. Needs to be fixed upstream but at least this fix removes some frustration...

Sepero (cowpie2000) wrote :

Thanks for that, rooijan. It seems to work for me.

Jérôme Poulin (jeromepoulin) wrote :

I confirm this problem is still present in Ubuntu 13.10 alpha 2. The fix should be trivial but I didn't bother to get the source and fix it yet. Is there still a maintainer on Brasero?

ziotibia81 (ziotibia1) wrote :

A related iusse is this:

I have a PC with two cd burner.
I want to burn two CD or DVD at the same time.

I run the first Brasero and start to burn.
I run the second Brasero and the error is :

** (brasero:5478): WARNING **: An instance of Brasero is already running, exiting

So burn two disks at the same time I have to user thers tools (es wodim)

This happens in Ubuntu 13.04

Silviu C. (silviucc) wrote :

Hi,

This bug has been fixed upstream. This is the commit:

https://git.gnome.org/browse/brasero/commit/?id=f122ee0620380b7c21edce722cfe347f10c8c827

Any chance this will get in either LTS or Raring (hopefully both) ?

Barry Drake (b-drake) wrote :

The bug is still present in Trusty ..... For an essential default application inUbuntu, this really needs fixing.

Changed in brasero:
importance: Unknown → Medium
status: Unknown → Fix Released
houstonbofh (leesharp) wrote :

How can this still be bugged when the fix is so easy?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.