Brasero can't select DVD drive to burn image

Bug #848340 reported by Federico Vera on 2011-09-12
116
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Brasero
Confirmed
Medium
brasero (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned

Bug Description

[Impact]
When trying to burn an image using brasero (or selecting the drive to write to using libbrasero from any application using it) doesn't allow to select the drive (the drive appears on the list, but it can't be selected), thus making writing a DVD/CD impossible, which is a major regression from the previous releases.

[Development fix]
The fix has been committed upstream at GNOME, see the commit [1] in GNOME git imported in launchpad as revision 3422 of the brasero master branch [2]

[Stable fix]
Applying the changes from the commit mentioned above to the 3.2.0 version retrieved with apt-get source from oneiric fixes the problem.

[Test case]
Right-click an ISO file and select Open with Brasero Disc Burner, with a Blank Disc in you CD/DVD+-RW drive, and try to select the drive to write the ISO file to. Before applying the patch, you will not be able, the combo will remain empty even after selecting the drive, but after applying the commit, you are able to select the drive and write the iso file to it.

[Regression potential]
I am not aware of any potential issues.

[1] http://git.gnome.org/browse/brasero/commit/?id=f9d1053a648110efbeb02bee6ee162eaaa809306
[2] http://bazaar.launchpad.net/~vcs-imports/brasero/master/revision/3722

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: brasero 3.1.90-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Mon Sep 12 18:39:03 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
SourcePackage: brasero
UpgradeStatus: No upgrade log present (probably fresh install)

Federico Vera (fedevera) wrote :
Brian D. Myers (tyrjorgennson) wrote :

same issue

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in brasero (Ubuntu):
status: New → Confirmed
ysNoi (ysnoi.ravemaster) wrote :

I have the same problem on my system Oneiric...

yossarian_uk (morgancoxuk) wrote :

Same here - tried 2 different DVD burners - they work in Arch linux (KDE4) and Winblows XP.

Also - k3b is not able to burn an .iso in Ubuntu 11.10

sok (kooskutschruiter) wrote :

It's likewise here, and burning an image results in a bin file.

Robert Roth (evfool) on 2011-11-17
Changed in brasero (Ubuntu):
importance: Undecided → Medium
Robert Roth (evfool) on 2011-11-17
Changed in brasero (Ubuntu):
status: Confirmed → Triaged
Robert Roth (evfool) on 2011-11-17
description: updated
Changed in brasero:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in brasero (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Low
Changed in brasero (Ubuntu):
importance: Medium → Low
Sebastien Bacher (seb128) wrote :

Thank you for your work, I've uploaded the fix to precise to start, it should still be sru-ed when somebody has the time to do the sru for it though

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 3.2.0-0ubuntu5

---------------
brasero (3.2.0-0ubuntu5) precise; urgency=low

  * debian/patches/git_drive_selection.patch: correctly display the default
    drive as selected, thanks "Fido" and Robert Roth (lp: #848340)
 -- Sebastien Bacher <email address hidden> Fri, 16 Dec 2011 16:46:05 +0100

Changed in brasero (Ubuntu):
status: Triaged → Fix Released
globalkeith (keithsalisbury) wrote :

This is NOT fixed

photonmedia (photonmedia) wrote :

As of today with all latest updates installed this is still an issue. See attachments.

Nautilus recognizes the blank CD for me to drag files to it, but if I right-click an ISO and choose "Write to Disc" the combo box where I choose the disc to write to is empty. You can still choose the "empty" space and click Burn and it works, but this is still a bug as it does not show the disc therefore making it seem as if it will not allow you to burn.

Bryce Harrington (bryce) on 2012-01-27
description: updated

Hello Fido, or anyone else affected,

Accepted brasero into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in brasero (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Federico Vera (fedevera) wrote :

I' ve test it with:

brasero-common_3.2.0-0ubuntu1.1
brasero-cdrkit_3.2.0-0ubuntu1.1
brasero_3.2.0-0ubuntu1.1..
libbrasero-media3-1_3.2.0-0ubuntu1.1

and it didn't work, as a matter of fact now the buttons disapeared from the dialog ('Properties', 'Cancel', 'Burn Several copies', 'Burn'), they reappear only when the mouse pointer passes over the place where the buttons are supposed to be.

And a as a secondary bug (I can't remember if it was always like this), everytime you close the application in order to open it again you need to kill brasero. (Perhaps this should be another bug)

Confirmed, this doesn't work: the combo box remains blank. Marking as verification-failed (and should be tested on precise too again since it probably reacts just the same there too).

tags: added: verification-failed
removed: verification-needed

Please disregard the ravings of a lunatic. I did it all wrong, it obviously works properly... I didn't have the updated packages installed :)

tags: added: verification-done
removed: verification-failed
tags: added: verification-needed
removed: verification-done
Federico Vera (fedevera) wrote :

It's still isn't working for me, in oneiric and precise...

Thibault D (thibdrev) wrote :

I am not sure that we get the right package "brasero - 3.2.0-0ubuntu5" in Oneiric.
With oneiric-proposed enabled I still get "brasero - 3.2.0-0ubuntu1.1"

edu jose (pepinmore) wrote :

It works for me.

Now the combo box for selecting the destination disk is filled, not empty. Writing the alpha-2 image to a DVD-R works.

Ok, after all is well and finished brasero process stays around, but this is another bug I suppose.

Using ubuntu 11.10 Oneiric (i386) and "brasero - 3.2.0-0ubuntu1.1" from oneiric-proposed.

Martin Pitt (pitti) on 2012-02-13
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 3.2.0-0ubuntu1.1

---------------
brasero (3.2.0-0ubuntu1.1) oneiric-proposed; urgency=low

  [ Robert Roth ]
  * Select a device by default for burning (LP: #848340)
 -- Luke Yelavich <email address hidden> Wed, 25 Jan 2012 13:24:36 +1100

Changed in brasero (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in brasero:
status: Fix Released → Confirmed
Stam Atis (stamatis5000) wrote :

When you insert a cd-dvd tell the dialog window to do something. (Open brasero or Kb3 etc)
If you choose "DO NOTHING" then it cannot detect the empty cd - dvd.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.