When I try burning DVDs it ejects and say that it's impossible to link plugin pads.

Bug #720466 reported by Samson Jean on 2011-02-17

This bug report was converted into a question: question #145678: When I try burning DVDs it ejects and say that it's impossible to link plugin pads..

112
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Brasero
Confirmed
Medium
brasero (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: brasero

That's it

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: brasero 2.32.0-0ubuntu2.2
ProcVersionSignature: Ubuntu 2.6.35-27.47-generic 2.6.35.11
Uname: Linux 2.6.35-27-generic i686
Architecture: i386
Date: Wed Feb 16 19:18:25 2011
ExecutablePath: /usr/bin/brasero
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: brasero
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1555): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1559): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (brasero:2096): GLib-CRITICAL **: the GVariant format string `(u)' has a type of `(u)' but the given value has a type of `()'
 (brasero:2096): GLib-CRITICAL **: g_variant_get: assertion `valid_format_string (format_string, TRUE, value)' failed

Samson Jean (samsonjean225) wrote :
Changed in brasero (Ubuntu):
status: New → Invalid
Changed in brasero (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in brasero (Ubuntu):
status: New → Confirmed
Daniël van Eeden (dveeden) wrote :
Daniël van Eeden (dveeden) wrote :
Daniël van Eeden (dveeden) wrote :

To reproduce:
1. Start Brasero
2. Choose video project
3. Add a .dvd file which is produced with OpenShot (DVD-PAL export)
4. Click Burn…
5. Set disk image type to "Video DVD image" and choose "Native format" and "4:3"
6. Click create image

Brasero calles "/usr/bin/genisoimage -input-charset utf8" which generates an error if I try it.

------------------------------------------------------------------
$ /usr/bin/genisoimage -input-charset utf8
/usr/bin/genisoimage: Missing pathspec.
Usage: genisoimage [options] -o file directory ...

Use genisoimage -help
to get a list of valid options.

Report problems to <email address hidden>.
------------------------------------------------------------------

Daniël van Eeden (dveeden) wrote :

The brasero_vob_error_on_pad_linking in plugins/transcode/burn-vob.c is only called by brasero_vob_new_decoded_pad_cb. This could have something to do with PulseAudio.

Daniël van Eeden (dveeden) wrote :

According to gst-typefind these are the types for the file I tried to burn:
video/mpeg, systemstream=(boolean)true, mpegversion=(int)2

Nokir (nokir) wrote :

When I start brasero with 'GST_DEBUG="*:3" brasero -g', I get the following:

0:00:10.984295768 16466 0xf36580 INFO GST_PADS gstpad.c:1978:gst_pad_link_prepare: trying to link capsfilter1:src and ffenc_ac31:sink
0:00:10.985340524 16466 0xf36580 INFO GST_PADS gstpad.c:2034:gst_pad_link_prepare: caps are incompatible
BraseroBurn: (at burn-vob.c:684) BraseroVob Error while linking pads

'gst-inspect-0.10 ffenc_ac3' gives me:

  SINK template: 'sink'
    Availability: Always
    Capabilities:
      audio/x-raw-float
               channels: [ 1, 6 ]
                   rate: { 48000, 44100, 32000 }
             endianness: 1234
                  width: 32

I looked into plugins/transcode/burn-vob.c near line 684 and found out that the capsfilter pad was set to use audio/x-raw-int, which is not compatible with ffenc_ac3. So I made the following change to that file:

@@ -638,7 +638,7 @@
  BRASERO_JOB_LOG (vob, "Setting AC3 rate to 48000");
  /* NOTE: we may want to limit the number of channels. */
- filtercaps = gst_caps_new_full (gst_structure_new ("audio/x-raw-int",
+ filtercaps = gst_caps_new_full (gst_structure_new ("audio/x-raw-float",
           "rate", G_TYPE_INT, 48000,
           NULL),
      NULL);

Now 'GST_DEBUG="*:3" brasero -g' shows me:

0:00:44.819663035 16554 0x2459580 INFO GST_PADS gstpad.c:1978:gst_pad_link_prepare: trying to link capsfilter1:src and ffenc_ac31:sink
0:00:44.820746205 16554 0x2459580 INFO GST_PADS gstpad.c:2161:gst_pad_link_full: linked capsfilter1:src and ffenc_ac31:sink, successful

The encoding is starting, but after some megabyte it hangs and the command line doesn't print anything anymore. But this seems to be another bug, since the very same happens if I select SVCD in the unmodified program.

Nokir (nokir) wrote :

I forgot to mention: I tested with Brasero 3.4.1 on Ubuntu 12.04 64bit.

Changed in brasero:
importance: Unknown → Medium
status: Unknown → New
Changed in brasero (Ubuntu):
status: Confirmed → Fix Released
Travis Larson (tlarson) wrote :

This is still an issue in 12.10.

Narcis Garcia (narcisgarcia) wrote :

I've seen this problem today with Ubuntu 12.04 64bit.

Changed in brasero:
status: New → Confirmed
amias (amias) wrote :

this is still a problem in 17:10.

i was trying to burn a 16:9 1920x1080 mp4 video to dvd in pal format.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.