Ubuntu

brasero crashes when trying to install missing packages.

Reported by Marc Deslauriers on 2011-02-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Critical
brasero (Ubuntu)
Undecided
Marc Deslauriers
Maverick
Undecided
Marc Deslauriers
Natty
Undecided
Marc Deslauriers

Bug Description

Binary package hint: brasero

Brasero 2.32.x crashes when trying to copy an audio cd without having cdrdao
installed and the packagekit backend tries to install it.

This happens on natty, and on maverick.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: brasero 2.32.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic x86_64
Architecture: amd64
Date: Mon Feb 14 15:21:36 2011
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 LC_MESSAGES=en_CA.utf8
 SHELL=/bin/bash
SourcePackage: brasero

Marc Deslauriers (mdeslaur) wrote :
Changed in brasero (Ubuntu):
assignee: nobody → Marc Deslauriers (mdeslaur)
status: New → Confirmed
Changed in brasero (Ubuntu Maverick):
status: New → Confirmed
assignee: nobody → Marc Deslauriers (mdeslaur)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.32.1-0ubuntu2

---------------
brasero (2.32.1-0ubuntu2) natty; urgency=low

  * debian/patches/41_fix_packagekit.patch: Don't crash when trying to use
    the packagekit backend to install missing packages, for example, when
    trying to copy an audio cd without having cdrdao installed.
    (LP: #718969)
 -- Marc Deslauriers <email address hidden> Mon, 14 Feb 2011 15:26:59 -0500

Changed in brasero (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in brasero:
importance: Unknown → Medium
status: Unknown → New
Marc Deslauriers (mdeslaur) wrote :

The maverick SRU to fix this issue is being tracked in bug #529696.

Changed in brasero:
importance: Medium → Critical

Accepted brasero into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Changed in brasero (Ubuntu Maverick):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Accepted brasero into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Ignore the "lucid-proposed" message, this only applies to maverick.

Marc Deslauriers (mdeslaur) wrote :

The tester of the maverick -proposed package in bug #529696 (comment #166) successfully tested the packagekit backend that this bug refers to. I am marking this as "verification-done".

tags: added: verification-done
removed: verification-needed
Changed in brasero:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.32.0-0ubuntu2.2

---------------
brasero (2.32.0-0ubuntu2.2) maverick-proposed; urgency=low

  * debian/patches/40_fix_cdrdao_detection.patch: Disable brasero's
    version check of the cdrdao binary, as it incorrectly parses the
    warnings that are printed before the banner. (LP: #529696)
  * debian/patches/41_fix_packagekit.patch: Don't crash when trying to use
    the packagekit backend to install missing packages, for example, when
    trying to copy an audio cd without having cdrdao installed.
    (LP: #718969)
 -- Marc Deslauriers <email address hidden> Mon, 14 Feb 2011 19:46:33 -0500

Changed in brasero (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.