Cannot burn an audio project

Bug #572942 reported by Uqbar on 2010-05-01
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Critical
brasero (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: brasero

It ejects the medium saying: An error occurred.
I attach here the log file I saved afterwise.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: brasero 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
Architecture: amd64
Date: Sat May 1 12:50:34 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=it_IT.utf8
 SHELL=/bin/bash
SourcePackage: brasero

Related branches

Uqbar (uqbar) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for your report, could you get a brasero log? please run brasero as: brasero --brasero-burn-debug --brasero-media-debug &> brasero-debug.txt ; perform the operation to reproduce the bug and attach that resulting log file to the report, thanks.

Changed in brasero (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Uqbar (uqbar) wrote :

I opened that bug on GNOME's bugzilla as there's been no feedback on launchpad!
So everything there applies here.

This tremendous bug is affecting my daily work, though.

Uqbar (uqbar) wrote :

Should I install K3b to be able to burn audio CDs again?

Uqbar (uqbar) wrote :

I just switched to mybashburn which is text mode but works perfectly.
Waiting for a fix ...

Uqbar (uqbar) wrote :

Whis is this bug "incomplete"? What's missing?

Uqbar (uqbar) wrote :

I'm sorry to say that I had to install k3b with almost the entire KDE environment in order to get back a working user friendly
program to burn CDs.
It could sound ridiculous, but the inability to burn CDs was hindering my everyday job!
I wonder when this bug will get the needed attention ...

Uqbar (uqbar) wrote :

It's clear now that none is paying attention to this bug as well as to any other cd burning related ones.
Both k3b and brasero cannot handle properly (like they used to) audio CD projects.
At least, K3b can actually burn an audio CD, but with the wrong pre-gap and post-gap settings. Better than nothing, though.

Changed in brasero (Ubuntu):
status: Incomplete → New
Changed in brasero:
status: Unknown → New
Changed in brasero:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

the issue was fixed upstream and it's divided in two parts: http://git.gnome.org/browse/brasero/commit/?id=c32a885c907e10781159aafc0454f417ecd6af08 ; http://git.gnome.org/browse/brasero/commit/?id=fa8b24102994b5dde894b42b39633dab3ba12332 ; Brasero 2.30.2 should have the fix, we might want to wait for that to be released soon.

Changed in brasero (Ubuntu):
status: New → Fix Committed
Uqbar (uqbar) wrote :

It seems instead that the bug is fixed by upgrading cdrdao to the latest version (1.2.3), which is already 6+ months old.

Uqbar (uqbar) wrote :

Please check the current status in the upstream bug @GNOME.

Changed in brasero:
status: Incomplete → Fix Released
Changed in brasero (Ubuntu Lucid):
importance: Undecided → Low
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :
Uqbar (uqbar) wrote :

How can I use that "debdiff" ?

Colin Watson (cjwatson) wrote :

The debdiff isn't intended for you to use directly - it's part of our stable update review process.

tags: added: verification-needed

Accepted into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Uqbar (uqbar) wrote :

It's not clear to me whether this bug is an Ubuntu specific one or it's a more general GNOME bug.
Or possibly, a scattered one.

Pedro Villavicencio (pedro) wrote :

Uqbar could you test the proposed package as soon as it's available for you? you can enable the proposed repository by running the Software Sources application (System->Administration->Software Sources) or by running software-properties-gtk from the command line. Please test the package and see if that fixes the issue for you and comment back, thanks in advance.

Uqbar (uqbar) wrote :

I will as soon as possible. Later today (CET).

Uqbar (uqbar) wrote :

It actually took more than "a few hors" to have the package available. Anyway ...
The fix worked for me: I could burn an audio CD project starting from 48KHz 16bit WAVs.
I'll try later with a CD copy as well.

What is still puzzling me is that in the plugin window (Modify-->Plugins) I have the following:
1. CD/DVD creation folder: enabled and greyed
2. audio2cue: enabled and greyed
3. cdda2wav: disabled and greyed
4. cdrdao: disabled and greyed
5. cdrecord: disabled and greyed
6. dvd+rw format: enabled and greyed
7. dvdauthor: enabled and greyed
8. dvdcss: enabled and greyed
9. genisoimage: enabled and greyed
A. growisofs. enabled and greyed
B. mkisofs: disabled and greyed
C. readcd: disabled and greyed
D. readom: disabled and greyed
E. transcode: enabled and greyed
F. transcode2vob: disabled and greyed
10. vcdimager: enabled and greyed
11. wodim: enabled and greyed

Is it all right?

Pedro Villavicencio (pedro) wrote :

It is if you have those plugins installed, if that's a bug it's a separate one, marking this as verification done then since you confirmed the issue is fixed there with the proposed package, thanks in advance.

tags: added: verification-done
removed: verification-needed
Uqbar (uqbar) wrote :

Copying an audio disk (previously created with brasero) doesn't work.
Brasero offered me to save a session log file but it turned out to be empty.

Uqbar (uqbar) wrote :

I am also reporting some extra debugging done with:
brasero --brasero-burn-debug --brasero-media-debug &> brasero-debug.txt

on the very same operation.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.30.1-1ubuntu1

---------------
brasero (2.30.1-1ubuntu1) maverick; urgency=low

  * Rebase on Debian unstable, remaining Ubuntu changes:
  * debian/control.in:
    - Set build-depend version on libgconf2-dev
    - Build-depend on libappindicator-dev
    - Build-depend on liblaunchpad-integration-dev
    - Bump Standards-Version
    - Set Vcs-Bzr info
    - libbrasero-media0 suggests instead of recommends gstreamer0.10-plugins-ugly
      and cdrdao
    - libbrasero-media0 suggests gstreamer0.10-fluendo-mp3
    - Bump libbrasero-media-dev depends for libglib2.0-dev and libgtk2.0-dev
    - libbrasero-media0 replaces brasero (plugins moved from this package)
  * debian/rules:
    - Run autoconf on build
  * debian/patches/010_lpi.patch:
    - Add launchpad-integration
  * debian/patches/011_nautilus_menu_move.patch
    - Moved the CD/DVD Creator menu item to Accessories
  * debian/patches/012_appindicator.patch:
    - Support application indicator
  * debian/patches/90_git_audio_project_creation.patch,
    debian/patches/91_git_audio_project_creation.patch:
    - git change to fix recording an audio project, which is what rhythmbox is
      using to record playlist for example (lp: #543892)
  * debian/patches/92_git_audio_cd_recording.patch:
    - git change to fix recording of audio cds, there is another git change
      which might be required to fix similar issues but it's not trivial so
      let's get that change in a first update for now (lp: #572942)
  * debian/patches/93_git_new_caps_function_definition.patch:
    - don't forget the git commit which define the function which is used
      in the previously uploaded revision
  * debian/watch:
    - Watch for unstable versions
 -- Robert Ancell <email address hidden> Mon, 31 May 2010 17:41:56 +1000

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
Uqbar (uqbar) wrote :

Brasero cannot still copy audio CDs!

papukaija (papukaija) wrote :

@Uqbar: Please open a new bug for that issue since it's not related to this bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.30.1-0ubuntu2

---------------
brasero (2.30.1-0ubuntu2) lucid-proposed; urgency=low

  * debian/patches/93_git_new_caps_function_definition.patch:
    - don't forget the git commit which define the function which is used
      in the previously uploaded revision

brasero (2.30.1-0ubuntu1) lucid-proposed; urgency=low

  * debian/patches/90_git_audio_project_creation.patch,
    debian/patches/91_git_audio_project_creation.patch:
    - git change to fix recording an audio project, which is what rhythmbox is
      using to record playlist for example (lp: #543892)
  * debian/patches/92_git_audio_cd_recording.patch:
    - git change to fix recording of audio cds, there is another git change
      which might be required to fix similar issues but it's not trivial so
      let's get that change in a first update for now (lp: #572942)

  [ Robert Ancell ]
  * New upstream release:
    - Add support for Tracker 0.8.x
    - brasero-rename.c: Fix signedness issues by assigning proper types
    - Harden code by checking for callback value being a BRASERO_PROJECT
    - Fix for Bug 578068 - Brasero does not check for free space before copying disc
    - Many updated translations
 -- Sebastien Bacher <email address hidden> Thu, 27 May 2010 19:20:52 +0200

Changed in brasero (Ubuntu Lucid):
status: Fix Committed → Fix Released
Uqbar (uqbar) wrote :

In Lucid-proposed there seems not to be such a release despite I've enabled the proposed repository.

~ apt-cache show brasero

Package: brasero
Priority: optional
Section: gnome
Installed-Size: 1140
Maintainer: Ubuntu Desktop Team <email address hidden>
Original-Maintainer: Pedro Fragoso <email address hidden>
Architecture: amd64
Version: 2.30.2-0ubuntu1
...

Uqbar (uqbar) wrote :

The package brasero (2.30.1-0ubuntu2) in lucid-proposed doesn't exist yet!
I understand that it has been set as urgency=low, but it's 10 days now!

~ apt-cache showpkg brasero
Package: brasero
Versions:
2.30.2-0ubuntu1 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid-updates_main_binary-amd64_Packages
                  MD5: 22e3ea6ae2a0d32987596d090c611bf1

2.30.0-0ubuntu1 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_main_binary-amd64_Packages
                  MD5: 22e3ea6ae2a0d32987596d090c611bf1

Changed in brasero:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.