brasero calls kpackagekit for finding toc2cue

Bug #570787 reported by staedtler-przyborski on 2010-04-27
76
This bug affects 18 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: brasero

brasero 2.30 calls kpackagekit instead of synaptic to find toc2cue if cdrdao is not installed

Sebastien Bacher (seb128) wrote :

Thank ou for your bug report, could you describe how to trigger the bug? Where do you click exactly?

Changed in brasero (Ubuntu):
status: New → Incomplete
importance: Undecided → Low

"could you describe how to trigger the bug? Where do you click exactly?"

I wanted to 1:1 copy a CD. Brasero thought that toc2cue is missing (Indeed I hadn't installed cdrdao). So it started to my surprise kpackagekit for searching the binary (and failed).

kpackagekit is installed, cause I've some KDE-Applications (e.g. digikam) on the Gnome Desktop

After installing cdrdao manually - using synaptic - I got https://bugs.launchpad.net/bugs/570785

Garbor (garbor) wrote :

I can confirm this, i had the same issue, a few minutes ago, just trying to copy an audio CD.

Thank you for the workaround "installing cdrdao manually".

Gilbert Dion (diong) wrote :

I wanted to copy a music CD with Brasero and it started to search for missing packages (toc2cue and cdda2wav) but could not find them. Then it suggested that I install them manually. But these do not exist in Synaptic.
Brasero was running ok in Karmic. I tried on a upgraded Lucid and a freshly installed Lucid with the same result.

Gilbert Dion (diong) wrote :

I forgot to mention that cdrdao is already installed, but it stills uses kpackagekit to search for toc2cue and cdda2wav.

Confirming...

To reproduce (on 64bit Lucid):
1) Right click CD in Computer view;
2) Choose 'Copy disc...';
3) Change 2nd drop-down to 'Image file';
4) Click 'Create image' button.
5) Get the error message:
All required applications and libraries are not installed.

Please install the following manually and try again:
toc2cue (application)
cdrdao (application)

And then in terminal...
>$ sudo apt-get install toc2cue cdrdao
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package toc2cue

Changed in brasero (Ubuntu):
status: Incomplete → Confirmed

Sorry all... I think I wanted #529696, though the bugs look like they have the same root cause.

In synaptic there is cue2toc so maybe the call from Brasero is to the wrong library?

Intstalled cue2toc and cdrdao via synaptic, so cdrdao is installed now, still Brasero says that cdrdao is not installed when I want to create an image or copy of an audio cd.
I am using 64bit Lucid on AMD64.
Last Tuesday I ran into the same problem installing 32bit Lucid on a Dell 4500 P4 PC, just to make a copy of that very Live CD I used to install and got the error also: Missing toc2cue and cdrdao...

Ditto #6.

Tried various workarounds: installed cdrdao and cuetools then also cdda2wav.

Brasero's 1:1 disk copy still doesn't work, just creates the following log:
"Checking session consistency (brasero_burn_check_session_consistency brasero-burn.c:1741)
Unsupported type of task operation
Session error : An internal error occurred (brasero_burn_record brasero-burn.c:2839)"

Trevor (trevorwood6) wrote :

Hi all trying to copy a simple music cd, with brasero am using Ubuntu 10.10l.
getting the three lines up need to download the
1/ cdda2wav
2/ cdrdo
3/ cdrdo

all three or application files, looked on senaptic packager as well as the
normal ubuntu updater.

I am new to linux so still learning, but impressed with it so far.

Trevor

Petux (pe8er) wrote :

Ureeka! - just found the answer to the bug!!

The reported missing package is toc2cue - but actually it should read cue2toc. So the command to install should be

 # sudo apt-get install cue2toc

Have also installed the cdrdao package

Hope that helps some...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers