brasero crashed with SIGSEGV in brasero_data_project_remove_node()

Bug #561319 reported by Michael Maxwell on 2010-04-12
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Critical
brasero (Ubuntu)
Medium
Unassigned
Lucid
Medium
Didier Roche

Bug Description

Binary package hint: brasero

Ubuntu 10.04 Beta
Adding files to a compilation to burn Data Cd.
I was attempting to combine a group of files already added to a new folder for organizational purposes.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: brasero 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Apr 12 05:17:48 2010
ExecutablePath: /usr/bin/brasero
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcCmdline: /usr/bin/brasero
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7ffab2f4b65e <brasero_data_project_remove_node+46>: testb $0x20,0x29(%rbp)
 PC (0x7ffab2f4b65e) ok
 source "$0x20" ok
 destination "0x29(%rbp)" (0x00000029) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: brasero
StacktraceTop:
 brasero_data_project_remove_node ()
 brasero_track_data_cfg_remove ()
 ?? ()
 ?? ()
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
Title: brasero crashed with SIGSEGV in brasero_data_project_remove_node()
UserGroups: adm cdrom dialout dip fax floppy fuse plugdev tape video

Michael Maxwell (madmax747) wrote :

StacktraceTop:
 brasero_data_project_remove_node (self=0xffb900, node=0x0)
 brasero_track_data_cfg_remove (
 brasero_data_disc_delete_selected (
 brasero_data_disc_key_released_cb (
 _gtk_marshal_BOOLEAN__BOXED (closure=0x1316bf0,

Changed in brasero (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugzilla.gnome.org/show_bug.cgi?id=615526

Changed in brasero (Ubuntu):
status: New → Triaged
Changed in brasero:
status: Unknown → New
Changed in brasero:
status: New → Fix Released
Pedro Villavicencio (pedro) wrote :
Changed in brasero (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) wrote :

uploaded in -proposed:

brasero (2.30.2-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release
    - Lot's of memleak fixes
    - Fixed a runtime warning related to cancelling tracker searches
    - Crash in brasero_data_project_node_removed at
      brasero-data-project.c:1163
    - brasero crashed with SIGSEGV in brasero_data_project_remove_node()
      (LP: #561319)
    - Fix a few runtime warnings with the Cover Editor
    - Text in cover editor does not show up automatically (LP: #469459)
    - Removed use of deprecated flags
    - Use accessor functions instead direct access (use GSEAL GnomeGoal)
    - Fix a bug in the layout on first start (side pane was hidden and
      remained so until the user moved it)
    - Save printer settings for cover printing
    - Write the contents of the GtkTextBuffer displayed line by displayed
      line which should improve the layout
    - "Write to Disc" button sensitivity regression
    - Fix flaw in mask that led libburn plugin not to work (not to be picked
      up actually) in some circumstances
    - Fails to burn ANY audio project
    - Move columns doesn't work (LP: #581759)
    - Brasero does not correctly handle double clicking on column separators
      (LP: #581885)
    - Bad info when burning, high CPU usage and slow burn
    - Change the priority for cdrdao and raised the one of cdda2wav plugin
    - brasero crashed with SIGSEGV in
      brasero_mmc3_get_performa nce_wrt_spd_desc() (LP: #564766)
    - brasero crashed with SIGSEGV in brasero_scsi_command_issue_sync()
      (LP: #444832)
    - Do not check for symlinks on cdda2wav so the plugin can use icedax.
    - Brasero's failure with some file names (LP: #380643)
    - Pressing create audio cd does nothing
    - Empty project not available
    - can't actually save error logs
    - doesn't handle incorrect temp dirs properly
    - Fix multi DND in GtkFileChooser
    - Displays "starting to record" during whole burn process
    - Fix wrong report of speed with both cdrecord and wodim
    - Disk project doesn't save the disk title (LP: #587924)
    - Brasero reports outdated cdrtools on cdrtools-3.00 (LP: #592075)
    - misc bug fixes
    - Updated Translations
  * Removed upstream patches:
    - debian/patches/90_git_audio_project_creation.patch,
      debian/patches/91_git_audio_project_creation.patch,
      debian/patches/92_git_audio_cd_recording.patch,
      debian/patches/93_git_new_caps_function_definition.patch
  * debian/patches/99_autoconf.patch:
    - refreshed

Test case:
- install the package from lucid-proposed and check you have 2.30.2-0ubuntu1
- try to burn a data and an audio CD and check everything is fine
- check that bugs mentioned in the above changelog are fixed too and comment on each bug report
Thanks!

Didier Roche (didrocks) on 2010-06-24
Changed in brasero (Ubuntu Lucid):
status: New → Triaged
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → Wishlist
importance: Wishlist → Medium

Accepted brasero into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in brasero (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.30.2-0ubuntu2

---------------
brasero (2.30.2-0ubuntu2) maverick; urgency=low

  * New upstream release
    - Lot's of memleak fixes
    - Fixed a runtime warning related to cancelling tracker searches
    - Crash in brasero_data_project_node_removed at
      brasero-data-project.c:1163
    - brasero crashed with SIGSEGV in brasero_data_project_remove_node()
      (LP: #561319)
    - Fix a few runtime warnings with the Cover Editor
    - Text in cover editor does not show up automatically (LP: #469459)
    - Removed use of deprecated flags
    - Use accessor functions instead direct access (use GSEAL GnomeGoal)
    - Fix a bug in the layout on first start (side pane was hidden and
      remained so until the user moved it)
    - Save printer settings for cover printing
    - Write the contents of the GtkTextBuffer displayed line by displayed
      line which should improve the layout
    - "Write to Disc" button sensitivity regression
    - Fix flaw in mask that led libburn plugin not to work (not to be picked
      up actually) in some circumstances
    - Fails to burn ANY audio project
    - Move columns doesn't work (LP: #581759)
    - Brasero does not correctly handle double clicking on column separators
      (LP: #581885)
    - Bad info when burning, high CPU usage and slow burn
    - Change the priority for cdrdao and raised the one of cdda2wav plugin
    - brasero crashed with SIGSEGV in
      brasero_mmc3_get_performa nce_wrt_spd_desc() (LP: #564766)
    - brasero crashed with SIGSEGV in brasero_scsi_command_issue_sync()
      (LP: #444832)
    - Do not check for symlinks on cdda2wav so the plugin can use icedax.
    - Brasero's failure with some file names (LP: #380643)
    - Pressing create audio cd does nothing
    - Empty project not available
    - can't actually save error logs
    - doesn't handle incorrect temp dirs properly
    - Fix multi DND in GtkFileChooser
    - Displays "starting to record" during whole burn process
    - Fix wrong report of speed with both cdrecord and wodim
    - Disk project doesn't save the disk title (LP: #587924)
    - Brasero reports outdated cdrtools on cdrtools-3.00 (LP: #592075)
    - misc bug fixes
    - Updated Translations
  * Removed upstream patches:
    - debian/patches/90_git_audio_project_creation.patch,
      debian/patches/91_git_audio_project_creation.patch,
      debian/patches/92_git_audio_cd_recording.patch,
      debian/patches/93_git_new_caps_function_definition.patch
  * debian/rules, debian/control.in:
    - use dh-autoreconf to launch autoreconf on build
 -- Didier Roche <email address hidden> Mon, 28 Jun 2010 10:33:09 +0200

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
Pedro Villavicencio (pedro) wrote :

I cannot reproduce the original crash on this report but i can confirm that the proposed package is working fine, I've been using it for a couple of days and cd burning works ok, no regressions were noticed, marking this as verification done, thanks all.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.30.2-0ubuntu1

---------------
brasero (2.30.2-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release
    - Lot's of memleak fixes
    - Fixed a runtime warning related to cancelling tracker searches
    - Crash in brasero_data_project_node_removed at
      brasero-data-project.c:1163
    - brasero crashed with SIGSEGV in brasero_data_project_remove_node()
      (LP: #561319)
    - Fix a few runtime warnings with the Cover Editor
    - Text in cover editor does not show up automatically (LP: #469459)
    - Removed use of deprecated flags
    - Use accessor functions instead direct access (use GSEAL GnomeGoal)
    - Fix a bug in the layout on first start (side pane was hidden and
      remained so until the user moved it)
    - Save printer settings for cover printing
    - Write the contents of the GtkTextBuffer displayed line by displayed
      line which should improve the layout
    - "Write to Disc" button sensitivity regression
    - Fix flaw in mask that led libburn plugin not to work (not to be picked
      up actually) in some circumstances
    - Fails to burn ANY audio project
    - Move columns doesn't work (LP: #581759)
    - Brasero does not correctly handle double clicking on column separators
      (LP: #581885)
    - Bad info when burning, high CPU usage and slow burn
    - Change the priority for cdrdao and raised the one of cdda2wav plugin
    - brasero crashed with SIGSEGV in
      brasero_mmc3_get_performa nce_wrt_spd_desc() (LP: #564766)
    - brasero crashed with SIGSEGV in brasero_scsi_command_issue_sync()
      (LP: #444832)
    - Do not check for symlinks on cdda2wav so the plugin can use icedax.
    - Brasero's failure with some file names (LP: #380643)
    - Pressing create audio cd does nothing
    - Empty project not available
    - can't actually save error logs
    - doesn't handle incorrect temp dirs properly
    - Fix multi DND in GtkFileChooser
    - Displays "starting to record" during whole burn process
    - Fix wrong report of speed with both cdrecord and wodim
    - Disk project doesn't save the disk title (LP: #587924)
    - Brasero reports outdated cdrtools on cdrtools-3.00 (LP: #592075)
    - misc bug fixes
    - Updated Translations
  * Removed upstream patches:
    - debian/patches/90_git_audio_project_creation.patch,
      debian/patches/91_git_audio_project_creation.patch,
      debian/patches/92_git_audio_cd_recording.patch,
      debian/patches/93_git_new_caps_function_definition.patch
  * debian/patches/99_autoconf.patch:
    - refreshed
 -- Didier Roche <email address hidden> Thu, 24 Jun 2010 11:22:46 +0200

Changed in brasero (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in brasero:
importance: Unknown → Critical

I have received several emails from this guy recently. (nigel huges)
quit wasting peoples time.
On Thu, Feb 10, 2011 at 11:16 AM, Nigel Hughes <email address hidden>wrote:

> Hurroo !
> Customer
>
> We provide a program that will allow someone with sufficient work
> experience to obtain a fully verifiable Dgeree: Bacheolrs, Bahcelors or
> Doctroate.
>
> Obtain a prosperous future, money-earning power and the prestige that comes
> with having the career position you’ve always dreamed of.
>
> Get your Dilpoma!. Get a Promotion. No books!.
>
> Many people share the same frustration, they are doing the work of the
> person that has the degree and the person that has the degree is getting
> all the money. Do not you think that it is time you were paid fair
> compensation for the level of work you are already doing?
>
> ***********
> Give us a call NOW!
>
> + 1 - 646 - 537 - 1732 <+16465371732>
> Please leave us your:
> 1) Your Name
> 2) Your Country
> 3) Phone No. with countrycode if outside USA
>
> We will get back to you ASAP
> ***********
>
> Do Not Reply to this Email.
> We do not reply to text inquiries, and our server will reject all response
> traffic.
> We apologize for any inconvenience this may have caused you.
>
> --
> You received this bug notification because you are subscribed to Lucid.
> https://bugs.launchpad.net/bugs/561319
>
> Title:
> brasero crashed with SIGSEGV in brasero_data_project_remove_node()
>

--
@Dave Stroud@

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.