brasero dialog "please eject the CD yourself" has a Cancel button instead of OK.

Bug #549184 reported by Yann Dìnendal on 2010-03-26
78
This bug affects 17 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: brasero

After successfully burning a CD, brasero asked to "please eject the CD yourself" (or similar, I've it in French). So I eject it. And the dialog doesn't disappear and the only option available remains the "Cancel" button. It should be "OK", to acknowledge that I've ejected the CD. I hesitated and didn't know exactly what it would cancel…

Pedro Villavicencio (pedro) wrote :

the dialog seems ok here, could you please take an screenshot of the issue? thanks.

Changed in brasero (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in brasero (Ubuntu):
status: Incomplete → Invalid
Joonas Saarinen (jza) wrote :

I also see a "Cancel" button there. Screenshot attached.

Setup: English language, Data CD project, USB writer, Brasero 2.30.2 (Ubuntu 10.04).

Joonas Saarinen (jza) on 2010-07-24
Changed in brasero (Ubuntu):
status: Invalid → Confirmed
Jody McIntyre (scjody) wrote :

I'm getting the same dialog as Joonas. I don't understand why this dialog appears in the first place. It says "The disc could not be ejected though it needs to be removed for the current operation to continue." - this is untrue. There is no reason why the disc even needs to be ejected. I was about to reboot and boot off it, so it's fine where it is. Why does brasero care?

A better dialog would perhaps be along the lines of "The disc could not be ejected automatically. Please eject it if needed. --- OK" or simply "The disc could not be ejected automatically. --- OK"

Or even how about NOT using a dialog, and just putting a message in the main window: "Image successfully burned to CD. The disc could not be ejected automatically."

al espenschied (alvinmoneypit) wrote :

 I think it's important to note that because of this problem, the program does NOT continue in the case of making multiple copies

Whenever Brasero is started, you have the option of "copy" or "make multiple copies". With this bug it CANNOT achieve this task because it hangs on 'ejecting disc". Someone took my bug down, pointed me here, and truncated all the particulars which I just described.

I don't understand why it doesn't have the permissions to eject the disc, it does in 9.10.

Joonas Saarinen (jza) wrote :

In a more recent Brasero there is some improvement as the dialog now closes automatically when I eject the disc. So the "Cancel" button makes sense now too.

It still lacks the ability to automatically eject the disc though.

I've exactly the same bug, but it's weird because without sudo, the command eject /dev/cdrom works perfectly ! So I don't that's a problem of permission !

tags: added: brasero eject
Amr Ibrahim (amribrahim1987) wrote :

@Tim, No, it's not a duplicate of that bug.

The submitter of this bug, Yann, complains that the message should have an "OK" button not a "Cancel" one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers