Update to 2.29.92

Bug #548479 reported by Robert Ancell on 2010-03-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: brasero

Fails to build:
/usr/bin/g-ir-scanner -v --namespace=BraseroBurn --nsversion=1.0 \
     -I../libbrasero-media \
     -I../libbrasero-media \
     -I../libbrasero-burn \
     -I../libbrasero-burn \
            --include=Gtk-2.0 \
            --add-include-path=../libbrasero-media \
     --include=BraseroMedia-1.0 \
     --library=brasero-burn \
     --libtool="/bin/bash ../libtool" \
            --output BraseroBurn-1.0.gir \
            --pkg=gtk+-2.0 \
     --strip-prefix=Brasero \
            ../libbrasero-burn/brasero-tags.h \
            ../libbrasero-burn/brasero-enums.h \
            ../libbrasero-burn/brasero-error.h \
            ../libbrasero-burn/brasero-status.h \
            ../libbrasero-burn/brasero-burn-lib.h \
            ../libbrasero-burn/brasero-track-type.h \
            ../libbrasero-burn/brasero-track.h \
            ../libbrasero-burn/brasero-track-data.h \
            ../libbrasero-burn/brasero-track-data-cfg.h \
            ../libbrasero-burn/brasero-track-disc.h \
            ../libbrasero-burn/brasero-track-stream.h \
            ../libbrasero-burn/brasero-track-stream-cfg.h \
            ../libbrasero-burn/brasero-track-image.h \
            ../libbrasero-burn/brasero-track-image-cfg.h \
            ../libbrasero-burn/brasero-session.h \
            ../libbrasero-burn/brasero-session-span.h \
            ../libbrasero-burn/brasero-session-cfg.h \
            ../libbrasero-burn/brasero-burn.h \
            ../libbrasero-burn/brasero-burn-options.h \
            ../libbrasero-burn/brasero-burn-dialog.h \
            ../libbrasero-burn/brasero-tool-dialog.h \
     ../libbrasero-burn/brasero-sum-dialog.h \
     ../libbrasero-burn/*.c
/home/bob/bzr/ubuntu/build-area/brasero-2.29.92/libbrasero-burn/.libs/libbrasero-burn.so: undefined reference to `brasero_app_indicator_get_type'
/home/bob/bzr/ubuntu/build-area/brasero-2.29.92/libbrasero-burn/.libs/libbrasero-burn.so: undefined reference to `brasero_app_indicator_set_show_dialog'
/home/bob/bzr/ubuntu/build-area/brasero-2.29.92/libbrasero-burn/.libs/libbrasero-burn.so: undefined reference to `brasero_app_indicator_hide'
/home/bob/bzr/ubuntu/build-area/brasero-2.29.92/libbrasero-burn/.libs/libbrasero-burn.so: undefined reference to `brasero_app_indicator_set_action'
/home/bob/bzr/ubuntu/build-area/brasero-2.29.92/libbrasero-burn/.libs/libbrasero-burn.so: undefined reference to `brasero_app_indicator_set_progress'
/home/bob/bzr/ubuntu/build-area/brasero-2.29.92/libbrasero-burn/.libs/libbrasero-burn.so: undefined reference to `brasero_app_indicator_new'
collect2: ld returned 1 exit status
Traceback (most recent call last):
  File "/usr/bin/g-ir-scanner", line 38, in <module>
    sys.exit(scanner_main(sys.argv))
  File "/usr/lib/gobject-introspection/giscanner/scannermain.py", line 317, in scanner_main
    glibtransformer.get_get_type_functions())
  File "/usr/lib/gobject-introspection/giscanner/dumper.py", line 231, in compile_introspection_binary
    return dc.run()
  File "/usr/lib/gobject-introspection/giscanner/dumper.py", line 132, in run
    self._link(bin_path, o_path)
  File "/usr/lib/gobject-introspection/giscanner/dumper.py", line 226, in _link
    subprocess.check_call(args)
  File "/usr/lib/python2.6/subprocess.py", line 498, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['/bin/bash', '../libtool', '--mode=link', '--tag=CC', '--silent', 'gcc', '-o', '/home/bob/bzr/ubuntu/build-area/brasero-2.29.92/libbrasero-burn/tmp-introspecttIYmaL/BraseroBurn-1.0', '-g', '-O2', '-g', '-Wall', '-O2', '-L.', '-lbrasero-burn', '-pthread', '-Wl,--export-dynamic', '-lgio-2.0', '-lgirepository-1.0', '-lgobject-2.0', '-lgmodule-2.0', '-lffi', '-lgthread-2.0', '-lrt', '-lglib-2.0', '/home/bob/bzr/ubuntu/build-area/brasero-2.29.92/libbrasero-burn/tmp-introspecttIYmaL/BraseroBurn-1.0.o']' returned non-zero exit status 1
make[3]: *** [BraseroBurn-1.0.gir] Error 1

Changed in brasero (Ubuntu):
importance: Undecided → Wishlist
tags: added: desktop-upgrade
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.30.0-0ubuntu1

---------------
brasero (2.30.0-0ubuntu1) lucid; urgency=low

  * New upstream version
    Bug Fixes:
    - Fix a problem if multiple tracks were processed in a single pass by
      a plugin then progress was not smooth
    - Fix video options so that for SVCD we do have a proper default for
      aspect ratio
    - Fix two problem with video transcoding:
      - a hang that was caused by buffers being too little
      - progress reporting that did not always properly work
    - Make soft autodetection.
    - Update to latest GTK code
    - Fix #Bug 611111 - brasero burn:/// hangs
    - Use gtk_widget_style_attach () in realize implementations
  * debian/control.in:
    - updated gtk requirement

brasero (2.29.92-0ubuntu1) lucid; urgency=low

  * New upstream release: (LP: #548479)
    - Fix #608170 - Drive selection widget unusable from GtkBuilder
    - Add support for GtkBuilder interface to BraseroMediumSelection
      widget
    - Fix gobject-introspection shared libraries
    - Fix #608719 - nautilus crashed with signal 5 in
      brasero_burn_caps_get_default() (lp: #515471)
    - Fix building libbrasero-burn with GObject Introspection in some cases
    - Fix memory leak where a GError was not propagated properly
    - Ran autoupdate on configure.in to straight things up
    - Fix #611373 - messages in the Brasero Manual V2.2 are different from
      the real
    - Fix a test that could lead to read outside the allocated buffer.
    - Many Updated translations
 -- Sebastien Bacher <email address hidden> Tue, 30 Mar 2010 00:57:57 +0200

Changed in brasero (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers