Brasero silently loses directories

Bug #541019 reported by Noel J. Bergman on 2010-03-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Brasero
Expired
Critical
brasero (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: brasero

I can reproduce this with brasero on both Lucid and Karmic. I add a directory tree to brasero, and when it finishes adding, there are files silently discarded. The lost directory is:

  converted-to-tar/DRIVE-I\ \(WORK\)/NJB/DEVTECH/2BPORTED/YACL/

which contains files and a subdirectory. A weird thing is that I have a second, parallel, directory tree:

  recovered-drives/DRIVE-I\ \(WORK\)/NJB/DEVTECH/2BPORTED/YACL/

which appears completely when I drag both to brasero. The primary difference is that the latter directory contains everything, and the former (failing) tree contains the same tree structure, but only tar files converted from older archive formats found in the source tree.

brasero on Karmic works a bit differently than on Lucid. On Karmic, I'll be asked if I want to add the directory, because it is so far down in the tree, and that question will be repeated. On Lucid, I am asked just one. On Karmic, if I had *just* that one tree, it actually works, but if I add that tree along with its peers, it silently fails. On Lucid, it fails in all cases.

FWIW, I prefer Karmic's handling, where it offered NEVER, NOT THIS ONE, JUST THIS ONE, and ALWAYS, rather than NO and ALWAYS. I agree that if I want the option at all, I'm inclined to chose ALWAYS, but at least having the options was better than now.

Even if I manually repair the project by dragging the missing directory into its place in brasero, brasero will silently drop the contents when burning!

ALL FAILURES ARE SILENT. The image contains over 33,000 files and over 1200 directories. Were it not for the fact that I always store an md5sum.txt file in the root of the image, and always verify the burn with it, I would likely not have noticed the missing files until after the data might have been permanently lost. I CONSIDER THIS CRUCIAL TO RESOLVE ASAP! Silent data loss is unacceptable.

ProblemType: Bug
Architecture: amd64
Date: Thu Mar 18 11:02:31 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
NonfreeKernelModules: nvidia
Package: brasero 2.29.91-0ubuntu2
ProcEnviron:
 LANG=C
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: brasero
Uname: Linux 2.6.32-16-generic x86_64

Noel J. Bergman (noeljb) wrote :
Noel J. Bergman (noeljb) wrote :

The same burn works perfectly with Fedora 11 (brasero 2.26.3). And look at the difference in the .ISO file sizes:

  -rw-r--r--. 1 noel noel 5074489344 2010-03-18 11:36 piccolo-bad.iso
  -rw-rw-r--. 1 noel noel 5090373632 2010-03-18 12:17 piccolo.iso

summary: - [CRITICAL] Brasero silently loses directories
+ Brasero silently loses directories
Pedro Villavicencio (pedro) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME . Thanks in advance!

Changed in brasero (Ubuntu):
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Any news on this? did you sent it upstream? may you tell us the bug number there ? Thanks.

Changed in brasero (Ubuntu):
status: New → Incomplete
Noel J. Bergman (noeljb) wrote :

I've confirmed it in the newly dropped 2.30.0 release, and reported it upstream.

Changed in brasero (Ubuntu):
status: Incomplete → Confirmed
Changed in brasero:
importance: Undecided → Unknown
status: New → Unknown
Changed in brasero (Ubuntu):
status: Confirmed → New
Pedro Villavicencio (pedro) wrote :

Thanks a lot for sent this upstream Noel.

Changed in brasero (Ubuntu):
status: New → Triaged
Changed in brasero:
status: Unknown → New
Changed in brasero:
importance: Unknown → Critical
paolode (paolo-debortoli) wrote :

hi. i am using ubuntu 12.04 on hp pavilion laptop with this optical unit:: scsi 3:0:0:0: CD-ROM Optiarc DVD RW AD-7581A BH05 PQ: 0 ANSI: 5 cdrom: Uniform CD-ROM driver Revision: 3.20 sr 3:0:0:0: Attached scsi CD-ROM sr0. brasero manages very well cds, but doesn't burn correctly dvds (it is like it enters in an infinite cycle; stopping it, it gives error messages, cannot closing disk or eject it) and doesn't recognize double face dvds (recognized as single face). I installed k3b and everything worked well.

piotr zimoch (ebytyes) on 2013-05-26
Changed in brasero (Ubuntu):
status: Triaged → New
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Invalid
status: Invalid → Confirmed
status: Confirmed → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Changed in brasero:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.