nautilus crashed with signal 5 in brasero_burn_caps_get_default()

Bug #515471 reported by ahornby on 2010-02-01
202
This bug affects 55 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Critical
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: brasero

Crashed trying to write from USB media to DVD

ProblemType: Crash
Architecture: amd64
Date: Mon Feb 1 22:07:21 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/nautilus
Package: brasero 2.29.6-0ubuntu1
ProcCmdline: nautilus
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.16-generic
Signal: 5
SourcePackage: brasero
StacktraceTop:
 brasero_burn_caps_get_default ()
 brasero_burn_library_get_media_capabilities ()
 ?? () from /usr/lib/libbrasero-burn.so.0
 ?? () from /usr/lib/libbrasero-burn.so.0
 g_type_create_instance ()
Title: nautilus crashed with signal 5 in brasero_burn_caps_get_default()
Uname: Linux 2.6.32-12-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

ahornby (anthony-w-hornby) wrote :

StacktraceTop:
 brasero_burn_caps_get_default ()
 brasero_burn_library_get_media_capabilities (
 brasero_data_session_is_valid_multi (
 brasero_data_session_init (
 g_type_create_instance ()

Changed in brasero (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Pedro Villavicencio (pedro) wrote :

this report has been sent upstream at: https://bugzilla.gnome.org/show_bug.cgi?id=608719

Changed in brasero (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Triaged
visibility: private → public
PaulS (stibbard) wrote :

Only difference is I was trying to write to CD.

Stephan Peijnik (speijnik) wrote :

I can confirm this problem. The source or destination (ie. USB, local harddisk/cd, dvd) doesn't seem to matter.
Using brasero directly works perfectly well.

dinamic (dinamic6661) wrote :

i can't write on DVD, nautilus crashes

Pedro Villavicencio (pedro) wrote :

fixed upstream, thanks a lot for reporting.

Changed in brasero (Ubuntu):
status: Triaged → Fix Committed
Oded Arbel (oded-geek) wrote :

I still get this problem with a fully up to date Lucid - when is this planned to land in Lucid?

Pedro Villavicencio (pedro) wrote :

Oded, the bug was fixed 4 days ago , Please be patient.

Thanks a lot for fixing :-)

Anthony

On 17 March 2010 04:52, Pedro Villavicencio <email address hidden> wrote:
> fixed upstream, thanks a lot for reporting.
>
> ** Changed in: brasero (Ubuntu)
>       Status: Triaged => Fix Committed
>
> --
> nautilus crashed with signal 5 in brasero_burn_caps_get_default()
> https://bugs.launchpad.net/bugs/515471
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.30.0-0ubuntu1

---------------
brasero (2.30.0-0ubuntu1) lucid; urgency=low

  * New upstream version
    Bug Fixes:
    - Fix a problem if multiple tracks were processed in a single pass by
      a plugin then progress was not smooth
    - Fix video options so that for SVCD we do have a proper default for
      aspect ratio
    - Fix two problem with video transcoding:
      - a hang that was caused by buffers being too little
      - progress reporting that did not always properly work
    - Make soft autodetection.
    - Update to latest GTK code
    - Fix #Bug 611111 - brasero burn:/// hangs
    - Use gtk_widget_style_attach () in realize implementations
  * debian/control.in:
    - updated gtk requirement

brasero (2.29.92-0ubuntu1) lucid; urgency=low

  * New upstream release: (LP: #548479)
    - Fix #608170 - Drive selection widget unusable from GtkBuilder
    - Add support for GtkBuilder interface to BraseroMediumSelection
      widget
    - Fix gobject-introspection shared libraries
    - Fix #608719 - nautilus crashed with signal 5 in
      brasero_burn_caps_get_default() (lp: #515471)
    - Fix building libbrasero-burn with GObject Introspection in some cases
    - Fix memory leak where a GError was not propagated properly
    - Ran autoupdate on configure.in to straight things up
    - Fix #611373 - messages in the Brasero Manual V2.2 are different from
      the real
    - Fix a test that could lead to read outside the allocated buffer.
    - Many Updated translations
 -- Sebastien Bacher <email address hidden> Tue, 30 Mar 2010 00:57:57 +0200

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
Changed in brasero:
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.