Brasero won't accept FLAC files for audio disc project

Bug #504645 reported by Chris Wagner on 2010-01-08
56
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Brasero
Expired
Medium
brasero (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: brasero

Steps to reproduce:
  1) Launch 'brasero'
  2) Create a new audio project
  3) Attempt to drag a FLAC file into the project from nautilus

After following those steps, I am presented with a dialog that says the following in larger bold text:
  "02 - Roll with It.flac" could not be opened.
And it says the following below that in regular text:
  "02 - Roll with It.flac" is not suitable for audio or video media.

Totem seems to play the file just fine. And I seem to have several FLAC-related gstreamer things installed:
  chris@dell-desktop:~$ gst-inspect-0.10 | grep flac
  (gst-inspect-0.10:12694): GLib-WARNING **: g_set_prgname() called multiple times
  typefindfunctions: audio/x-flac: flac
  typefindfunctions: application/x-id3v1: tta, flac, ogg, mpga, mp1, mp2, mp3
  typefindfunctions: application/x-id3v2: tta, flac, ogg, mpga, mp1, mp2, mp3
  flac: flactag: FLAC tagger
  flac: flacdec: FLAC audio decoder
  flac: flacenc: FLAC audio encoder
  ffmpeg: ffmux_flac: FFmpeg raw FLAC muxer
  ffmpeg: ffdec_flac: FFmpeg FLAC (Free Lossless Audio Codec) decoder

...

Upon further investigation, actually, it seems that this is only a problem with a certain FLAC-encoded album that I have. But why should it work under Totem but not Brasero? I'll attach a culprit file.

ProblemType: Bug
Architecture: i386
Date: Fri Jan 8 02:39:25 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/brasero
NonfreeKernelModules: wl
Package: brasero 2.28.2-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: brasero
Uname: Linux 2.6.31-17-generic i686

Chris Wagner (chris-wagner) wrote :
Changed in brasero (Ubuntu):
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

looks like that's not supported at the moment, linking the upstream report for now.

Changed in brasero (Ubuntu):
status: New → Confirmed
summary: - [Ubuntu 9.10] Brasero won't accept FLAC files for audio disc project
+ Brasero won't accept FLAC files for audio disc project
Changed in brasero (Ubuntu):
status: Confirmed → Triaged

I can confirm this. One FLAC file out of an entire album fails to import for unknown reasons. They were all created from the same source the same way. I could not find anything interesting in this debug log I made, however perhaps someone else can.

Changed in brasero:
status: Unknown → New
Changed in brasero:
importance: Unknown → Wishlist
ricardisimo (ricardisimo) wrote :

I'm having the same problem:

>>"Neko Case - Blacklisted - 14 - Untitled.flac" could not be opened.
>>"Neko Case - Blacklisted - 14 - Untitled.flac" is not suitable for audio or video media.

And I click OK, and the second song on the mix - also flac - says the same thing. I've read through several threads and installed all of the codecs and libraries mentioned in all of them. No change.

I'm on 10.10, fully updated. K3b does the job perfectly. I'm saving the playlist to m3u in rhythmbox, then opening that m3u with k3b, and voila. Still, it should not be an issue, certainly not on a Linux system with open formats. Bizarre.

hyper_sonic (hyper-sonic) wrote :

When I try burn Audio-Cd project from flac files brasero fail process, and create log file.
Log file in attach.

pconwell (patrick-conwell) wrote :

I was having the same problem, sometimes brasero was fine with flac, other times it would throw an error about "is not suitable for audio or video media".

A work-around that fixed the problem for me - convert the file using "Sound Converter". I just 'converted' the files from .flac to .flac in a different directory and it fixed the problem. Something odd, though, is the file sizes are *slightly* different, but whatever. As long as it works now...

ricardisimo (ricardisimo) wrote :

That doesn't really fix the problem any more than my using k3b does. Brasero should always be able to burn a flac music file to an audio disc, especially if k3b can do it. It's flac... it's not some bizarre proprietary Sony DRM format. This is ridiculous.

ricardisimo (ricardisimo) wrote :

By the way, one odd little detail. When I run brasero from the terminal, encountering this flac problem, the only error reported is this:
":~$ brasero

** (brasero:4536): WARNING **: ERROR loading background pix : Failed to open file '/usr/share/brasero/logo.png': No such file or directory"

I doubt very much that this is the culprit, but sillier things have happened.

Milan Bouchet-Valat (nalimilan) wrote :

Upstream bug 537977 doesn't actually deal with the problem at stake here: it's about converting FLACs to MP3s in order to burn them to a MP3 CD, not a classic audio CD.

I've filed a similar report today about a problem with FLAC files, so I posted your file upstream too, and I'm changing the remote watch accordingly.

Changed in brasero:
importance: Wishlist → Unknown
status: New → Unknown
Changed in brasero (Ubuntu):
importance: Low → Medium
Changed in brasero:
importance: Unknown → Medium
status: Unknown → New
James (ubuntu-soundunreason) wrote :

I am also experiencing this bug.

I have discovered that the files effected appear to be those I have ripped using EAC over the last several months. I do have one album I downloaded which exhibits the same symptoms and I do not know its ripper, but I have hundreds of my own CD's which I have ripped using EAC (0.99pb5) on my 10.04 system ripping directly to FLAC with tagging. These files reside on my music server (rw,r,r) and are usable by every other application (Totem, VLC, Rhythmbox, Banshee, and K3B) on that system and any other on my network.

Rhythmbox and Banshee send burning operations to Brasero and the same error occurs for each file in question.

If I run flac -V I do see an error (ERROR: input file /path/to/file.flac has an ID3v2 tag) which seems consistent across those files Brasero rejects (and not in those it does not), but I have not tested every file obviously. Further my testing of recent EAC ripped files was a random sampling and the only reason I found the downloaded file in question is it happened to be in a playlist I was trying to burn.

You care read about this in my thread: http://ubuntuforums.org/showthread.php?t=1917215

I am available to do any testing which may be of interest and I can provide many example files if that would be useful. Developers may contact me directly.

Doug McMahon (mc3man) wrote :

As I mentioned elsewhere - I believe that .flac files that have added ID3 tags will be rejected by brasero. The immediate solution would be to avoid adding such tags
(EAC has that option disabled by default, if using EAC make sure it is disabled..

pavel bursa (bursap) wrote :

Ubnutu 16.10 in Brasero, When I drag FLAC to Brasero audio disc project, all have only 6 secs. I can play the flac files in vlc, all of them have more than 6 secs.

Changed in brasero:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.