brasero crashes on right click on video file if preview is open

Bug #489048 reported by Ariel Arjona on 2009-11-27
38
This bug affects 11 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: brasero

Steps to reproduce:
* Open brasero and start a data project.
* Make sure the preview is enabled (view->preview).
* Add a video file to the project. Once it's added there should appear a preview below the file list, with play controls.
* Right click on the video file, brasero crashes a second after the menu pops.

ProblemType: Bug
Architecture: amd64
Date: Thu Nov 26 23:37:43 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/brasero
NonfreeKernelModules: nvidia
Package: brasero 2.28.2-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: brasero
Uname: Linux 2.6.31-15-generic x86_64
XsessionErrors:
 (gnome-settings-daemon:2304): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2304): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2418): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2400): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Ariel Arjona (arjona) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.
If you are using Kubuntu or Xubuntu you can file the crash using /usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash in a terminal - where _my_crash_report.crash is the crash you would like to report.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in brasero (Ubuntu):
importance: Undecided → Medium
status: New → Invalid
Ariel Arjona (arjona) wrote :

I followed the instructions and started apport. It's working (it caught an Empathy crash) but it doesn't catch the brasero crash.

Starting brasero from the command line when it crashes I see the following error message:
brasero: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.

Ariel Arjona (arjona) on 2009-12-02
Changed in brasero (Ubuntu):
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

Please try to obtain a backtrace manually following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in brasero (Ubuntu):
status: New → Incomplete
Ariel Arjona (arjona) wrote :

this is what gdb generated

Changed in brasero (Ubuntu):
status: Incomplete → New
Ariel Arjona (arjona) wrote :

xtrace of brasero --sync

this is the error on the other console:

brasero: Fatal IO error 11 (Resource temporarily unavailable) on X server :9.0.

Pedro Villavicencio (pedro) wrote :

there's no signs of a crash on the reports you attached, may you please try again? Thanks in advance.

Changed in brasero (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete

> there's no signs of a crash on the reports you attached, may you please
> try again? Thanks in advance.
It's OK now, the bug is gone. Thank you very much.

--
With best regards,
Dennis V. Prochko

Pedro Villavicencio (pedro) wrote :

ok closing the bug then, Thanks Ariel.

Changed in brasero (Ubuntu):
status: Incomplete → Invalid
Ariel Arjona (arjona) wrote :

Pedro, that was not me. The bug is still present for me.

Ariel Arjona (arjona) on 2010-01-20
Changed in brasero (Ubuntu):
status: Invalid → Incomplete
Hrotkó Gábor (roti-al) wrote :

karmic, brasero 2.28.2
when i select a video file, ant the preview is eanbled, and I start the play button, brasero will crash

Changed in brasero (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers