brasero crashed with SIGSEGV in request_targets_received_func()

Bug #466099 reported by Csipak Attila on 2009-10-31
72
This bug affects 1 person
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: brasero

Using Ubuntu 9.04 and brasero 2.26.1.

I was trying to do a Data CD write, and already added a couple of directories to the project. Then tried to cut-paste one of the dirs to another location within the project's directory tree, and the crash happened. The error is reproducible on my machine.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/brasero
NonfreeKernelModules: nvidia
Package: brasero 2.26.1-0ubuntu1
ProcCmdline: brasero
ProcEnviron:
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: brasero
StacktraceTop:
 ?? ()
 request_targets_received_func (clipboard=0x9d7e778,
 selection_received (widget=0x9f100a8,
 _gtk_marshal_VOID__BOXED_UINT (closure=0x9f13830,
 IA__g_closure_invoke (closure=0x9f13830, return_value=0x0,
Title: brasero crashed with SIGSEGV in request_targets_received_func()
Uname: Linux 2.6.28-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Csipak Attila (corphicks) wrote :
visibility: private → public
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug report is public and visible to everyone but I noticed that it has an attachment named 'CoreDump.gz'. It is possible that this contains sensitive information so I've set it back to private.

visibility: public → private

StacktraceTop:brasero_data_disc_clipboard_targets_cb (clipboard=0x9d7e778, atoms=0x0,
request_targets_received_func (clipboard=0x9d7e778,
selection_received (widget=0x9f100a8,
_gtk_marshal_VOID__BOXED_UINT (closure=0x9f13830,
IA__g_closure_invoke (closure=0x9f13830, return_value=0x0,

Changed in brasero (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Pedro Villavicencio (pedro) wrote :

is this reproducible with karmic?

Changed in brasero (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete
visibility: private → public
Csipak Attila (corphicks) wrote :

OK, here's some update.

I tried to reproduce the error on Karmic (9.10) with Brasero 2.28.2, but I couldn't. Looks like this version of Brasero simply doesn't react to the CTRL+C, CTRL+X, CTRL+V key combinations. (Maybe this is intentional.)

Also, if you want to move added directories/files within a Brasero project, simply using mouse drag&drops works fine both with Jaunty+Brasero 2.26.1 and Karmic+Brasero 2.28.2.

Vish (vish) wrote :

Thanks for following up. This bug report is being closed due to your last comment regarding this being a non issue since copy-paste no longer is triggered there. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in brasero (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers