creating audio cd in rhythmbox no longer works

Bug #459103 reported by Michael Olberg on 2009-10-23
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
brasero (Ubuntu)
High
Unassigned
Karmic
High
Unassigned
rhythmbox (Ubuntu)
High
Unassigned
Karmic
High
Robert Ancell

Bug Description

Binary package hint: rhythmbox

Trying to burn an audio CD in rhythmbox from a playlist (this works flwalessly in jaunty) fails. No error is reported, even if I start rhythmbox from the command line. The command to burn a CD seems to be silently ignored.

ProblemType: Bug
Architecture: i386
Date: Fri Oct 23 15:52:20 2009
DistroRelease: Ubuntu 9.10
Package: rhythmbox 0.12.5-0ubuntu4
ProcEnviron:
 LC_TIME=en_DK.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
 LC_PAPER=en_DK.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:2258): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2258): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:2420): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:2432): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:2371): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

Michael Olberg (michael-olberg) wrote :
Davide Capodaglio (davidecapod) wrote :

Same behaviour here, I upgraded from Jaunty, on AMD64. The "burn" command is silently ignored.

Sebastien Bacher (seb128) wrote :

the issue is fixed in the upgrade in bug #458709

affects: rhythmbox (Ubuntu) → brasero (Ubuntu)
Changed in brasero (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
sgage@tds.net (sgage) on 2009-10-26
Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Martin Pitt (pitti) wrote :

Accepted brasero into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in brasero (Ubuntu Karmic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in brasero (Ubuntu):
importance: Low → High
Changed in brasero (Ubuntu Karmic):
importance: Undecided → High
tags: added: regression-updates
Changed in brasero (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
Pedro Villavicencio (pedro) wrote :

This is not working fine, The option to burn a cd with rhythmbox now works, yes, but only the first track of the playlist is burned into the cd, the others are just ignored.

Martin Pitt (pitti) on 2009-11-02
tags: added: regression-release verification-failed
removed: regression-updates verification-needed
Changed in brasero (Ubuntu Karmic):
status: Fix Committed → Triaged
Changed in brasero (Ubuntu):
status: Fix Committed → Triaged
Changed in rhythmbox (Ubuntu Karmic):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Robert Ancell (robert-ancell)
Changed in brasero (Ubuntu Karmic):
assignee: Robert Ancell (robert-ancell) → nobody
Changed in rhythmbox (Ubuntu):
status: New → Triaged
importance: Undecided → High
Robert Ancell (robert-ancell) wrote :

Fixed bug in Rhythmbox, please consider for SRU:
- The current Rhythmbox can only burn the last track in the playlist to a CD. The cause is an invalid Brasero project file generated by Rhythmbox. To reproduce try to burn more than one track and see how many tracks are shown in Brasero.
- This has been fixed in 0.12.5-0ubuntu5 (lp:~ubuntu-desktop/rhythmbox/ubuntu) by correctly generating the <audio> XML tags in the project file
- The regression potential is LOW as the change only affects the project file generated and the functionality is currently unusable.

Changed in brasero (Ubuntu):
status: Triaged → Fix Released
Changed in brasero (Ubuntu Karmic):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Robert, please don't close these tasks yet. It's not fixed in lucid yet, and as long as brasero is still in karmic-proposed it is not yet fixed either (just when it moves to -updates).

Changed in brasero (Ubuntu):
status: Fix Released → Fix Committed
Changed in brasero (Ubuntu Karmic):
status: Fix Released → Fix Committed

Accepted rhythmbox into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in rhythmbox (Ubuntu Karmic):
status: Triaged → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) on 2009-11-03
tags: removed: verification-failed
Pedro Villavicencio (pedro) wrote :

This is working fine now, Tried same behavior than in comment #5, and now it does add all the songs on the playlist no tracks are ignored and the burning works quite well, I'm thus marking this as verification-done, Thanks for the quick fix!.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.28.2-0ubuntu1

---------------
brasero (2.28.2-0ubuntu1) karmic-proposed; urgency=low

  * New upstream version: (LP: #458709)
    - Data project: multiple file rename do not work
    - Remember volume title
    - Crash when launching with -e option
    - brasero crashed with SIGSEGV in
      brasero_burn_session_set_image_output_full() (LP: #449644)
    - Make burning audio cds with brasero work (LP: #459103)

 -- Robert Ancell <email address hidden> Fri, 23 Oct 2009 13:26:40 +1100

Changed in brasero (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.5-0ubuntu5

---------------
rhythmbox (0.12.5-0ubuntu5) karmic-proposed; urgency=low

  * debian/patches/05_brasero_burn_xml.patch:
    - Fix Brasero project <audio> tags when burning tracks (LP: #459103)

 -- Robert Ancell <email address hidden> Tue, 03 Nov 2009 11:14:51 +0100

Changed in rhythmbox (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied karmic-proposed to lucid.

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Released
Changed in rhythmbox (Ubuntu Karmic):
status: Fix Released → Fix Committed
Changed in brasero (Ubuntu Karmic):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.28.2-0ubuntu1

---------------
brasero (2.28.2-0ubuntu1) karmic-proposed; urgency=low

  * New upstream version: (LP: #458709)
    - Data project: multiple file rename do not work
    - Remember volume title
    - Crash when launching with -e option
    - brasero crashed with SIGSEGV in
      brasero_burn_session_set_image_output_full() (LP: #449644)
    - Make burning audio cds with brasero work (LP: #459103)

 -- Robert Ancell <email address hidden> Fri, 23 Oct 2009 13:26:40 +1100

Changed in brasero (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.5-0ubuntu5

---------------
rhythmbox (0.12.5-0ubuntu5) karmic-proposed; urgency=low

  * debian/patches/05_brasero_burn_xml.patch:
    - Fix Brasero project <audio> tags when burning tracks (LP: #459103)

 -- Robert Ancell <email address hidden> Tue, 03 Nov 2009 11:14:51 +0100

Changed in rhythmbox (Ubuntu Karmic):
status: Fix Committed → Fix Released
Dag Odenhall (dag.odenhall) wrote :

This bug affects me in a fresh Lucid install. The button just does nothing, and there are no errors reported.

Same here, the button does not work on Lucid. When running from command line, I get these errors when pressing the button...

(-r:7544): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed
(-r:7544): GLib-GObject-CRITICAL **: g_object_unref: assertion `object->ref_count > 0' failed
(-r:7544): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed
(-r:7544): GLib-GObject-CRITICAL **: g_object_unref: assertion `object->ref_count > 0' failed

ValentinV (valentinverde) wrote :

Not working for me neither in lucid

Pedro Villavicencio (pedro) wrote :

You're commenting on the wrong report, Lucid issue is being tracked on bug 543892, please subscribe to that one, thanks.

Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.