brasero crashed with SIGSEGV in g_main_context_dispatch()

Bug #452059 reported by Alessandro Lazzari on 2009-10-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Brasero
Expired
Critical
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: brasero

If Gstreamer "Ugly" plugin is NOT installed, when trying to load a list of mp3 in an audio cd project, Brasero shows an error popup for every file in the list, forcing the user to click repeatedly on every error button, then crashes. It doesn't happen when loading a single file, only with larger lists, at least 8+ files. I think it should instead warn the user about the missing plugin, then try to download it, like Totem does.

ProblemType: Crash
Architecture: amd64
CheckboxSubmission: cd406c803aa1cc7675b5f0b47d355126
CheckboxSystem: d00f84de8a555815fa1c4660280da308
CrashCounter: 1
Date: Thu Oct 15 12:32:39 2009
Disassembly: 0x0: Cannot access memory at address 0x0
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/brasero
Package: brasero 2.28.1-0ubuntu1
ProcCmdline: brasero
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: brasero
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/libbrasero-utils.so.0
 g_main_context_dispatch ()
 ?? () from /lib/libglib-2.0.so.0
 g_main_loop_run () from /lib/libglib-2.0.so.0
Title: brasero crashed with SIGSEGV in g_main_context_dispatch()
Uname: Linux 2.6.31-14-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:2009): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2009): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2173): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2155): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

StacktraceTop:?? ()
brasero_io_return_result_idle (
g_main_context_dispatch ()
?? () from /lib/libglib-2.0.so.0
g_main_loop_run () from /lib/libglib-2.0.so.0

Changed in brasero (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

The error popups appear with any number of file, but it crashes only with larger lists.

visibility: private → public
Pedro Villavicencio (pedro) wrote :
Changed in brasero (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Triaged

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in brasero (Ubuntu):
status: Triaged → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in brasero:
status: Unknown → Invalid
Changed in brasero (Ubuntu):
status: Incomplete → Invalid
Matt Lavin (matt-lavin) wrote :

I just hit this bug today. The description is perfectly accurate. It crashed (twice) before I installed gstreamer ugly, and once I installed it there was no problem.

I would agree that this bug shouldn't be considered major since there is such an easy workaround (install ugly), but it's definitely not an incomplete/invalid bug report. The problem is reproduceable just as described. Can we re-open the bug so that it can get looked at?

I'm reopening the bug, and attaching backtrace information.
file 1: program run as normal user.

Changed in brasero (Ubuntu):
status: Invalid → New

file 2

Sorry, file 2 is the backtrace of the program run as super user. It seems to contain more information than the other.

Pedro Villavicencio (pedro) wrote :

are you getting this using Lucid?

Changed in brasero (Ubuntu):
status: New → Incomplete

No, behaviour in Lucid is completely different.
When you add the files, Brasero gives an error prompt for each file in the list, then prompts for missing codecs, providing a list of downloadable ones, gstreamer0.10-ffmpeg, gstreamer0.10-fluendo-mp3, gstreamer0.10-plugins-ugly; (no crashes)

case 1: you accept to download the files.
           - Brasero downloads the codecs and dependencies, and terminates saying that the downloaded plugins are not enough to proceed.
           - Start another project, add files, and everything works.

case 2: you refuse to download the files.
            - You're stuck (of course)!
            - Start another project, add files, and Brasero won't ask you again to download the codecs, and you're stuck again.
            - If you close Brasero and then open it, it will correctly prompt for codecs again.

In general, if you should later uninstall one or more of the needed packages, eg. gstreamer0.10-plugins-ugly, Brasero won't anymore realize that it's missing, and it will never prompt for codecs again, returning the error prompt for each file in list.

Changed in brasero:
importance: Unknown → Critical
status: Invalid → Expired
Vish (vish) wrote :

Thanks for following up. This bug report is being closed due to your last comment regarding brasero no longer crashing.
Kindly open a new bug report for the new issue you mention.
 Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in brasero (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.