nautilus crashed with SIGSEGV in strcmp()

Bug #413660 reported by Albert Damen on 2009-08-14
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Critical
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Nautilus crashes immediately at start-up (using auto-login) and starts many new nautilus instances.
Stacktrace looks different then bug 403549.
This started after today's updates. Until today I have not seen this crash.

$ apt-cache policy nautilus
nautilus:
  Installed: 1:2.27.4-0ubuntu6
  Candidate: 1:2.27.4-0ubuntu6
  Version table:
 *** 1:2.27.4-0ubuntu6 0
        500 http://192.168.1.100 karmic/main Packages
        100 /var/lib/dpkg/status
$ apt-cache policy libbrasero-media0
libbrasero-media0:
  Installed: 2.27.90-0ubuntu1
  Candidate: 2.27.90-0ubuntu1
  Version table:
 *** 2.27.90-0ubuntu1 0
        500 http://192.168.1.100 karmic/main Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
Architecture: amd64
Date: Fri Aug 14 17:30:23 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.27.4-0ubuntu6
ProcCmdline: nautilus
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SegvAnalysis:
 Segfault happened at: 0x7f94d6cacd42 <strcmp+2>: cmp (%rsi),%al
 PC (0x7f94d6cacd42) ok
 source "(%rsi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%al" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 strcmp () from /lib/libc.so.6
 brasero_medium_monitor_get_drive (
 brasero_medium_monitor_init (object=0x2267c00)
 IA__g_type_create_instance (
 g_object_constructor (type=34214272,
Title: nautilus crashed with SIGSEGV in strcmp()
Uname: Linux 2.6.31-5-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare sbuild

Albert Damen (albrt) wrote :

StacktraceTop:strcmp () from /lib/libc.so.6
brasero_medium_monitor_get_drive (
brasero_medium_monitor_init (object=0x2267c00)
IA__g_type_create_instance (
g_object_constructor (type=34214272,

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Albert Damen (albrt) on 2009-08-14
visibility: private → public
Albert Damen (albrt) wrote :

Attached is the output of hal-device /org/freedesktop/Hal/devices/storage_model_DVDRW_SSM_8515S
There was no disk in the drive.
The crash happened before I could start anything myself.

C de-Avillez (hggdh2) wrote :

Confirming, and setting to HIGH. In my case, I get a very unresponsive gnome, with nautilus spawning off continuously.

Removing librasero-media0 (and removing is dependencies) bypasses the issue. I did not have brasero installed, to begin with.

Changed in nautilus (Ubuntu):
status: New → Confirmed
importance: Medium → High
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Pedro Villavicencio (pedro) wrote :

looks like a libbrasero issue, reassigning and also will send upstream.

Changed in nautilus (Ubuntu):
importance: High → Medium
affects: nautilus (Ubuntu) → brasero (Ubuntu)
Pedro Villavicencio (pedro) wrote :

I've sent this upstream at: http://bugzilla.gnome.org/show_bug.cgi?id=591826 ; Thanks for reporting.

Changed in brasero (Ubuntu):
status: Confirmed → Triaged
anagor (anagor) wrote :

I can confirm that indeed removing the libbrasero-media0 allows nautilus to work.
There was a bug #405544 (unable to burn CD or DVD with Brasero with 2.6.31 kernel) that got fixed in the recent version of nautilus.
Maybe they are related, since the offending package with our bug is libbrasero-media0.

Changed in brasero:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :
Changed in brasero (Ubuntu):
status: Triaged → Fix Committed
Albert Damen (albrt) wrote :

Upstream git commit c255543c "Should fix #591826 – nautilus crashed with SIGSEGV in strcmp()" solves the problem for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.27.90-0ubuntu2

---------------
brasero (2.27.90-0ubuntu2) karmic; urgency=low

  [ Chris Coulson ]
  * debian/patches/012_fix_null_device_crash.patch:
    - Upstream GIT change to not assume that all GVolume's have a
      unix-device identifier. Fixes a Nautilus crash due to the Brasero
      plugin (LP: #413660).

 -- Steve Langasek <email address hidden> Fri, 14 Aug 2009 14:24:20 -0700

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
LoonyPhoenix (loonyphoenix) wrote :

I have the same issue BUT I deleted brasero and it didn't help. Only sudo mv /usr/bin/nautilus /usr/bin/nautilus-backup helped...

well, removing libbrasero-media0 didn't do it for me, LoonyPhoenix's way stopped the constant opening of nautilus instances and the segfaults have become less frequent in the logs. But i cannot use the desktop at all the normal way, i had to sudo nautilus via gnome-do.

Changed in brasero:
importance: Unknown → Critical
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.