brasero crashed with SIGSEGV in strcmp()

Bug #404540 reported by benie on 2009-07-25
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: brasero

Description: Ubuntu karmic (development branch)
Release: 9.10

brasero:
  Installiert: 2.27.4-0ubuntu1
  Kandidat: 2.27.4-0ubuntu1
  Versions-Tabelle:
 *** 2.27.4-0ubuntu1 0
        500 http://de.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

brasero crashed on following command:
brasero --brasero-media-debug --debug &> brasero-debug.txt

I tried this to get information why brasero doesn't recognize my burner.

ProblemType: Crash
Architecture: amd64
Date: Sat Jul 25 15:03:04 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/brasero
NonfreeKernelModules: nvidia
Package: brasero 2.27.4-0ubuntu1
ProcCmdline: brasero --brasero-media-debug --debug
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=de_DE.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-4.22-generic
SegvAnalysis:
 Segfault happened at: 0x7f9fd482cb22 <strcmp+2>: cmp (%rsi),%al
 PC (0x7f9fd482cb22) ok
 source "(%rsi)" (0x000003b8) not located in a known VMA region (needed readable region)!
 destination "%al" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: brasero
Stacktrace:
 #0 0x00007f9fd482cb22 in strcmp () from /lib/libc.so.6
 #1 0x00007f9fd4f8a206 in ?? () from /usr/lib/libglib-2.0.so.0
 #2 0x00007f9fd4f8b6ab in g_option_context_parse ()
    from /usr/lib/libglib-2.0.so.0
 #3 0x000000000042000d in main ()
StacktraceTop:
 strcmp () from /lib/libc.so.6
 ?? () from /usr/lib/libglib-2.0.so.0
 g_option_context_parse ()
 main ()
Title: brasero crashed with SIGSEGV in strcmp()
Uname: Linux 2.6.31-4-generic x86_64
UserGroups: adm admin cdrom dialout disk lpadmin plugdev sambashare

benie (bernd-niederberger) wrote :

StacktraceTop:strcmp () at ../sysdeps/x86_64/strcmp.S:30
parse_long_option (context=<value optimized out>,
IA__g_option_context_parse (context=0x1798f50,
main (argc=3, argv=0x7fffc48e4768) at main.c:495

Changed in brasero (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Pedro Villavicencio (pedro) wrote :

Thanks for the report, could you reproduce it everytime ? i cannot confirm that here, the command runs fine.

Changed in brasero (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete
visibility: private → public
anagor (anagor) wrote :

I can reproduce it every time I run
$brasero --debug

I get the same error as the original bug reporter on updated Ubuntu 9.10 x86_64.

Victor Vargas (kamus) wrote :

Not reproducible here in Ubuntu Maverick, please could you upgrade your system to the latest release of Ubuntu and check if this behaviour is still affecting you? Thanks.

paolode (paolo-debortoli) wrote :

hi. i am using ubuntu 12.04 on hp pavilion laptop with this optical unit:: scsi 3:0:0:0: CD-ROM Optiarc DVD RW AD-7581A BH05 PQ: 0 ANSI: 5 cdrom: Uniform CD-ROM driver Revision: 3.20 sr 3:0:0:0: Attached scsi CD-ROM sr0. brasero manages very well cds, but doesn't burn correctly dvds (it is like it enters in an infinite cycle; stopping it, it gives error messages, cannot closing disk or eject it) and doesn't recognize double face dvds (recognized as single face). I installed k3b and everything worked well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers