Ubuntu

files with % in name within folder fail to burn in brasero

Reported by Fifoxtasy on 2009-05-26
74
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Critical
brasero (Ubuntu)
Low
Unassigned
Lucid
Wishlist
Didier Roche

Bug Description

Binary package hint: brasero

maybe similar to this bug: https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/307957
error log attached.

burning the image just breaks up and gives attached error log. the only thing i can think of that could create this error is the % in the filenames. when i removed them from some files i was able to burn them.

----------------
Note: This only happens when the files with a % in the name are INSIDE another folder, if they are burned to the root folder there is no problem.
----------------

Steps to reproduce:

- Either create or rename some files with a % sign in the name.
- Burn to root folder of any CD/DVD using Brasero -- no problem.
- Create a folder, and insert the % files into this folder, and place the folder onto the root directory on the CD/DVD i.e. /cdrom0/blah/eoio%wihw.jpg
- Brasero fails

I don't know what the default format is i.e. Joilet or ISO9660, but it was the default option in brasero with the Windows compatibility checkbox checked.

Not sure if this might be brasero itself or cdrkit/cdrecord, needs further testing.

description: updated
Roy Jamison (xteejx) on 2009-05-27
visibility: public → private
Roy Jamison (xteejx) wrote :

Marked as Private, email address is visible in the log file.
I am unable to reproduce this in brasero in Jaunty. I renamed 2 or 3 files to include the % sign in their names, and burned as Data DVD.
What version of Ubuntu are you using, and what version of brasero is it? Note the current version of brasero for Jaunty is 2.26.1-0ubuntu1
Thank you.

Changed in brasero (Ubuntu):
status: New → Incomplete
Fifoxtasy (philipp-foerster) wrote :

i'm using 2.26.1-0ubuntu1 in linuxmint 7 (based on jaunty)
i was burning a data DVD as well.
thanks for making it private, should have changed the log a bit. can you make anything out of that error log? i had the a similar error log before; the last few files were some pictures including a %. i changed them and tried again and then brasero continued further and stopped where you can see in the error log i included.

Roy Jamison (xteejx) wrote :

I am not too sure about this, it seems that it is trying to make 2 copies of the same file in the makeisofs command before it burns, which is where the problem is. I shall edit out the email address in the log and remark this as Public so other people can have a look and see if they have the same/similar problem.
Can you reproduce this every time? How about using a CD instead, or moving those files around, etc?
Marking Low.

Changed in brasero (Ubuntu):
importance: Undecided → Low
Roy Jamison (xteejx) wrote :
Roy Jamison (xteejx) wrote :

Changed log file to remove any identifiable information - original log from reporter deleted. Marking Public again.

visibility: private → public
Fifoxtasy (philipp-foerster) wrote :
  • x.7z Edit (3.0 KiB, application/x-7z-compressed)

it was not the % in the filename but the folder name that caused the problem. i burned some other files with % in them without a problem. but then what is the problem???
i attached two of those files (i got 4 in total if you care for more) i have problems with. they are in an 7z archive. just extract the folder in there and then drag the folder into brasero or add it via the add.. button. if you only add the files, without the folder, there is no error. you have to add the whole folder. you have to add them to a Data Project. it doesn't matter if you burn them or create an image.
if you change the filename (on disk) or the name in brasero the file can be burnt normally (= the error disappears)
i hope this is reproduceable on other machines.
about those files: they were created by Miranda a windows instant messenger on a NTFS partition under windows XP. i copied them over to a ext3 partition when i switched to linux. permissions are set to be rw for everybody; me being the owner.
please let me know what's wrong about those files, i'm getting really curious.

by the way another bug: when i delete (move to trash) a folder that i just dragged into brasero, brasero closes/crashes.

Fifoxtasy (philipp-foerster) wrote :

i burned some other files with % in them without a problem. but there are some files (also containing %) that just won't be burnt by brasero.
i attached two of those files (i got 4 in total if you care for more) i have problems with. they are in an 7z archive. just extract the folder in there and then drag the folder into brasero or add it via the add.. button. if you only add the files, without the folder, there is no error. you have to add the whole folder. you have to add them to a Data Project. it doesn't matter if you burn them or create an image.
if you change the filename (on disk) or the name in brasero the file can be burnt normally (= the error disappears)
i hope this is reproduceable on other machines.
about those files: they were created by Miranda a windows instant messenger on a NTFS partition under windows XP. i copied them over to a ext3 partition when i switched to linux. permissions are set to be rw for everybody; me being the owner.
please let me know what's wrong about those files, i'm getting really curious.

by the way another bug: when i delete (move to trash) a folder that i just dragged into brasero, brasero closes/crashes.

Roy Jamison (xteejx) wrote :

I can confirm this. Adding steps to reproduce into the description, marking Confirmed and setting Medium importance - moderate severity on core application.

Changed in brasero (Ubuntu):
importance: Low → Medium
status: Incomplete → Confirmed
description: updated
summary: - burning files containing % creates error
+ files with % in name within folder fail to burn
Roy Jamison (xteejx) on 2009-05-28
description: updated

Unless brasero called "genisiomage" two times with the same
path argument (*), this is a well known "genisoimage" bug.
Genisoimage is full of bugs and unmaintained. I recommend
you to upgrade to recent original software from:

ftp://ftp.berlios.de/pub/cdrecord/alpha/

*) the brasero debug output is useless and incomplete as
it does not include the content of the path list file.

Roy Jamison (xteejx) wrote :

Perhaps it would be more helpful to get a backtrace on this? https://wiki.ubuntu.com/Backtrace

Schily (schilling-fokus) wrote :

From reading the original report, this would not help at all.

Roy Jamison (xteejx) wrote :

Nevertheless, this is still reproducible very easily, and I have added reproduction steps to the description, although it is a Low importance bug, it is a bug nonetheless, and as this has been dealt with by a member of Bug Control. I will leave this to the developers to have a look at, when they get a chance, and of course if any more information is needed, then the reporter will need to provide that if necessary, unless I can myself. :)

Schily (schilling-fokus) wrote :

In order to verify whether this is a bug in brasero or a bug in "cdrkit",
you still need to replace at least genisoimage with the official mkisofs.

remove /usr/bin/genisoimage
remove /usr/bin/mkisofsmatch_hist(
install the _official_ mklisofs in /usr/bin/mkisofs
create a symlink /usr/bin/genisoimage that points to /usr/bin/mkisofs

Note that genisoimage is full of bugs and that genisoimage is
unmaintained. Note that one of the well known bugs in genisoimage
is that it caims "cannot sort dir" problems where mkisofs has no problems!

Get recent original software from

ftp://ftp.berlios.de/pub/cdrecord/alpha/

Roy Jamison (xteejx) wrote :

Changing back to Low, didn't realise I re-changed it already by accident, sorry for the confusion.

Changed in brasero (Ubuntu):
importance: Medium → Low
khaktus (khaktus) wrote :

I've just recently installed Jackalope (and updated all packages), having the same issue.

I tried to use Brasero, GnomeBaker, XCDRoast for burning - neither can burn DVD, just I myself start to be burned out prematurely :)

Issue 1: This bug ("have the same Rock Ridge name" & "Unable to sort directory"), happening in Brasero & GnomeBaker. See the log please. Spent all day searching for bugs/forums, no solution found, besides Schilly's advices (side of official downloadable release), but it seems that support from berlios's sites finished with Interpid (https://launchpad.net/~ubuntu-burning/+archive/ppa) and he stopped developing (as I understood from the bottom of his site http://cdrecord.berlios.de/private/cdrecord.html).

Issue 2: If not this, I still cannot burn more than 7-level deep directories (which is ridiculous, if you want to burn some complex real-life compilation as it is, not with moving directories). There is a warning and an option to ignore this in both burners, in Preferences or during runtime "add and burn anyways", but even so somehow it was not accepted and threw an error and finished.

Issue 3: XCDRoast (installed with Synaptic without any dependencies needed) wants to be "run for the first time and configured" as root, but when launched, misses cdrecord (which is link to a wodim). Simply cannot run.

Issue 4: For me, each burner misses an important option (functioning in Nero, I admit) : Showing size of directories to be added (or at least those added) to the compilation - together with how much of DVD-space is left (or the overburn warning) - so that I can promptly remove some parts of the compilation to fit DVD size - the smallest ones of course, not blindly trying.

In fact, on my Jackalope - I don't have a burning possibility at all. Sad for "stable version" from the user point of view.

For Schily (if he still reads the thread): Yes, Jackalope is still released with:
/usr/bin/cdrecord -> wodim [Wodim 1.1.9]
/usr/bin/cdda2wav -> icedax [icedax 1.1.9]
/usr/bin/mkisofs -> genisoimage [genisoimage 1.1.9 (Linux)]
/usr/bin/readcd Nonexistent

Now I'm let to make/install recent Schilly's packages (not sure if compatible with Jackalope, plus what will it do to GBaker, Brasero). I'm not so experienced with linux, expert might play, "common user" not.

For Ubuntu team: until when please? Do read his notes, at least: http://cdrecord.berlios.de/private/linux-dist.html

Roy Jamison (xteejx) wrote :

Sorry this hasn't been updated, do you know if is this a problem in Karmic, I am unable to test at this time. Thank you.

summary: - files with % in name within folder fail to burn
+ files with % in name within folder fail to burn in brasero
Changed in brasero (Ubuntu):
status: Confirmed → Incomplete
Roy Jamison (xteejx) wrote :

Tested this in Lucid with no problems whatsoever. Marking Fix Released. If you still encounter this problem in the development release, please reopen this bug report by changing the status back to New. Thank you for reporting this to us.

Changed in brasero (Ubuntu):
status: Incomplete → Fix Released
Tsu Jan (tsujan2000) wrote :

Still present in v2.30.0 (when a file name contains a string of the form "%1a") :( I'm disappointed with Brasero and will stick to K3b with all its KDE libraries.

Changed in brasero (Ubuntu):
status: Fix Released → New
Fifoxtasy (philipp-foerster) wrote :

i switched to K3b as well. switched to KDE completely actually.

Tsu Jan (tsujan2000) wrote :

I came back to Brasero because K3b can't write symlinks correctly (Brasero can). v2.30.1 also suffers from this bug (not yet in Lucid). It seems that renaming such files is the only "workaround" found up to now!

Tsu Jan (tsujan2000) wrote :

At last I found a really good workaround for the "%1a_in_the_filename" bug:

Go to gconf-editor > apps > brasero > config > priority and increase the priority of libisofs-image to 2 or higher.

The bug is perhaps in genisoimage, not in Brasero :)

Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in brasero (Ubuntu):
status: New → Fix Committed
Didier Roche (didrocks) wrote :

uploaded in -proposed:

brasero (2.30.2-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release
    - Lot's of memleak fixes
    - Fixed a runtime warning related to cancelling tracker searches
    - Crash in brasero_data_project_node_removed at
      brasero-data-project.c:1163
    - brasero crashed with SIGSEGV in brasero_data_project_remove_node()
      (LP: #561319)
    - Fix a few runtime warnings with the Cover Editor
    - Text in cover editor does not show up automatically (LP: #469459)
    - Removed use of deprecated flags
    - Use accessor functions instead direct access (use GSEAL GnomeGoal)
    - Fix a bug in the layout on first start (side pane was hidden and
      remained so until the user moved it)
    - Save printer settings for cover printing
    - Write the contents of the GtkTextBuffer displayed line by displayed
      line which should improve the layout
    - "Write to Disc" button sensitivity regression
    - Fix flaw in mask that led libburn plugin not to work (not to be picked
      up actually) in some circumstances
    - Fails to burn ANY audio project
    - Move columns doesn't work (LP: #581759)
    - Brasero does not correctly handle double clicking on column separators
      (LP: #581885)
    - Bad info when burning, high CPU usage and slow burn
    - Change the priority for cdrdao and raised the one of cdda2wav plugin
    - brasero crashed with SIGSEGV in
      brasero_mmc3_get_performa nce_wrt_spd_desc() (LP: #564766)
    - brasero crashed with SIGSEGV in brasero_scsi_command_issue_sync()
      (LP: #444832)
    - Do not check for symlinks on cdda2wav so the plugin can use icedax.
    - Brasero's failure with some file names (LP: #380643)
    - Pressing create audio cd does nothing
    - Empty project not available
    - can't actually save error logs
    - doesn't handle incorrect temp dirs properly
    - Fix multi DND in GtkFileChooser
    - Displays "starting to record" during whole burn process
    - Fix wrong report of speed with both cdrecord and wodim
    - Disk project doesn't save the disk title (LP: #587924)
    - Brasero reports outdated cdrtools on cdrtools-3.00 (LP: #592075)
    - misc bug fixes
    - Updated Translations
  * Removed upstream patches:
    - debian/patches/90_git_audio_project_creation.patch,
      debian/patches/91_git_audio_project_creation.patch,
      debian/patches/92_git_audio_cd_recording.patch,
      debian/patches/93_git_new_caps_function_definition.patch
  * debian/patches/99_autoconf.patch:
    - refreshed

Test case:
- install the package from lucid-proposed and check you have 2.30.2-0ubuntu1
- try to burn a data and an audio CD and check everything is fine
- check that bugs mentioned in the above changelog are fixed too and comment on each bug report
Thanks!

Didier Roche (didrocks) on 2010-06-24
Changed in brasero (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Wishlist
assignee: nobody → Didier Roche (didrocks)

Accepted brasero into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in brasero (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.30.2-0ubuntu2

---------------
brasero (2.30.2-0ubuntu2) maverick; urgency=low

  * New upstream release
    - Lot's of memleak fixes
    - Fixed a runtime warning related to cancelling tracker searches
    - Crash in brasero_data_project_node_removed at
      brasero-data-project.c:1163
    - brasero crashed with SIGSEGV in brasero_data_project_remove_node()
      (LP: #561319)
    - Fix a few runtime warnings with the Cover Editor
    - Text in cover editor does not show up automatically (LP: #469459)
    - Removed use of deprecated flags
    - Use accessor functions instead direct access (use GSEAL GnomeGoal)
    - Fix a bug in the layout on first start (side pane was hidden and
      remained so until the user moved it)
    - Save printer settings for cover printing
    - Write the contents of the GtkTextBuffer displayed line by displayed
      line which should improve the layout
    - "Write to Disc" button sensitivity regression
    - Fix flaw in mask that led libburn plugin not to work (not to be picked
      up actually) in some circumstances
    - Fails to burn ANY audio project
    - Move columns doesn't work (LP: #581759)
    - Brasero does not correctly handle double clicking on column separators
      (LP: #581885)
    - Bad info when burning, high CPU usage and slow burn
    - Change the priority for cdrdao and raised the one of cdda2wav plugin
    - brasero crashed with SIGSEGV in
      brasero_mmc3_get_performa nce_wrt_spd_desc() (LP: #564766)
    - brasero crashed with SIGSEGV in brasero_scsi_command_issue_sync()
      (LP: #444832)
    - Do not check for symlinks on cdda2wav so the plugin can use icedax.
    - Brasero's failure with some file names (LP: #380643)
    - Pressing create audio cd does nothing
    - Empty project not available
    - can't actually save error logs
    - doesn't handle incorrect temp dirs properly
    - Fix multi DND in GtkFileChooser
    - Displays "starting to record" during whole burn process
    - Fix wrong report of speed with both cdrecord and wodim
    - Disk project doesn't save the disk title (LP: #587924)
    - Brasero reports outdated cdrtools on cdrtools-3.00 (LP: #592075)
    - misc bug fixes
    - Updated Translations
  * Removed upstream patches:
    - debian/patches/90_git_audio_project_creation.patch,
      debian/patches/91_git_audio_project_creation.patch,
      debian/patches/92_git_audio_cd_recording.patch,
      debian/patches/93_git_new_caps_function_definition.patch
  * debian/rules, debian/control.in:
    - use dh-autoreconf to launch autoreconf on build
 -- Didier Roche <email address hidden> Mon, 28 Jun 2010 10:33:09 +0200

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
Pedro Villavicencio (pedro) wrote :

This is know working fine with the proposed package, marking the bug as verification done, thanks all.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.30.2-0ubuntu1

---------------
brasero (2.30.2-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release
    - Lot's of memleak fixes
    - Fixed a runtime warning related to cancelling tracker searches
    - Crash in brasero_data_project_node_removed at
      brasero-data-project.c:1163
    - brasero crashed with SIGSEGV in brasero_data_project_remove_node()
      (LP: #561319)
    - Fix a few runtime warnings with the Cover Editor
    - Text in cover editor does not show up automatically (LP: #469459)
    - Removed use of deprecated flags
    - Use accessor functions instead direct access (use GSEAL GnomeGoal)
    - Fix a bug in the layout on first start (side pane was hidden and
      remained so until the user moved it)
    - Save printer settings for cover printing
    - Write the contents of the GtkTextBuffer displayed line by displayed
      line which should improve the layout
    - "Write to Disc" button sensitivity regression
    - Fix flaw in mask that led libburn plugin not to work (not to be picked
      up actually) in some circumstances
    - Fails to burn ANY audio project
    - Move columns doesn't work (LP: #581759)
    - Brasero does not correctly handle double clicking on column separators
      (LP: #581885)
    - Bad info when burning, high CPU usage and slow burn
    - Change the priority for cdrdao and raised the one of cdda2wav plugin
    - brasero crashed with SIGSEGV in
      brasero_mmc3_get_performa nce_wrt_spd_desc() (LP: #564766)
    - brasero crashed with SIGSEGV in brasero_scsi_command_issue_sync()
      (LP: #444832)
    - Do not check for symlinks on cdda2wav so the plugin can use icedax.
    - Brasero's failure with some file names (LP: #380643)
    - Pressing create audio cd does nothing
    - Empty project not available
    - can't actually save error logs
    - doesn't handle incorrect temp dirs properly
    - Fix multi DND in GtkFileChooser
    - Displays "starting to record" during whole burn process
    - Fix wrong report of speed with both cdrecord and wodim
    - Disk project doesn't save the disk title (LP: #587924)
    - Brasero reports outdated cdrtools on cdrtools-3.00 (LP: #592075)
    - misc bug fixes
    - Updated Translations
  * Removed upstream patches:
    - debian/patches/90_git_audio_project_creation.patch,
      debian/patches/91_git_audio_project_creation.patch,
      debian/patches/92_git_audio_cd_recording.patch,
      debian/patches/93_git_new_caps_function_definition.patch
  * debian/patches/99_autoconf.patch:
    - refreshed
 -- Didier Roche <email address hidden> Thu, 24 Jun 2010 11:22:46 +0200

Changed in brasero (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in brasero:
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.