reports 0% until finished, also slowly burning at speed 0.3x or 0.5x

Bug #370999 reported by Scott Armitage
120
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Low
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs
Nominated for Jaunty by Savvas Radevic
Nominated for Karmic by Savvas Radevic

Bug Description

Binary package hint: brasero

Ubuntu 9.04 (Jaunty)
Brasero 2.26.1-0ubuntu1

When burning data DVDs, roughly midway through the burning process, the progress bar disappears, the dialogue title shows "0% Done", and the listed data burned counter shows "0 MiB of {} MiB". No estimated completion time is shown. Estimated drive speed continues to show. If left alone, Brasero will successfully finish burning the DVD in the expected time and report such.

This occurs predictably every time I burn a data DVD. See the attached screenshot.

Revision history for this message
Scott Armitage (scott-armitage) wrote :
description: updated
Revision history for this message
Scott Armitage (scott-armitage) wrote :

Note: this bug may be related to bug 371002.

Revision history for this message
Nizar Kerkeni (nizarus) wrote :

I confirm this bug on jauntu 64 bits

Changed in brasero (Ubuntu):
status: New → Confirmed
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thanks for the report, could be similar to bug 277977. May someone having the issue send this upstream at bugzilla.gnome.org? For forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; Thanks in advance.

Changed in brasero (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Revision history for this message
znemeth (syntaxerror-syntaxerror) wrote :
Revision history for this message
znemeth (syntaxerror-syntaxerror) wrote :

here is another screenshot

Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thanks you for sent it upstream!.

Changed in brasero (Ubuntu):
status: Confirmed → Triaged
Changed in brasero:
status: Unknown → New
Revision history for this message
Scott Armitage (scott-armitage) wrote :

For what it's worth:

I originally reported this based on my experiences on my 6-year-old desktop computer, using an LG DVD burner (I can look up the actual model when I get home).

Today I burned my first DVD using my laptop, a Lenovo T61 which uses a Matshita drive, and the exact same thing happened.

Revision history for this message
Savvas Radevic (medigeek) wrote :

Please forward any comments to the gnome bug:
http://bugzilla.gnome.org/show_bug.cgi?id=582261

summary: - Brasero reports 0% done until finished burning
+ reports 0% until finished, also slowly burning at speed 0.3x or 0.5x
Revision history for this message
Savvas Radevic (medigeek) wrote :

The bug has been marked as fixed at gnome: http://bugzilla.gnome.org/show_bug.cgi?id=582261

Revision history for this message
Petar Velkovski (pvelkovski) wrote :

It's nice that it's fixed at Gnome. Will we get an updated package in Ubuntu 9.04 or not?

Revision history for this message
Savvas Radevic (medigeek) wrote :

As you can see at the bug status, I have nominated it for Jaunty and Karmic, we will see what the ubuntu folks say about it. :)

Changed in brasero:
status: New → Fix Released
Revision history for this message
Petar Velkovski (pvelkovski) wrote :

And where is the fix?

Revision history for this message
Savvas Radevic (medigeek) wrote : Re: [Bug 370999] Re: reports 0% until finished, also slowly burning at speed 0.3x or 0.5x

> And where is the fix?

It said "Changed in: brasero", not "Changed in: brasero (Ubuntu)", the
fix for Ubuntu is not applied yet.

Revision history for this message
Nandox7 (nandox7) wrote :

As it is stated there the problem seems to be the plugin used.
I also had this problem, as it was using wodim to burn the iso instead of growisofs.
To remove wodim is not possible in a clean way as Brasero is marked to depend on it and it will be removed along with wodim.

But there is a quick and simple workaround to fix half of this problem.
Using Gnome Configuration Editor navigate too:

apps > brasero > config > priority

In there it list all the plugins found and their priority, by default all are in 0 so Brasero chooses the one that fit the best.

Two things can be done here either disable the plugin in this case wodim and that is done by changing the value to '-1' or
to increase the priority of the one we want and i went for growisofs and in that case giving it a value higher than 0.

In my case I did both:

growisofs-burn = 1 (raises the priority forcing it to be choose)
wodim-burn = -1 (disables it)

This fixed my problem regarding the wrong percentage been showed as soon as it reaches the 2GB mark as for the burning speed is still slow even while using growisofs.

Revision history for this message
Petar Velkovski (pvelkovski) wrote :

Thanks for the partial fix Nandox7. As for the slow burning speed, I noticed that when I choose the burning speed manually, in my case 8x instead of the "max" value, the burning is performed faster.

Revision history for this message
fleamour (gtx-swift) wrote :

What is correct file path from within Xubuntu Jaunty?

Revision history for this message
Lex Ross (lross) wrote :

The correct path would be:

~/.gconf/apps/brasero/config/priority/%gconf.xml

Edit the file with values mentioned above. To me, Brasero using wodim burns unreadable DVDs (wodim 9:1.1.9-1ubuntu1 64-bit).

Revision history for this message
Nandox7 (nandox7) wrote :

I kept doing some other tests with this, specially regarding the speed.
And the speed problem doesn't seem to be from Brasero but from growisofs or wodim.
Easily tested by calling growisofs directly, there is no change in the speed.

Some external links refer a problem with how the buffer works and how it detects the available memory, but supposedly a fix for that was released not long ago. Still, even passing params to define a size for the buffer had little impact, i noticed a slight increase in speed.

Also i noticed a interesting report where someone stated that it might be using wrongly the burn-proof feature of the burners ending in poor quality burns and slowing down the process. Unfortunately all my DVD burners have burn-proof so it was impossible to try out with one without.
On the other hand I don't see growisofs outputting anything related to that, so I'm not sure if this can be a problem.

Revision history for this message
Savvas Radevic (medigeek) wrote :

> To me, Brasero using wodim
> burns unreadable DVDs (wodim 9:1.1.9-1ubuntu1 64-bit).

1. Try burning at lower speeds (e.g. 2x or 4x)
2. Try with a different dvd burner (I mean your device/hardware, not
the software).

I tried with a DVD-rewritable disc (4.0x maximum speed):
- burning 1.6GB image
- burning 4.3GB image
- burning 3.3GB of data

All successful!

Revision history for this message
Savvas Radevic (medigeek) wrote :

Ah wait, the problematic plugin is *wodim*. You should be using
*growisofs* instead of wodim.
Change the priority, it was mentioned earlier. :)

http://blog.radevic.com/2009/08/workaround-for-brasero-error-when.html

Revision history for this message
fleamour (gtx-swift) wrote :

Thanks.

Revision history for this message
Suco (sucotronic) wrote :

The workaround solves the problem in a dirty way. It will be better to release a fixed version of Brasero via Ubuntu Update.

Revision history for this message
fleamour (gtx-swift) wrote :

I agree, that fix means Brasio no longer supports my CDRW discs. Have reverted to normal priority & wodim.

Changed in brasero (Ubuntu):
importance: Low → Medium
Revision history for this message
Robert Ancell (robert-ancell) wrote :

The upstream bug was fixed in 2.27.4

Changed in brasero (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
fleamour (gtx-swift) wrote :

There only appears to be 2.26.1 in Xubuntu repository?

Changed in brasero:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.