the system freeze when I insert an audio cd

Bug #367767 reported by Alexandre Touret on 2009-04-27
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Hello,
I' ve been just installing jaunty on my computer with the alternate cd.
When I insert an audio cd in my dvd player I always have a freeze. I m forced to reboot my computer. But, when I insert a data cd or dvd, everything works fine.
This 'functionality' worked fine before ( up to 8.10).

This dvd player is installed into 'slave' mode. When I insert an audio cd in my dvd burner which is installed in 'master' mode, it s ok

Unfortunately, I can only provide the log provided by syslog :

syslog:Apr 27 20:49:37 littlewing-desktop kernel: [ 2.078868] sr1: scsi3-mmc drive: 12x/50x cd/rw xa/form2 cdda tray
syslog:Apr 27 20:49:37 littlewing-desktop kernel: [ 2.078919] sr 1:0:1:0: Attached scsi CD-ROM sr1
syslog:Apr 27 20:56:12 littlewing-desktop kernel: [ 2.067798] sr1: scsi3-mmc drive: 12x/50x cd/rw xa/form2 cdda tray
syslog:Apr 27 20:56:12 littlewing-desktop kernel: [ 2.067849] sr 1:0:1:0: Attached scsi CD-ROM sr1
syslog:Apr 27 21:24:23 littlewing-desktop kernel: [ 2.074383] sr1: scsi3-mmc drive: 12x/50x cd/rw xa/form2 cdda tray
syslog:Apr 27 21:24:23 littlewing-desktop kernel: [ 2.074443] sr 1:0:1:0: Attached scsi CD-ROM sr1
syslog:Apr 27 21:29:40 littlewing-desktop kernel: [ 4.974242] sr1: scsi3-mmc drive: 0x/50x cd/rw xa/form2 cdda tray
syslog:Apr 27 21:29:40 littlewing-desktop kernel: [ 4.974309] sr 5:0:1:0: Attached scsi CD-ROM sr1
syslog:Apr 27 21:35:40 littlewing-desktop kernel: [ 2.104842] sr1: scsi3-mmc drive: 0x/50x cd/rw xa/form2 cdda tray
syslog:Apr 27 21:35:40 littlewing-desktop kernel: [ 2.104963] sr 1:0:1:0: Attached scsi CD-ROM sr1
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.841479] end_request: I/O error, dev sr1, sector 0
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.843038] Buffer I/O error on device sr1, logical block 0
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.843091] Buffer I/O error on device sr1, logical block 1
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.843146] Buffer I/O error on device sr1, logical block 2
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.843198] Buffer I/O error on device sr1, logical block 3
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.843251] Buffer I/O error on device sr1, logical block 4
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.843303] Buffer I/O error on device sr1, logical block 5
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.843356] Buffer I/O error on device sr1, logical block 6
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.843408] Buffer I/O error on device sr1, logical block 7
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.855010] end_request: I/O error, dev sr1, sector 0
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.855065] Buffer I/O error on device sr1, logical block 0
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.865749] end_request: I/O error, dev sr1, sector 4
syslog:Apr 27 21:35:42 littlewing-desktop kernel: [ 99.865803] Buffer I/O error on device sr1, logical block 1
syslog:Apr 27 21:50:31 littlewing-desktop kernel: [ 2.088437] sr1: scsi3-mmc drive: 0x/50x cd/rw xa/form2 cdda tray
syslog:Apr 27 21:50:31 littlewing-desktop kernel: [ 2.088507] sr 1:0:1:0: Attached scsi CD-ROM sr1

You could see the output of lspci in the file I attached to this bug report.

Thanks in advance.
Regards

description: updated
Alexandre Touret (atouret) wrote :
description: updated
tags: added: freeze jaunty
Alexandre Touret (atouret) wrote :

According to this post : http://forum.ubuntu-fr.org/viewtopic.php?pid=2595566#p2595566
You could see, if you understand french language , that the main problem is the brasero library. After remove "libbrasero-média-0" the dvd reader works fine !!!

I guess you can confirm that bug in the package "libbrasero-media-0"

Regards

sam tygier (samtygier) on 2009-04-28
affects: ubuntu → brasero (Ubuntu)
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in brasero (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
Alexandre Touret (atouret) wrote :

Hello
Sorry for the late answer.
I have tried to install the debugsym packages but I have no log . I guess my desktop freezes before log anything in the .xsession-errors

Gordon Fick (ghfick) wrote :

Thank you, Alexandre
I had the same problem with my Dell Inspiron 8100. With a fresh install of 9.04, Data CDs and DVDs played fine but Audio CDs hung my machine. Seeing the issue was related to Brasero, I uninstalled Brasero and deleted all sundry files connected to Brasero.
Now the DVD drive recognizes Audio CDs and all is well again. For CD burning, I have had success using X-CD-roast for several years. I think I will stay away from Brasero for the time being.

Jonas Eberle (jonas-eberle) wrote :

You could check for the actions taken by your Desktop Environment when inserting an Audio CD:

nautilus-file-management-properties

Schily (schilling-fokus) wrote :

Just a note: XCD-roast is based on cdrtools.....and it
does not issue own SCSI commands directly but
rather calls cdrtools for all communication to the drives.
As a result, xcdroast

brasero seems to use cdrdao for audio. cdrdao did not
introduce new features since 5 years and it did not indroduce
bug-fixes since three years.

For data media un ubuntu, brasero uses a buggy and dead
cdrtools fork instead of the orgiginal software.

The original software (see cdrecord.berlios.de) is of course still
actively maintained and releases new versions on a regular
base. Reported and reproducable bugs are typically fixed
with a few hours in the original software.

Hello,
I also set the cd audio device with the parameter " do nothing "
(probably the english translation) and I always have the same result

Regards

2009/5/8 Jonas Eberle <email address hidden>:
> nautilus-file-management-properties

Martin G Miller (mgmiller) wrote :

This problem seems to be brand &/or DMA speed specific for the DVD drive. I have an Asus DVD-E616P3 with firmware 1.06 that will freeze the system every time with audio CD's. When I swap it out for an old Pioneer DVD-500M or TSSTcorp DVD burner, I have no problems. The main difference is the Asus is DMA 100 which freezes, the Pioneer is DMA 66 which is good and the TSST drive is DMA 33 which is also good. Perhaps it has something to do with the transfer speed of the drives? An Optiarc SATA DVD burner in the same system works fine.

I also have another computer with a fresh Jaunty install with an Asus DVD-E616P2 with firmware 1.08 that will not mount audio cd's. At least it does not freeze the system. This drive is also DMA 100. A Plextor Px-716A Firmware 1.06 in the same machine that runs at DMA 66 accepts audio cd's just fine.

So, could it be something about brasero and PATA UDMA 100 optical drives?

Dibya Sanyal (sanyaldibya) wrote :

Hi,
I am facing similar issue in Karmic. I have Karmic installed in my HP Laptop with internal DVD-ROM drive. In general I get the pop-up notification 'which program should be used to open the CD' if I pop in a Audio CD. But for some Audio CDs esp. for Audio book CDs Karmic will freeze when the CD tries to boot up. Display will garble, keybord and mouse will hand. I had to do a hard-boot to restart Karmic. This happens every time I put in the same specific CD. I have tried playing the same CD in Windows Vista - it plays fine. I could even rip it. This problem does not happen with all Audio CDs - only with specific ones.
I can cut a copy of the CD and mail if you want.

Dibya Sanyal (sanyaldibya) wrote :

Forgot to mention...
Karmic works fine for DVD or data CD. This problem occurs with Audio CDs only.

Martin G Miller (mgmiller) wrote :

For Dibya Sanyal...this is not a fix for the bug, just a work around so you don't have to hard reboot.

If you hold down the alt and scroll lock (sysreq) keys and while holding them down, press k, you should restart x without having to reboot.

This can also be set back to the old standard of ctrl / alt / backspace in Karmic by going to System > Preferences > Keyboard and then on the Layouts tab, Click on "Layout Options" and you will see a list of items. Click the triangle next to "key sequence to kill the x server" and put a check mark in the box next to "Control + Alt + Backspace" box, then click close.

If all this does not work, a safe way to force a reboot is to again hold down the alt and scroll lock (sysreq) keys and while holding them down, press in sequence, r s e i u b. Even when the system appears totally locked up, this "should" work.

Martin G Miller (mgmiller) wrote :

OOPS!, I made a slight mistake in the key sequence I listed in my last post. I meant to say the Print Screen (sysreq) key, NOT the Scroll Lock key.
That's what I get for doing a quick post here before my morning coffee.

Sorry about that....

piotr zimoch (ebytyes) on 2013-05-26
Changed in brasero (Ubuntu):
status: Incomplete → New
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Invalid
status: Invalid → Confirmed
status: Confirmed → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers