nautilus. GLib-ERROR **: ... failed to allocate 1073741824 bytes

Bug #366526 reported by Vital Fadeev
8
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Start LiveCD Ubuntu Desktop 9.04 (i386).

In desktop no icons.
I run terminal and try run nautilus:
ubuntu@ubuntu:~$ nautilus

GLib-ERROR **: /build/buildd/glib2.0-2.20.1/glib/gmem.c:156: failed to allocate 1073741824 bytes
aborting...
Aborted (core dumped)

My PC hardware:
RAM 512 MB
CPU Athlon64

Revision history for this message
Vital Fadeev (adisk-deactivatedaccount) wrote :

Solved.
Just use Ubuntu-desktop-9.04.amd64.iso

Thanks.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
Ariszló (ariszlo) wrote :

It seems that Ubuntu 9.04 requires more RAM than advertised. This machine has:

* Intel(R) Celeron(R) CPU 1.70GHz
* NV11 [GeForce2 MX/MX 400]
* 512 MB RAM

Revision history for this message
Sebastien Bacher (seb128) wrote :

the log indicates a brasero issue, could you be one of the issue that the new candidate update version solve

affects: nautilus (Ubuntu) → brasero (Ubuntu)
Changed in brasero (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Incomplete → New
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Vitaly, may you please try to reproduce the same with brasero from the proposed repositories and comment back? Thanks in advance.

Changed in brasero (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete
Revision history for this message
Vital Fadeev (adisk-deactivatedaccount) wrote :

I such solve problem:
Install Ubuntu-desktop-9.04 compiled for amd64 platform.

Reproduce bug unavailable.

Changed in brasero (Ubuntu):
status: Incomplete → Fix Committed
Revision history for this message
giovani (wejick-gmail) wrote :

I confirm this problem on my jaunty.
first time my nautilus work well. i think i update the nautilus package but i forgot it.
spec:
pent 4 2.6
ram 512
jaunty with 32 bit stock kernel
nautilus package version: 1:2.26.2-0ubuntu1
brasero package version: 2.26.0-ubuntu3

sory for my bad in english.

Revision history for this message
giovani (wejick-gmail) wrote :

oh and my pc cant run 64bit code so dont ask me to run 64 bit edition.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Closing based on comments saying fixed in Ubuntu 9.04

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
ofb (cottlestonpie) wrote :

This isn't fixed. I have the same error as described in original post, except CPU AthlonXP.

The i386 9.04 LiveCD was downloaded and burned last night. Memtest OK, disk integrity OK, checksum OK.

Tried to get valgrind log for you, but lacking Nautilus, I got stuck for how to locate & attach. Tried to install Dolphin, but installation failed due to crashes.

FWIW, the 8.04 LiveCD works fine.

Revision history for this message
ofb (cottlestonpie) wrote :

Aha - fix is in the pipeline. Thanks, folks.

(Solution is to update Brasero to version from Proposed. Thread here.
http://ubuntuforums.org/showthread.php?t=1135678 )

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments