Jaunty: Nautilus triggering segfault under Vmware

Bug #361882 reported by John Morris on 2009-04-15
2
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Low
Unassigned

Bug Description

Just installed the 9.04 beta into a new Vmware workstation VM. All ok until I tell Vmware to use an iso as the virtual CD. File manager repeatedly tries to auto-start, but repeatedly fails. Stops trying when I tell Vmware to roce unmount to iso image.

Environment:

VMware workstation, 6.5.2 build-156735
Host: Windows XP Professional 5.1.2600, Service pack 2
Ubuntu: 9.04 Beta, downloaded April 15 2009.

Tail from /var/log/messages:

Apr 15 10:02:19 jrm-904beta syslogd 1.5.0#5ubuntu3: restart.
Apr 15 10:03:26 jrm-904beta kernel: [ 2044.932700] nautilus[19379]: segfault at b6321002 ip b62eed10 sp b6236f70 error 4 in libbrasero-media.so.0.1.1[b62e0000+1e000]
Apr 15 10:07:50 jrm-904beta kernel: [ 2309.543765] nautilus[21315]: segfault at b6321002 ip b6419d10 sp b61f6f70 error 4 in libbrasero-media.so.0.1.1[b640b000+1e000]
Apr 15 10:11:46 jrm-904beta kernel: [ 2545.173351] nautilus[23258]: segfault at c ip b73bd0f6 sp b6364e28 error 4 in libc-2.9.so[b734b000+15c000]
Apr 15 10:12:43 jrm-904beta kernel: [ 2601.720133] nautilus[23497]: segfault at 9cf7002 ip b654bd10 sp b4993f70 error 4 in libbrasero-media.so.0.1.1[b653d000+1e000]

dmesg | tail:

j@jrm-904beta:~$ dmesg | tail
[ 1802.983843] nautilus[17011]: segfault at b6321002 ip b6434d10 sp b6208f70 error 4 in libbrasero-media.so.0.1.1[b6426000+1e000]
[ 1836.738734] nautilus[17258]: segfault at a202002 ip b6546d10 sp b648ef70 error 4 in libbrasero-media.so.0.1.1[b6538000+1e000]
[ 1934.750586] nautilus[18467]: segfault at 8ecf002 ip b650ed10 sp b6456f70 error 4 in libbrasero-media.so.0.1.1[b6500000+1e000]
[ 1942.996051] nautilus[18522]: segfault at 9cf8002 ip b63c8d10 sp b6310f70 error 4 in libbrasero-media.so.0.1.1[b63ba000+1e000]
[ 1956.970108] nautilus[18613]: segfault at 9b63002 ip b6550d10 sp b6368f70 error 4 in libbrasero-media.so.0.1.1[b6542000+1e000]
[ 1976.532890] nautilus[18740]: segfault at b6421002 ip b637ad10 sp b62c2f70 error 4 in libbrasero-media.so.0.1.1[b636c000+1e000]
[ 2044.932700] nautilus[19379]: segfault at b6321002 ip b62eed10 sp b6236f70 error 4 in libbrasero-media.so.0.1.1[b62e0000+1e000]
[ 2309.543765] nautilus[21315]: segfault at b6321002 ip b6419d10 sp b61f6f70 error 4 in libbrasero-media.so.0.1.1[b640b000+1e000]
[ 2545.173351] nautilus[23258]: segfault at c ip b73bd0f6 sp b6364e28 error 4 in libc-2.9.so[b734b000+15c000]
[ 2601.720133] nautilus[23497]: segfault at 9cf7002 ip b654bd10 sp b4993f70 error 4 in libbrasero-media.so.0.1.1[b653d000+1e000]

Other info in the attached files.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: VMware, Inc. VMware Virtual Platform
Package: linux-image-2.6.28-11-generic 2.6.28-11.37
ProcCmdLine: root=UUID=2ac49da5-ed3c-41e2-bb92-734dc45347e4 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-11.37-generic
SourcePackage: linux

John Morris (john-kirsta) wrote :

Based on the error messages there is a segfault in libbrasero-media. Not a kernel bug so I'm reassigning to brasero. However, this looks like it may be a duplicate of bug 339993 which was marked Fix Released in brasero - 2.26.0-0ubuntu2 . You may want to verify you've got this updated version first. Thanks.

affects: linux (Ubuntu) → brasero (Ubuntu)
Changed in brasero (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
John Morris (john-kirsta) wrote :

Yes, that was it - updating brasero fixed it - duplicate.

Thanks.

Carlos Lerzundy (arepaking) wrote :

This bug is not fixed. I am experiencing the same behavior but when pluging/unpluging an USB hard drive.

Pedro Villavicencio (pedro) wrote :

Thanks for the report John Morris , It has been a long time without any comment or a duplicate in this bug report and It is possible that the bug has been fixed. May you please try to reproduce it with the latest Stable Release of Ubuntu the Natty Narwhal and add the respective comments to the report? You can learn how to get that release at http://www.ubuntu.com/download . Thanks again and we appreciate your help.

Changed in brasero (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Launchpad Janitor (janitor) wrote :

[Expired for brasero (Ubuntu) because there has been no activity for 60 days.]

Changed in brasero (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers