Brasero crashes when pasting from an (empty?) clipboard

Bug #345177 reported by Matthäus Brandl on 2009-03-19
8
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Critical
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs
Jaunty
Undecided
Pedro Fragoso

Bug Description

Binary package hint: brasero

Brasero crashes without any error mesage (it just closes) if you try to do copy and paste in an audio project.
Steps to reproduce:
1) open a new audio project
2) add a file (in my case a mp3) to the project
3) mark this file
4) press Ctrl-C to copy
5) paste with Ctrl-V => crash

% brasero --version
GNOME brasero 0.8.3
on Intrepid

Andreas Moog (ampelbein) wrote :

Thank you for your bug-report. Could you please try versio 0.9.1-0ubuntu3~intrepid1 from intrepid-backports? See https://help.ubuntu.com/community/UbuntuBackports for information on how to enable. Version 0.8.3 seems not to be published in intrepid, did you compile it yourself?

Changed in brasero (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Matthäus Brandl (matthaeus) wrote :

Oh I'm sorry, because of Bug #294268 I did compile it myself. I forgot to use --prefix=/usr though, that's why I had two versions installed. (I had reverted to the package manager when the fix was committed)
However this bug still affects version 0.9.1 from the Intrepid backports. The output to the terminal is as follows:

% brasero
zsh: segmentation fault brasero

Andreas Moog (ampelbein) wrote :

OK, please follow the instructions at https://wiki.ubuntu.com/DebuggingProgramCrash and attach a backtrace with full debug-symbols to your report. The needed packages are:
brasero-dbgsym, libtotem-plparser12-dbgsym, libglib2.0-0-dbgsym, libgtk2.0-0-dbgsym

Thanks.

Matthäus Brandl (matthaeus) wrote :

Before following your suggestions, I wanted to attach the output of "braser --debug", but the funny thing is that I can't reproduce the error any more.
But I made an interesting discovery. It seems that you can't copy an element of the brasero content list but you can paste to the content list. (the list which shows you which (audio) files were already added to the project) Actually this behaviour is somewhat logical, who wants to have the same track several times on his disc? (I did)
So this time brasero tried to import "gpg -o - --export 428D7C01 | sudo apt-key add -" on Ctrl-V because that was the last string I had copied. (from the manuel you linked)
So it seems that it was whatever I had copied to my clipboard the other day what crashed brasero.
My proposal is to check the clipboard content before pasting and adding it to the project. (only files allowed)

Please let me know if I can help you in other ways with this bug...

Matthäus Brandl (matthaeus) wrote :

I changed the summary according to my last comment

a backtrace is needed in order to see where it's crashing, please try to obtain one with the instructions previously described, thanks.

Matthäus Brandl (matthaeus) wrote :

Well I'm lucky, pasting is crashing brasero at the moment, it seems that the clipboard is actually empty...
I'm attaching the output of "brasero --debug", the backtrace will follow soon

Matthäus Brandl (matthaeus) wrote :

I'm lucky, I succeded in generating the backtrace, but as I don't know how to install the *-dbgsym for backported apps, this is for GNOME brasero 0.8.2 (ie not from the backports)

Matthäus Brandl (matthaeus) wrote :

I'm almost sure that brasero crashes because I paste an empty clipboard. Now my clipboards isn't empty anymore, so as well no crash anymore

Matthäus Brandl (matthaeus) wrote :

This problem also exists in version 2.26.0 from http://projects.gnome.org/brasero/

Andreas Moog (ampelbein) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.gnome.org/show_bug.cgi?id=576928

Changed in brasero (Ubuntu):
status: Incomplete → Triaged
Changed in brasero:
status: Unknown → New
Yann Simon (yann-simon-fr) wrote :

The bug was fixed upstream. Please backport the patch. Thanks!

Changed in brasero:
status: New → Fix Released
Andreas Moog (ampelbein) wrote :

Fixed upstream, will be included in 2.26.1

Changed in brasero (Ubuntu):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Accepted brasero into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in brasero (Ubuntu Jaunty):
assignee: nobody → Pedro Fragoso (ember)
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.26.1-0ubuntu1

---------------
brasero (2.26.1-0ubuntu1) jaunty-proposed; urgency=low

  * New upstream release (LP: #361224)
    - Fix bgo #576439 – nautilus crash because of probable double g_free in
      brasero_medium_get_css_feature (Philippe Rouquier)
    - Fix bgo #575904 - Remove unneeded signal connection and rename callback.
      Fixes crash on Rhythmbox playlist import. (Luis Medinas) (LP: #288392)
    - Fix bgo #576564 – brasero crashed with SIGSEGV in brasero_image_format_get_cdrdao_size()
      (LP: #346784)
    - Fix bgo #576928 – Brasero crashes when pasting empty clipboard. (LP: #345177)
    - Fix bgo #573929 – nautilus crashed with SIGSEGV in start_thread() (Philippe
      Rouquier) (LP: #335942)
    - Fix bgo 573859 – Several 'Make Cover' buttons in Disc Copy dialog (LP: #347637)
    - Fix bgo #578677 - Registered property name in BraseroDriveSelectionClass is
      translated on runtime. (Luis Medinas) (LP: #578677) (LP: #360884)
  * debian/patches/02_css_double_free.patch:
    - Removed, the change is in the tarball

 -- Pedro Fragoso <email address hidden> Tue, 14 Apr 2009 17:59:04 +0100

Changed in brasero (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Sorry, this is a Launchpad bug. I copied the jaunty-proposed update to karmic. Fixing tasks accordingly.

Changed in brasero (Ubuntu Jaunty):
status: Fix Released → Fix Committed
Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
Matthäus Brandl (matthaeus) wrote :

As far as I can see, this bugs seems fixed. No crash and the "Paste" entry in the context menu is grayed with an empty clipboard.
Thanks

Martin Pitt (pitti) on 2009-05-04
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.26.1-0ubuntu1

---------------
brasero (2.26.1-0ubuntu1) jaunty-proposed; urgency=low

  * New upstream release (LP: #361224)
    - Fix bgo #576439 – nautilus crash because of probable double g_free in
      brasero_medium_get_css_feature (Philippe Rouquier)
    - Fix bgo #575904 - Remove unneeded signal connection and rename callback.
      Fixes crash on Rhythmbox playlist import. (Luis Medinas) (LP: #288392)
    - Fix bgo #576564 – brasero crashed with SIGSEGV in brasero_image_format_get_cdrdao_size()
      (LP: #346784)
    - Fix bgo #576928 – Brasero crashes when pasting empty clipboard. (LP: #345177)
    - Fix bgo #573929 – nautilus crashed with SIGSEGV in start_thread() (Philippe
      Rouquier) (LP: #335942)
    - Fix bgo 573859 – Several 'Make Cover' buttons in Disc Copy dialog (LP: #347637)
    - Fix bgo #578677 - Registered property name in BraseroDriveSelectionClass is
      translated on runtime. (Luis Medinas) (LP: #578677) (LP: #360884)
  * debian/patches/02_css_double_free.patch:
    - Removed, the change is in the tarball

 -- Pedro Fragoso <email address hidden> Tue, 14 Apr 2009 17:59:04 +0100

Changed in brasero (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in brasero:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.