Unable to use DVD/CD Drive

Bug #337160 reported by bra10n on 2009-03-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Low
Unassigned

Bug Description

I have lost the use of DVD drive. Upon insertion of any CD/DVD, I get many, many open windows along the panel "Starting File Manager" until I eject the disk and all then slowly close.
Jaunty 9.04 (up-to-date)

I browsed System Log and under Messages Tuesday, 3 March found the following;

bra10n-desktop syslogd 1.5.0#5ubuntu3: restart.
Mar 3 20:17:00 bra10n-desktop -- MARK --
Mar 3 20:37:00 bra10n-desktop -- MARK --
Mar 3 20:42:29 bra10n-desktop kernel: [ 3954.056221] eth0: link down
Mar 3 20:42:32 bra10n-desktop kernel: [ 3957.637541] eth0: link up, 10Mbps, half-duplex, lpa 0x0000
Mar 3 20:57:00 bra10n-desktop -- MARK --
Mar 3 21:02:09 bra10n-desktop kernel: [ 5133.808790] nautilus[8269]: segfault at a008008 ip b54707dd sp b3315fc0 error 4 in libbrasero-media.so.0.1.1[b5460000+1e000]
Mar 3 21:02:11 bra10n-desktop kernel: [ 5136.543644] nautilus[8277]: segfault at 9093000 ip b56007dd sp b55eefc0 error 4 in libbrasero-media.so.0.1.1[b55f0000+1e000]
Mar 3 21:02:12 bra10n-desktop kernel: [ 5137.373371] nautilus[8288]: segfault at 861d008 ip b54fa7dd sp b54e8fc0 error 4 in libbrasero-media.so.0.1.1[b54ea000+1e000]
Mar 3 21:02:13 bra10n-desktop kernel: [ 5137.971795] nautilus[8292]: segfault at 86a1008 ip b546c7dd sp b545afc0 error 4 in libbrasero-media.so.0.1.1[b545c000+1e000]
Mar 3 21:02:13 bra10n-desktop kernel: [ 5138.560780] nautilus[8296]: segfault at 87f3008 ip b55567dd sp b5544fc0 error 4 in libbrasero-media.so.0.1.1[b5546000+1e000]
Mar 3 21:02:14 bra10n-desktop kernel: [ 5139.155183] nautilus[8300]: segfault at 9496008 ip b545a7dd sp b5448fc0 error 4 in libbrasero-media.so.0.1.1[b544a000+1e000]
Mar 3 21:02:15 bra10n-desktop kernel: [ 5139.751639] nautilus[8304]: segfault at 865c008 ip b556a7dd sp b5558fc0 error 4 in libbrasero-media.so.0.1.1[b555a000+1e000]
Mar 3 21:02:15 bra10n-desktop kernel: [ 5140.342402] nautilus[8308]: segfault at 85b7008 ip b55d37dd sp b55c1fc0 error 4 in libbrasero-media.so.0.1.1[b55c3000+1e000]
Mar 3 21:02:16 bra10n-desktop kernel: [ 5140.940146] nautilus[8312]: segfault at a30d008 ip b56217dd sp b560ffc0 error 4 in libbrasero-media.so.0.1.1[b5611000+1e000]
Mar 3 21:02:16 bra10n-desktop kernel: [ 5141.529790] nautilus[8316]: segfault at 9076008 ip b55b87dd sp b55a6fc0 error 4 in libbrasero-media.so.0.1.1[b55a8000+1e000]
Mar 3 21:17:00 bra10n-desktop -- MARK --

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instuctions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in brasero:
status: New → Invalid
matli (stephane-davy) wrote :

Hello,

I have the same behavior on my Jaunty. I don't remember when it happened first, around the end of March, but now, each time I try to insert something in my DVD reader / burner, nautilus crashes. I can see the following kind of error messages in /var/log /messages:
Apr 17 12:53:39 vd01 kernel: [12209.902032] nautilus[12221]: segfault at 8cda000 ip b50547dd sp b36c2fc0 error 4 in libbrasero-media.so.0.1.1[b5044000+1e000]

Deinstalling libbrasero-media allow me using my DVD reader, but brasero is no longer installed.

JoseStefan (josestefan) wrote :

I also have the same problem I think,

I tested this right now:
1) I made sure I had all the updates, applied them and restarted.
2) Logged in
3) Waited a few seconds and put a recorded CDRW media:

Result:
First thing I noticed was all my icons on the desktop disappeared.
dmesg says:
[ 153.025715] nautilus[4276]: segfault at 9786000 ip b59d17dd sp b3365fc0 error 4 in libbrasero-media.so.0.1.1[b59c1000+1e000]

JoseStefan (josestefan) wrote :

As a temporary fix I've also removed "libbrasero-media0"
and went back to "nautilus-cd-burner"

JoseStefan (josestefan) wrote :

After seeing the error happen in dmesg, I don't see anything in /var/crash
launching brasero by right clicking an iso image algo triggers a similar segfault

[11122.754012] brasero[9201]: segfault at 910b008 ip b80477dd sp b67b2fa0 error 4 in libbrasero-media.so.0.1.1[b8037000+1e000]

matli (stephane-davy) on 2009-04-18
Changed in brasero (Ubuntu):
status: Invalid → Confirmed
JoseStefan (josestefan) wrote :

I found the crash file by restarting apport first (https://wiki.ubuntu.com/Apport)
Then launching brasero.

I can't seem to right clicking and open with "Report a problem.."

It reads:
'Sorry, the program "brasero" closed unexpectedly'
'Your computer does not have enough free memory to automatically analyze the problem and send a report to the developers.'

So I am uploading the file directly.

While the bug has still not been fixed, the issue of Nautilus spawning multiple windows initially reported no longer occurs. A crash report is not generated either.

Can I ask why the "Importance" status on this is still set as "undecided", when this bug seems to be affecting more and more users of Jaunty?

Rob Taylor (rstemail) wrote :

I'm also experiencing this problem on Jaunty. Haven't noticed for a while, but a pain not being able to use brasero any more. This being looked at?

timo (osborntandj) wrote :

Never had the multiple windows open, but ever since I installed Jaunty, if i put any disk in the cd/rw drive Nautilus crashes.

Maybe I'll drop Brasero too, so that I can avoid the hassle of having to restart the machine everytime I use the cd/rw drive.

Changed in brasero (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers