Brasero - recognises a 4.7 gb writable dvd as 4.3 gb

Bug #315913 reported by asifanwar98 on 2009-01-10
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Brasero
Expired
Wishlist
brasero (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: brasero

See attached screen print it shows Brasero not having any option for a 4.7 gb dvd. I presume there is a config file some were which lists standard cd and dvd sizes (not sure where though ?).

ProblemType: Bug
Architecture: i386
DistroRelease: LinuxMint 6
ExecutablePath: /usr/bin/brasero
Package: brasero 0.8.2-0ubuntu1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: brasero
Uname: Linux 2.6.27-7-generic i686
UnreportableReason: This is not a genuine LinuxMint package

asifanwar98 (asifanwar98) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for your report, could you run brasero from the command line as: brasero --debug &> brasero-debug.txt perform the operation to reproduce the bug and attach the resulting file to the report?. Thanks in advance

Changed in brasero:
importance: Undecided → Low
status: New → Incomplete
Mike Trim (miketrim) wrote :

This is not a bug, it is just that the DVD makers describe their disc capacity using GB = 1000^3, but brasero is reporting the capacity using GB = 1024^3. See http://en.wikipedia.org/wiki/DVD-R#Recordable_DVD_capacity_comparison.

Changed in brasero:
status: Incomplete → Invalid
Ben M. (bmhm) wrote :

@Mike:
If it used GB as in 1000^3, it would say "4.7 GB". The 4.3 are referring to GiB (4.7 GB ~= 4.3 GiB).

This is definitly a bug, since it uses wrong units.
See
    man 7 units
for more information.

Thus, I dare to reopen.

Changed in brasero (Ubuntu):
status: Invalid → Confirmed
Endolith (endolith) on 2010-03-13
tags: added: units-policy
Benjamin Drung (bdrung) wrote :

This is fixed in Ubuntu 10.04 (lucid) with the upload of glib2.0 2.23.5-1ubuntu2, which follows https://wiki.ubuntu.com/UnitsPolicy

Changed in brasero (Ubuntu):
status: Confirmed → Fix Released
Benjamin Drung (bdrung) wrote :

The attached screenshot shows two numbers: The ISO is 707.1 MB. When you burn the CD, 29.8 MB will be left. I summary, you can put 736.9 MB (~ 700 MiB) on the CD.

Endolith (endolith) wrote :

You're right. I misunderstood the complaint.

Benjamin Drung (bdrung) wrote :

With glib2.0 2.23.5-1ubuntu3 we are back at the previous state.

Changed in brasero (Ubuntu):
status: Fix Released → Triaged
Andreas Saurwein (saurwein) wrote :

Not sure if its the same bug but seems related:

When I open Brasero with an empty disk inserted already, click on Burn ISO Image, it shows me that there is an blank DVD with 4.3 Gb free inserted (though its 4.7 by manufacturer definition). Yet after choosing an ISO to burn (4.7 Gb), Brasero changes the information shown to "4.0 Gb free space". Somewhere between real free space and calculated free space after selecting ISO it gets lost.
I also cant burn any DVD where this happens. Brasero starts the process and gets stuck in "preparing to write" forever.

Changed in brasero:
importance: Unknown → Wishlist
status: Unknown → New
Changed in brasero:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.