Brasero segfault when opening pls within browser pane

Bug #288392 reported by Matthew Woerly on 2008-10-23
8
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Critical
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs
Jaunty
Undecided
Pedro Fragoso

Bug Description

Binary package hint: brasero

I opened Brasero and started an Audio CD project. I double clicked on a pls file in the browser, and Brasero segfaulted. I've attached gdb info. Let me know if you need any debugging packages added, there was no brasero-dbg, so I didn't know what was needed.
I guess I know you aren't supposed to add a pls file to an Audio CD, but I wanted the tracks from it on the CD, and in the least, it should not have crashed.

Matthew Woerly (nattgew) wrote :
Pedro Villavicencio (pedro) wrote :

thanks for the report, i cannot reproduce this behavior, can you get another backtrace? the one you submitted is missing a couple of symbols, please install the following packages and get a new one: brasero-dbgsym, libtotem-plparser12-dbgsym, libglib2.0-0-dbgsym, libgtk2.0-0-dbgsym ; thanks in advance.

Changed in brasero:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Matthew Woerly (nattgew) wrote :

Thanks for your reply.
The only package available to be with -dbgsym is pkg-create-dbgsym.
If I look for brasero, the only package I get is brasero. No debug symbol package.
libglib2.0-0-dbg was already installed.
I was able to find and install:
libtotem-plparser-dbg
libgtk2.0-0-dbg

I did another backtrace. I think it's still missing symbols. I looked in the us.archive.ubuntu.com pool but couldn't find a brasero-dbg package.

Pedro Villavicencio (pedro) wrote :

you need to add the sources listed at https://wiki.ubuntu.com/DebuggingProgramCrash to your sources.list and replace hardy for intrepid on it, then you'll be able to find those packages, thanks.

Matthew Woerly (nattgew) wrote :

I tried adding all of the ddebs and replacing hardy with intrepid, but it came back with 404 errors for all of them.
I changed them back to hardy and got dependency errors, because the hardy debug packages depend on the hardy versions.

Sebastien Bacher (seb128) wrote :

could you describe the changes you did exactly?

Matthew Woerly (nattgew) wrote :

Well I was trying to use the dbgsym packages before Intrepid was released, and apparently they weren't available at that time.
I installed all of those packages and did the backtrace again.

Andreas Moog (ampelbein) wrote :

I can reproduce this issue.

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.gnome.org/show_bug.cgi?id=575904

Changed in brasero (Ubuntu):
status: Incomplete → Triaged
Changed in brasero:
status: Unknown → New
Yann Simon (yann-simon-fr) wrote :

The bug was fixed upstream. The patch has to be backported. Thanks!

Changed in brasero:
status: New → Fix Released
Andreas Moog (ampelbein) wrote :

Fixed upstream, will be fixed with 2.26.1

Changed in brasero (Ubuntu):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Accepted brasero into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in brasero (Ubuntu Jaunty):
assignee: nobody → Pedro Fragoso (ember)
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.26.1-0ubuntu1

---------------
brasero (2.26.1-0ubuntu1) jaunty-proposed; urgency=low

  * New upstream release (LP: #361224)
    - Fix bgo #576439 – nautilus crash because of probable double g_free in
      brasero_medium_get_css_feature (Philippe Rouquier)
    - Fix bgo #575904 - Remove unneeded signal connection and rename callback.
      Fixes crash on Rhythmbox playlist import. (Luis Medinas) (LP: #288392)
    - Fix bgo #576564 – brasero crashed with SIGSEGV in brasero_image_format_get_cdrdao_size()
      (LP: #346784)
    - Fix bgo #576928 – Brasero crashes when pasting empty clipboard. (LP: #345177)
    - Fix bgo #573929 – nautilus crashed with SIGSEGV in start_thread() (Philippe
      Rouquier) (LP: #335942)
    - Fix bgo 573859 – Several 'Make Cover' buttons in Disc Copy dialog (LP: #347637)
    - Fix bgo #578677 - Registered property name in BraseroDriveSelectionClass is
      translated on runtime. (Luis Medinas) (LP: #578677) (LP: #360884)
  * debian/patches/02_css_double_free.patch:
    - Removed, the change is in the tarball

 -- Pedro Fragoso <email address hidden> Tue, 14 Apr 2009 17:59:04 +0100

Changed in brasero (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Sorry, this is a Launchpad bug. I copied the jaunty-proposed update to karmic. Fixing tasks accordingly.

Changed in brasero (Ubuntu Jaunty):
status: Fix Released → Fix Committed
Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

This update was tested successfully in bugs #335942, #346784 #360884 #361224, #345177. Considering sufficiently regression tested.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.26.1-0ubuntu1

---------------
brasero (2.26.1-0ubuntu1) jaunty-proposed; urgency=low

  * New upstream release (LP: #361224)
    - Fix bgo #576439 – nautilus crash because of probable double g_free in
      brasero_medium_get_css_feature (Philippe Rouquier)
    - Fix bgo #575904 - Remove unneeded signal connection and rename callback.
      Fixes crash on Rhythmbox playlist import. (Luis Medinas) (LP: #288392)
    - Fix bgo #576564 – brasero crashed with SIGSEGV in brasero_image_format_get_cdrdao_size()
      (LP: #346784)
    - Fix bgo #576928 – Brasero crashes when pasting empty clipboard. (LP: #345177)
    - Fix bgo #573929 – nautilus crashed with SIGSEGV in start_thread() (Philippe
      Rouquier) (LP: #335942)
    - Fix bgo 573859 – Several 'Make Cover' buttons in Disc Copy dialog (LP: #347637)
    - Fix bgo #578677 - Registered property name in BraseroDriveSelectionClass is
      translated on runtime. (Luis Medinas) (LP: #578677) (LP: #360884)
  * debian/patches/02_css_double_free.patch:
    - Removed, the change is in the tarball

 -- Pedro Fragoso <email address hidden> Tue, 14 Apr 2009 17:59:04 +0100

Changed in brasero (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in brasero:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.