Can't burn/erase cd using brasero

Bug #281633 reported by Emmanuel Pacaud on 2008-10-11
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: brasero

When I try to burn a data cd/dvd, or erase a cd/dvd, brasero fails with the following dialog:

Error while burning:
the drive can't be locked (Gravure du CD/DVD).

The log says:

Session error : the drive can't be locked (Gravure du CD/DVD) (brasero_burn_record burn.c:2524)

Burning/erasing works just fine using nautilus-cd-burner.

This is on an up to date Intrepid, using brasero:

brasero:
  Installé : 0.8.2-0ubuntu1
  Candidat : 0.8.2-0ubuntu1
 Table de version :
 *** 0.8.2-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

lrwxrwxrwx 1 root root 4 2008-10-11 09:04 dvd1 -> scd0
lrwxrwxrwx 1 root root 4 2008-10-11 09:04 dvdrw1 -> scd0
brw-rw----+ 1 root cdrom 11, 0 2008-10-11 09:03 scd0

With the default admin user, member of the cdrom group.

yoyoyo (muymuchabasura) wrote :

I confirm this bug

Log: Session error : no se puede bloquear la unidad (proceso de grabado en curso) (brasero_burn_record burn.c:2524)

Pedro Villavicencio (pedro) wrote :

thanks for the report, may you tell us a few easy steps in order to trigger the issue? burning here works fine, may you send us a brasero log while running brasero as: brasero --debug &> brasero-debug.txt , reproduce the bug and attach the resulting file to the report, thanks in advance.

Changed in brasero:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Dimas (dimasmjunior) wrote :

Hello, thanks for your help Pedro.

There's nothing special to do to trigger the bug, just try to record a data cd. I think it's important to tell that I'm using an Intel MacMini (slot loading cd).

The requested log is attached.

yoyoyo (muymuchabasura) wrote :

My beutifull log

Thanks ;]

Dimas (dimasmjunior) wrote :

What hardware are you guys using? I'm asking this because brasero says that "the drive can't be locked", so maybe it's related to slot loading optical unit (my case).

yoyoyo (muymuchabasura) wrote :

Pioneer dvd-rw dvr-107d

Dimas (dimasmjunior) wrote :

Looks like my drive is a Pioneer too. I'm attaching the result of "hdparm -I /dev/scd0".

yoyoyo: Comparing our logs, I see different errors. In your log, the burn fails in this line:

BraseroGrowisofs stderr: :-[ PERFORM OPC failed with SK=3h/POWER CALIBRATION AREA ERROR]: Input/output error

while in mine it fails in this:

(brasero:7452): BraseroBurn-DEBUG: At burn.c:2524: Session error : the drive can't be locked (Burning CD)

so I ask you, when the error you logged occurred, did you get the dialog that says "Error while burning: the drive can't be locked (Gravure du CD/DVD)."?

Pedro Villavicencio (pedro) wrote :

looks like http://bugzilla.gnome.org/show_bug.cgi?id=469667 , could you see if there's another instance of cdrecord running? for people there restarting hal make the recording works, does that works for you as well? thanks.

Changed in brasero:
status: New → Incomplete
kiroh (kiroh) wrote :

same problem here!
I'm attaching the result of "hdparm -I /dev/scd0".

Derek White (d-man97) wrote :
Download full text (3.3 KiB)

I am getting the same problem on my Sony DVD drive (DRU-830A) using Brasero.

Downloaded a mp3 for a friend: http://podcast.kingschurchjax.com/012509samw.mp3
Opened Brasero, clicked the button to start an Audio CD
Dragged the mp3 from my desktop to the Brasero window and dropped it
After a minute or two (its a big mp3 and I'm on a 1.5Ghz) the info loaded, and I changed the title/artist
Put in an 80 minute CD, canceled Ubuntu's blank CD auto-run dialog
Brasero automatically selected the CD I inserted
Clicked the Burn button, then clicked Properties
At this point, I see my weird speed listings: Max speed, 31.9 x (CD), 23.9 x (CD), 16.0 x (CD), 8.0 x (CD), 8.0 x (CD)

[ A tiny tangent. ]
Yup, that's two 8.0x speed settings. (Why? Another bug? Been like that forever, since my first Ubuntu: 7.10.)

Selected 16.0 x (CD) [As I said, I have a slower system - it can't keep up with 24x (or 23.9 x - stupid Brasero) and definitely not 32x]
Burn directly, and burnproof both checked
Simulate is grayed out
Eject is checked
Temp files set to /tmp with 3.9GB free-space
Clicked OK to start the burn process

Brasero took awhile (again) to prepare, then started burning it.
It got to roughly 7%, then started fixating the drive for some reason, like it would do when finished burning.
The dialog never went away. After about 5 minutes the graphics on the dialog would not redraw after minimize/restore and I clicked X, waited for it to not respond, and let Ubuntu stop it.

I removed the CD, it was partially burnt, Ubuntu loaded it up as an audio-cd with Japanese/Chinese text, lol, now part of my Tesla coil collection. I restarted Brasero, and started over using the same process detailed above, except I choose the top-most 8.0 x (CD) setting for the speed and unchecked burn directly without saving. When I hit OK to start the burn, I immediately got the "Session error : the drive can't be locked (ongoing burning process) (brasero_burn_record burn.c:2524)" error.

I closed down Brasero, checked System Monitor for Brasero, cdrecord, anything out of the ordinary. The only thing I found was that gvfsd-burn was open and using a third of a MB of memory; gvfsd-http was also open using half a MB, even with firefox closed down after dl'ing the mp3.

[ Questions about bug. ]
It seems like gvfs has been going through major updates lately, could gvfs-backends (which includes -burn) be causing this? Or is -burn only used with nautilus...

Anyways, that's where I am. I am sure a reboot would fix this, but there should be no reason for that.

My drive can be opened, closed, mounted, ejected, etc. all OK, why does Brasero think it's in use?
What does Brasero use to lock the drive for burning?
How can I reverse it, since the force quit of Brasero left it there?
Can this be done automatically when Brasero starts? (i.e. - check to see if drive is REALLY in use?)

[ Other thoughts. ]
Finally, if anyone can help me, why did Brasero start fixating after 7%? Shouldn't burnproof have prevented a buffer under-run?

P.S. - 'Places' > 'CD/DVD Creator' > Add a file...or more > 'Write to Disc' lists 37.6x, 28.2x, 18.8x, & 9.4x as my speeds. Why is everything different? My drive really can't do all ...

Read more...

Dimas (dimasmjunior) wrote :

Just tried to reproduce it again and found that I no longer have problems with Brasero. Maybe an update solved it.

Chucky Ellison (ellisonch) wrote :

I'm getting the same behavior. "Session error : the drive can't be locked (ongoing burning process) (brasero_burn_record burn.c:2524)". I had a failed burn using Ubuntu CD/DVD Creator, so I closed it and opened up Brasero. Any other suggestions for debugging help?

~$ ps -A | grep cd
~$

I have attached my debug file, and below is my hdparm -I /dev/scd0 :

ATAPI CD-ROM, with removable media
 Model Number: TSSTcorp CDDVDW SH-S203B
 Serial Number:
 Firmware Revision: SB01
Standards:
 Supported: CD-ROM ATAPI-3 -4 -5 -6 -7
Configuration:
 DRQ response: 50us.
 Packet size: 12 bytes
Capabilities:
 LBA, IORDY(can be disabled)
 DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5
      Cycle time: min=120ns recommended=120ns
 PIO: pio0 pio1 pio2 pio3 pio4
      Cycle time: no flow control=383ns IORDY flow control=120ns

suntania (ozerki) wrote :

same issue here
blowing out the dust and lowering the recording speed to 1x solved the issue.

piotr zimoch (ebytyes) on 2013-05-26
Changed in brasero (Ubuntu):
status: Incomplete → New
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Invalid
status: Invalid → Confirmed
status: Confirmed → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.