Brasero and nautilus-cd-burner cannot burn 4GiB file to DVD

Bug #205919 reported by Jonathan Ernst on 2008-03-24
62
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Brasero
Expired
Medium
nautilus-cd-burner
Expired
Medium
brasero (Baltix)
Undecided
Unassigned
brasero (Ubuntu)
Low
Ubuntu Desktop Bugs
nautilus-cd-burner (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

I'm unable to burn large files (4Gib+) using hardy with both Brasero and nautilus-cd-burner.

Here is the brasero log where the error is shown ("-allow-limited-size was not specified. There is no way do represent this file size. Aborting."):

Checking session consistency (brasero_burn_check_session_consistency burn.c:1714)
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_current_track
BraseroLocalTrack called brasero_job_get_input_type
BraseroLocalTrack no foreign URIs
BraseroLocalTrack stopping
BraseroMd5sumFile called brasero_job_get_output_type
BraseroMd5sumFile called brasero_job_get_current_track
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile deactivating
BraseroMd5sumFile called brasero_job_get_output_type
BraseroMd5sumFile called brasero_job_get_current_track
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile called brasero_job_get_input_type
BraseroMd5sumFile called brasero_job_get_current_track
BraseroMd5sumFile called brasero_job_set_current_action
BraseroMd5sumFile called brasero_job_set_progress
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile called brasero_job_get_input_type
BraseroMd5sumFile called brasero_job_get_current_track
BraseroMd5sumFile called brasero_job_add_track
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile finished track successfully
BraseroMd5sumFile stopping
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs getting varg
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_get_input_type
BraseroGrowisofs called brasero_job_get_flags
BraseroGrowisofs called brasero_job_get_speed
BraseroGrowisofs called brasero_job_get_device
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_get_session_output_size
BraseroGrowisofs called brasero_job_get_input_type
BraseroGrowisofs called brasero_job_get_fd_in
BraseroGrowisofs called brasero_job_get_current_track
BraseroGrowisofs called brasero_job_get_input_type
BraseroGrowisofs called brasero_job_get_tmp_dir
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_set_current_action
BraseroGrowisofs got varg:
 growisofs
 -use-the-force-luke=notray
 -speed=2
 -use-the-force-luke=tty
 -Z
 /dev/scd0
 -dry-run
 -r
 -J
 -iso-level
 3
 -udf
 -input-charset
 utf8
 -graft-points
 -D
 -path-list
 /tmp/brasero_tmp_95ER8T
 -exclude-list
 /tmp/brasero_tmp_273O8T
 -print-size
BraseroGrowisofs launching command
BraseroGrowisofs called brasero_job_get_fd_out
BraseroGrowisofs stdout: Executing 'genisoimage -r -J -iso-level 3 -udf -input-charset utf8 -graft-points -D -path-list /tmp/brasero_tmp_95ER8T -exclude-list /tmp/brasero_tmp_273O8T -print-size | builtin_dd of=/dev/scd0 obs=32k seek=0'
BraseroGrowisofs called brasero_job_set_dangerous
BraseroGrowisofs stderr: File /home/user/file.mkv is larger than 4GiB-1.
BraseroGrowisofs stderr: -allow-limited-size was not specified. There is no way do represent this file size. Aborting.
BraseroGrowisofs stdout: HUP
BraseroGrowisofs stderr: HUP
BraseroGrowisofs process finished with status 5
BraseroGrowisofs called brasero_job_error
BraseroGrowisofs finished with an error
BraseroGrowisofs asked to stop because of an error
 error = 0
 message = "no message"
BraseroGrowisofs stopping
BraseroGrowisofs got killed
Session error : unknown (brasero_burn_record burn.c:2273)

LeeV (leev) wrote :

From memory I think this is correct. The max file size on an iso 9660 format disk is 2GB.
If you use UDF (I'm not sure Brasero can do this) then you can burn up to the size of the disk.

kulight (kulight) wrote :
Download full text (3.5 KiB)

confirmed this one

i have the same problem

here is my error log:

Checking session consistency (brasero_burn_check_session_consistency burn.c:1714)
BraseroMd5sumFile called brasero_job_get_output_type
BraseroMd5sumFile called brasero_job_get_current_track
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile deactivating
BraseroMd5sumFile called brasero_job_get_output_type
BraseroMd5sumFile called brasero_job_get_current_track
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile called brasero_job_get_input_type
BraseroMd5sumFile called brasero_job_get_current_track
BraseroMd5sumFile called brasero_job_set_current_action
BraseroMd5sumFile called brasero_job_set_progress
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile called brasero_job_get_input_type
BraseroMd5sumFile called brasero_job_get_current_track
BraseroMd5sumFile called brasero_job_add_track
BraseroMd5sumFile called brasero_job_get_action
BraseroMd5sumFile finished track successfully
BraseroMd5sumFile stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack stopping
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_action
BraseroLocalTrack called brasero_job_get_current_track
BraseroLocalTrack called brasero_job_get_input_type
BraseroLocalTrack no foreign URIs
BraseroLocalTrack stopping
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs getting varg
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_get_input_type
BraseroGrowisofs called brasero_job_get_flags
BraseroGrowisofs called brasero_job_get_speed
BraseroGrowisofs called brasero_job_get_device
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_get_session_output_size
BraseroGrowisofs called brasero_job_get_input_type
BraseroGrowisofs called brasero_job_get_fd_in
BraseroGrowisofs called brasero_job_get_current_track
BraseroGrowisofs called brasero_job_get_input_type
BraseroGrowisofs called brasero_job_get_tmp_dir
BraseroGrowisofs called brasero_job_get_action
BraseroGrowisofs called brasero_job_set_current_action
BraseroGrowisofs got varg:
 growisofs
 -use-the-force-luke=notray
 -use-the-force-luke=dao
 -dvd-compat
 -speed=16
 -use-the-force-luke=tty
 -Z
 /dev/scd0
 -dry-run
 -r
 -J
 -iso-level
 3
 -udf
 -input-charset
 utf8
 -graft-points
 -D
 -path-list
 /tmp/brasero_tmp_9HOO9T
 -exclude-list
 /tmp/brasero_tmp_1UMQ9T
 -print-size
BraseroGrowisofs launching command
BraseroGrowisofs called brasero_job_get_fd_out
BraseroGrowisofs stdout: Executing 'genisoimage -r -J -iso-level 3 -udf -input-charset utf8 -graft-points -D -path-list /tmp/brasero_tmp_9HOO9T -exclude-list /tmp/brasero_tmp_1UMQ9T -print-size | builtin_dd of=/dev/scd0 obs=32k seek=0'
BraseroGrowisofs called brasero_job_set_dangerous
BraseroGrowisofs stderr: File /home/kulight/yotam/My Documents.part1.rar is larger than 4GiB-1.
BraseroGrowisofs stderr: -allow-limited-size was not specified. There is no w...

Read more...

Changed in brasero:
status: New → Confirmed
Changed in brasero:
status: Unknown → Confirmed
Johan Kröckel (jnkl) wrote :

Same problem here. I need a workaround!

Changed in nautilus-cd-burner:
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

Roni, may you please comment when you change the status on a bug? thanks.

Changed in brasero:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Triaged
Brian Pitts (bpitts) wrote :

BraseroGrowisofs stdout: Executing 'genisoimage -r -J -iso-level 3 -udf -input-charset utf8 -graft-points -D -path-list /tmp/brasero_tmp_9HOO9T -exclude-list /tmp/brasero_tmp_1UMQ9T -print-size | builtin_dd of=/dev/scd0 obs=32k seek=0'
BraseroGrowisofs stderr: -allow-limited-size was not specified. There is no way do represent this file size. Aborting.

Brasero is using UDF, but genisoimage can't create an image that is only udf. The solution to this bug is in the log; Brasero needs to use the -allow-limited-size option of genisoimage when there are files greater than 2GiB. This is what K3B does.

From the man page:

-allow-limited-size
              When processing files larger than 2GiB which cannot be easily
              represented in ISO9660, add them with a shrunk visible file size
              to ISO9660 and with the correct visible file size to the UDF
              system. The result is an inconsistent filesystem and users need
              to make sure that they really use UDF rather than ISO9660 driver
              to read a such disk. Implies enabling -udf.

 -udf Include UDF filesystem support in the generated filesystem
              image. UDF support is currently in alpha status and for this
              reason, it is not possible to create UDF-only images. UDF data
              structures are currently coupled to the Joliet structures, so
              there are many pitfalls with the current implementation. There
              is no UID/GID support, there is no POSIX permission support,
              there is no support for symlinks. Note that UDF wastes the
              space from sector ~20 to sector 256 at the beginning of the disc
              in addition to the space needed for real UDF data structures.

Changed in nautilus-cd-burner:
importance: Undecided → Low
assignee: nobody → desktop-bugs
status: Confirmed → Triaged
Changed in nautilus-cd-burner:
status: Unknown → New

I want to burn 162.2 MB to a 700 CD-R.
But Brasero reports that no space (0 MB) on the CD are available. But the CD-R is empty, I tested other CD-Rs too!

Confirmed here in Hardy with genisoimage 1.1.6 and Brasero 0.8.1.

Writing a 4.2 GB file onto a 4.3 DVD works seamlessly with k3b but doesn't work with brasero, because the latter doesn't use -allow-limited-size.

Tai Siew Joon (sjtai) wrote :

I'm having similar problem on Intrepid. The burning of an ISO file stopped after a short while (2 min). I've attached the debug output of brasero.

Brian Pitts (bpitts) wrote :

Tai Siew Joon, that looks like a different problem.

This bug is resolved for me in Brasero 0.8.2

Changed in nautilus-cd-burner:
status: New → Invalid
Changed in brasero:
status: Confirmed → Invalid
Changed in nautilus-cd-burner:
status: Invalid → Unknown
Changed in nautilus-cd-burner:
status: Unknown → Confirmed

Upstream marked the brasero bug as a duplicate. Reassigning to the right bug.

Changed in brasero:
status: Invalid → Unknown
Changed in brasero:
status: Unknown → Confirmed
silvio1964 (verdecchiasilvio) wrote :

I doesn`t know what`s happen;every attemp to burn a dvd will fail Brasero and Nautilus-burner and k3b will fail tooo "means to small temp" dir:

BraseroGrowisofs stderr: 0.45% done, estimate finish Thu Mar 19 14:31:31 2009
BraseroGrowisofs called brasero_job_get_current_action
BraseroGrowisofs called brasero_job_set_current_action
BraseroGrowisofs stderr: 0.68% done, estimate finish Thu Mar 19 14:29:04 2009
BraseroGrowisofs called brasero_job_get_current_action
BraseroGrowisofs called brasero_job_set_current_action
BraseroGrowisofs stderr: /dev/scd1: "Current Write Speed" is 2.0x1352KBps.
BraseroGrowisofs stderr: :-[ WRITE@LBA=0h failed with SK=4h/ASC=91h/ACQ=C2h]: Input/output error
BraseroGrowisofs stderr: :-( write failed: Input/output error
BraseroGrowisofs stdout: HUP
BraseroGrowisofs stderr: HUP
BraseroGrowisofs process finished with status 5
BraseroGrowisofs called brasero_job_error
BraseroGrowisofs finished with an error
BraseroGrowisofs asked to stop because of an error
 error = 0
 message = "no message"
BraseroGrowisofs stopping
BraseroGrowisofs got killed
Session error : unknown (brasero_burn_record burn.c:2653)

A.K.Karthikeyan (mindaslab) wrote :

Confirm this bug on Ubuntu 9.04, unable to burn large files using brasero and K3B

Schily (schilling-fokus) wrote :

This is a well known "cdrkit" Bug: "genisoimage" does
not support large files.

Solution: Upgrade to recent original software;

ftp://ftp.berlios.de/pub/cdrecord/alpha/

emarkay (mrk) wrote :

No action since May 2009. What is the status on this in Lucid?

Changed in brasero:
importance: Unknown → Medium
status: Confirmed → Expired
Changed in nautilus-cd-burner:
importance: Unknown → Medium
status: Confirmed → Expired
Damnated (damnated) wrote :

The bug is still present in Lucid, I can't write a 4.2 file to a 4.3 DVD. I tried using brasero and nautilus' drag and drop burner.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.