[Hardy] Brasero fails if CUE sheet only specifies filename

Bug #202546 reported by Rotbart van Dainig on 2008-03-15
8
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Medium
brasero (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Hardy by Sb

Bug Description

brasero 0.7.1-3

Situation:

Both .bin and .cue are in the same directory.
CUE sheet is opened with Brasero and tried to be burned.
(Tried doth with letting brasero choose image type and manually specifying .cue)

Burning fails with error:
size can't be retrieved for ToGuardianAngel.bin: No such file or directory.

However, after editing the CUE sheet to specify the full path in the FILE header instead of just the file name, Brasero burns happily.

As Brasero is the default application for burning CUE sheets, it should check the path of the CUE sheet for the image before failing - hard paths are not usual in CUE sheets.

Related branches

Timo Aaltonen (tjaalton) wrote :

I can confirm the bug

Changed in brasero:
importance: Undecided → Low
status: New → Confirmed
Boniek (boniek12p) wrote :

Have same problem here

rzlatic (robin.zlatic) wrote :

same by me (brasero 0.7.1, hardy 64bit).
workaround with editing the cue file with full paths successfully helps Brasero burns the image.

Kris Marsh (moogman) wrote :

Linked to upstream bug which contains more information. Upstream bug is regarding music file, but the same issue occurs.

Changed in brasero:
status: Unknown → New
Kris Marsh (moogman) wrote :

Fixed upstream in Brasero 0.8.x. and 0.7.90

Changed in brasero:
status: Confirmed → Fix Committed
Changed in brasero:
assignee: nobody → desktop-bugs
Changed in brasero:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 0.7.91-0ubuntu1

---------------
brasero (0.7.91-0ubuntu1) intrepid; urgency=low

  * New upstream release (LP: #239524)
    - Fixed odd burning speeds (LP: #178482) (LP: #177124)
    - Cancel dialog buttons' wording is confusing (LP: #195083)
    - Support for DL DVDs (LP: #202206)
    - Brasero does not recognize .bin in the same directory
      when .cue is selected (LP: #202546)
    - Brasero does not save user settings (LP: #220352)
    - Can't set tmp dir and can't burn image if size > available
      on /tmp (LP: #226209)
    - Migrate from GnomeVFS to GIO (LP: #198771)
    - Preview disabled calls a video window (LP: #198497)
    - Brasero crashes in strlen () when debug mode is on (LP: #225405)
  * debian/control.in:
    - Remove Build depend on libgnomevfs2-dev (>= 2.14.2),
      libnautilus-burn-dev (>= 2.16.0), libnotify-dev
    - Bump Build depend libglib2.0-dev to (>= 2.15.6)
    - Bump Build depend libgstreamer0.10-dev to (>= 0.10.15)
    - Bump Build depend libtotem-plparser-dev to (>= 2.22.0)
    - Add Build depend on gnome-doc-utils (>= 0.3.2) and
      liblaunchpad-integration-dev
    - Bump Standards-Version to 3.8.0
  * debian/patches/007-fix-desktop-file-mime-typo.patch:
    - Dropped, merged upstream
  * debian/patches/010_lpi.patch:
    - Add launchpad-integration
  * debian/patches/012_gnome-doc-utils.make.patch
    - Add missing gnome-doc-utils.make to fix FTBFS
  * debian/rules:
    - Add --disable-scrollkeeper
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Pedro Fragoso <email address hidden> Thu, 03 Jul 2008 23:03:40 +0100

Changed in brasero:
status: Fix Committed → Fix Released
Sb (sb56637) wrote :

Why not make this available for Hardy? It's a needed bugfix.

Ben (benc) wrote :

This doesn't seem to be fixed in Intrepid (brasero version 0.8.2). If I `cd` to the directory containing the cue file, then re-run the cdrdao command given in the log, it burns correctly.

Ghost (ghostofmav) wrote :

Definitely not fixed in Intrepid (brasero version 0.8.2).
Hard to believe a later version does not have a previous bugfix.
Still trying to edit the cue file properly.

Ghost

Changed in brasero:
status: Fix Released → New
centx (centx) wrote :

Even if this is old, I can at least confirm this for Ubutu 8.10 - brasero 8.2

Irritating, but at least here I found a workaround.

Boniek (boniek12p) on 2010-01-04
Changed in brasero:
importance: Unknown → Undecided
status: New → Fix Released
Timo Aaltonen (tjaalton) wrote :

don't remove links to external bug trackers, thanks.

Changed in brasero:
importance: Undecided → Unknown
status: Fix Released → Unknown
Boniek (boniek12p) wrote :

I've changed to manual watch because remote watch seems not to work. Sorry for making your work more complicated.

Changed in brasero:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.