cannot rename video file

Bug #198497 reported by getaceres on 2008-03-04
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Low
brasero (Ubuntu)
Undecided
Ubuntu Desktop Bugs

Bug Description

Binary package hint: brasero

Using Hardy with updates up to March 4.

I cannot rename video files in Brasero. I add a video file to the project and then I either, click on the title or right click on the added file and select rename. The row becomes editable but right after that a preview window appears which steals the focus so the renaming is not possible.

Related branches

Murat Gunes (mgunes) wrote :

Thanks for reporting. This is with the Preview option in the View menu disabled, right?

Changed in brasero:
assignee: nobody → desktop-bugs
status: New → Incomplete
getaceres (getaceres) wrote :

Yes. If I enable it the result is the same.
I've observed that when I add a video file, I can rename it clicking on the name and the preview doesn't show on the first time. But once it has been edited, further tries to edit the name show this behavior.
Also, I tried cutting and pasting part of the name (in a file names A-B.avi, cut A and try to paste it after B). It gave me an error as if it was trying to paste the file itself, and not the clipboard content.

Murat Gunes (mgunes) wrote :

If enabling preview doesn't show you a separate preview integrated into the main GUI, that's a separate bug.

Changed in brasero:
status: Incomplete → Triaged
Changed in brasero:
status: Unknown → Confirmed
getaceres (getaceres) wrote :

Iv'e checked with the preview again enabled again and now it doesn't appear in a separate window, but in the preview panel. The last time I enabled the preview panel once the files were added to the project, while this time I had the preview panel enabled from the beggining.

Changed in brasero:
status: Confirmed → Fix Released
Félix Velasco (felix-velasco) wrote :

With the current solution, it fails right after installation, since a new gconf key has been added to the code, but not declared in the schema. Once the preview option in the menu is ticked, it works properly, even if you set the preview off again. I already reported it upstream.

Pedro Villavicencio (pedro) wrote :

fixed upstream, thanks for reporting.

Changed in brasero:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 0.7.91-0ubuntu1

---------------
brasero (0.7.91-0ubuntu1) intrepid; urgency=low

  * New upstream release (LP: #239524)
    - Fixed odd burning speeds (LP: #178482) (LP: #177124)
    - Cancel dialog buttons' wording is confusing (LP: #195083)
    - Support for DL DVDs (LP: #202206)
    - Brasero does not recognize .bin in the same directory
      when .cue is selected (LP: #202546)
    - Brasero does not save user settings (LP: #220352)
    - Can't set tmp dir and can't burn image if size > available
      on /tmp (LP: #226209)
    - Migrate from GnomeVFS to GIO (LP: #198771)
    - Preview disabled calls a video window (LP: #198497)
    - Brasero crashes in strlen () when debug mode is on (LP: #225405)
  * debian/control.in:
    - Remove Build depend on libgnomevfs2-dev (>= 2.14.2),
      libnautilus-burn-dev (>= 2.16.0), libnotify-dev
    - Bump Build depend libglib2.0-dev to (>= 2.15.6)
    - Bump Build depend libgstreamer0.10-dev to (>= 0.10.15)
    - Bump Build depend libtotem-plparser-dev to (>= 2.22.0)
    - Add Build depend on gnome-doc-utils (>= 0.3.2) and
      liblaunchpad-integration-dev
    - Bump Standards-Version to 3.8.0
  * debian/patches/007-fix-desktop-file-mime-typo.patch:
    - Dropped, merged upstream
  * debian/patches/010_lpi.patch:
    - Add launchpad-integration
  * debian/patches/012_gnome-doc-utils.make.patch
    - Add missing gnome-doc-utils.make to fix FTBFS
  * debian/rules:
    - Add --disable-scrollkeeper
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Pedro Fragoso <email address hidden> Thu, 03 Jul 2008 23:03:40 +0100

Changed in brasero:
status: Fix Committed → Fix Released
marco.pallotta (marco-pallotta) wrote :

I hope the fix will be released for Hardy Heron LTS x86-64 too as soon as possible.

Changed in brasero:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.