Brasero hangs when burning cds

Bug #1770502 reported by Bill Hammond on 2018-05-10
This bug affects 30 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)

Bug Description

Brasero hangs at the "starting recording..." status box and the progress bar freezes. Nothing is written to the disc. I did not have this problem prior to upgrading to 18.04.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: brasero 3.12.1-4ubuntu2
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu May 10 17:11:18 2018
InstallationDate: Installed on 2018-04-28 (12 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
 PATH=(custom, no user)
SourcePackage: brasero
UpgradeStatus: No upgrade log present (probably fresh install)

Bill Hammond (ka1ssr) wrote :
Bill Hammond (ka1ssr) wrote :

Some additional information.

As an experiment, I tried burning a cd with the write directly to the cd option unchecked. The files (mp3) seemed to transcode okay but when the time came to write the cd, it was ejected and the write failed. I am attaching the session log.

Mohammads (new-mohammads) wrote :

Same for burning "Audio CD"

I'm using bionic x64 on Asus_K43SD, After selecting files and pushing burn button, brasero hangs on the 'starting to record' dialogue!

Note: There were no any problem on artful x64 for burning "Audio CD".

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in brasero (Ubuntu):
status: New → Confirmed
nmaxx (nmaxx) wrote :

Same issue here (Asus DRW-24F1ST a), it worked fine in 16.04.

nmaxx (nmaxx) wrote :
Michael Crider (mecrider) wrote :

I had the same problem after an upgrade from 17.10 to 18.04 - worked fine in 17.10. Worked fine for other CD types, just not audio CDs. In desperation I installed k3b, which I used prior to finding brasero a couple years ago. On launch it complained about permissions on /usr/bin/cdrdao - it needed set to 4711. I did this, and both k3b and brasero worked. I don't remember now if any others needed fixed - k3b also checks permissions for /usr/bin/wodim (should be 4711) and /usr/bin/growisofs (should be 0755).

Ronald (ronald88888) wrote :

had the same problem. Like Michael wrote
/usr/bin/cdrdao - set to 4711, /usr/bin/wodim to4711 and /usr/bin/growisofs 0755 made it work

cd /usr/bin
sudo chmod -v 4711 cdrdao
udo chmod -v 4711 wodim
sudo chmod -v 0755 growisofs

Bill Hammond (ka1ssr) wrote :

Apologies for not replying sooner. Those workarounds solved my problem. However, it would be nice if this was fixed in later updates.

Thank you, all, for your help.

bitboy (zeus557) wrote :

On Linuxmint 19 it is also necessary to install cdrdao
sudo apt-get install cdrdao

I was also unable to burn anything in Brasero with default options. Making cdrdao & wodim setuid root (4711) solved the problem for me.

Dave H (dave-hills-2009) wrote :

Affected me, clean install of Ubuntu-mate 18.04.1 LTS. Brasero would fail to burn Audio CD's.

Thanks @Ronald, work around worked fine.

Nigel Stewart (nigels) wrote :

Same problem for me with Ubuntu 18.04.1 LTS

Workaround succeeded but seems reasonable for brasero to prompt for sudo, or similar.

UBUNTU 18.04 LTS, same Problem.
The workaround helped me.

Steve Petersen (spetey) wrote :

I had the same issue and the workaround did *not* help; `cdrdao` is 4711 (and just for good measure I changed `wodim` too), but brasero still hangs. I saw elsewhere that `xfburn` still works - and so it does, but without cd text information. Does *that* need sudo permission too, maybe? I have no idea what tool that is. Any help appreciated.

Steve Petersen (spetey) wrote :

... sorry, on a bit further experimentation, it worked when I disabled "burnproof", which I frankly don't understand (what it is *or* why disabling it would help). I remember having trouble with burnproof in the distant past and had tried to disable it before I knew to change the cdrdao permissions, but that did not work.

Mike (bild85) wrote :

This was also the fix for me. Repeating here for an easy copypasta:

sudo ls
[enter your password, then copy and paste these lines:]

sudo chmod -v 4711 /usr/bin/cdrdao
sudo chmod -v 4711 /usr/bin/wodim
sudo chmod -v 0755 /usr/bin/growisofs

The purpose of the 'sudo ls' is just to grant sudo access once. The remaining sudo calls will not prompt for the next few minutes.

For the developers, here is the output:
mode of 'cdrdao' changed from 0755 (rwxr-xr-x) to 4711 (rws--x--x)
mode of 'wodim' changed from 0755 (rwxr-xr-x) to 4711 (rws--x--x)
mode of 'growisofs' retained as 0755 (rwxr-xr-x)

Shane Bill (shaneonabike) wrote :

I can confirm that brasero finally worked after this. Can we roll this into a patch of some sort?

rory (roryaherne) wrote :

@Mike, your solution (#17) worked for me too on Ubuntu 18.04.2 LTS

Rob Cannell (r-cannell) wrote :

Mike's fix worked for me as well - Ubuntu 18.04.

Steve Walker (swalker2001) wrote :

Fix worked for me. Waiting on patch.

Confirmed that this fix worked for me as well on 18.04.3 LTS.

Louise Le Mottee (angrybird45) wrote :

I had the same problem. I am about to try the suggestions here.

Doc Mayhem (docmayhem90) wrote :

I never got an error - Brasero just hung. K3B has the same problem.

Wound up running brasero as root because I was in a rush - which worked as a one-time fix.

Can confirm that posted workaround works on 18.04.3 LTS as well

rseascaoe (rseascape) wrote :

Ubuntu 18.04.3 Brasero/K3B/XfBurn/SimpleBurn not writing/hanging - SOLVED

It’s a permissions problem: Change permissions in termial with these commands.

sudo chmod 4711 /usr/bin/cdrdao
sudo chmod 4711 /usr/bin/wodim
sudo chmod 0755 /user/bin/growisfs

rseascaoe (rseascape) wrote :

Ubuntu 18.04.3 Brasero/K3B/XfBurn/SimpleBurn not writing/hanging - SOLVED

It’s a permissions problem: Change permissions in termial with these commands.

sudo chmod 4711 /usr/bin/cdrdao
sudo chmod 4711 /usr/bin/wodim
sudo chmod 0755 /user/bin/growisfs

Paul (pagelec) wrote :

On Ubuntu 18.04.3 I started experiencing the same problem. CD burning worked fine with Brasero in December when I last burned a CD for my car.

I have suddenly had this problem since January, Brasero is hanging at "Starting to Record"

I ran the commands from this thread:
sudo chmod 4711 /usr/bin/cdrdao
sudo chmod 4711 /usr/bin/wodim
sudo chmod 0755 /user/bin/growisfs

And now it gets a bit further but hangs at "Writing CD-Text Information"

I am forced to End Process for Brasero and then the CD appears as no longer blank and I cannot use it again.

I have also tried K3b and XFBurn which have the same problem.

I have just clean installed this computer to 19.10 and again I have the same problem.

Can anyone give me some help? I need to get a bunch of CDs burned urgently by next weekend.

I have now wasted a whole bunch of blank CDs and I really do not want to have to change to another OS to fix this.

Jeff (jjzone44) wrote :

Just ran into this same issue with Linux Mint 19.3 with Cinnamon 4.4.8
Using this instruction worked for me also. Burning completed without further issue.

cd /usr/bin
sudo chmod -v 4711 cdrdao
udo chmod -v 4711 wodim
sudo chmod -v 0755 growisofs

This affects me to. Brasero frezes while writing audio CD. Workaround alowed me to get stuck at cd-text part just as Paul said. I have to kill application to stop it. I have Ubuntu 20.04.

nmaxx (nmaxx) on 2020-05-15
tags: added: focal
Matt Logos (excalibursedge) wrote :

I installed Ubuntu 18.04.3 when I finally changed over from gatescrap. However, I have yet to be able to burn a cd or dvd, which I use a lot. I have the linux version of DVDStyler 3.1, but am unable to get it to burn. I hope this workaround on permissions works or I may have to put Windows back on one of my desktops.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers