Brasero not translated at all on ubuntu 16.04

Bug #1574090 reported by Olivier Febwin on 2016-04-23
38
This bug affects 11 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
High
Gunnar Hjalmarsson
Xenial
High
Sebastien Bacher

Bug Description

To the sponsor: Please use the same patch for Xenial, changing the version to 3.12.1-1ubuntu2.1.

[Impact]

Translations are not enabled. The attached patch fixes it.

[Test Case]

1. Install some other language but english and make it the display language.

2. Start brasero and find that it's still displayed in English.

[Regression Potential]

Neglectable.

summary: - not translated at all
+ not translated at all on ubuntu 16.04
Olivier Febwin (febcrash) wrote :

ok, but they are not applied.
All was translated on ubuntu 15.10

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in brasero (Ubuntu):
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :
Changed in brasero (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → High
status: Confirmed → In Progress
tags: added: patch
Changed in brasero:
importance: Undecided → Unknown
status: New → Unknown
Changed in brasero:
importance: Unknown → High
status: Unknown → Confirmed
no longer affects: ubuntu-translations
description: updated
Changed in brasero (Ubuntu Xenial):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → High
status: New → In Progress
description: updated
Changed in brasero (Ubuntu):
status: In Progress → Fix Committed
Olivier Febwin (febcrash) wrote :

I have not understood how I can test your patch

Gunnar Hjalmarsson (gunnarhj) wrote :

Well, you'd need to build brasero from source to test it. I did so, and if you don't know how to do that, please be patient and wait until the fix lands in Xenial. (It may take some time.) Then, if you'd find that it still doesn't work as expected, please let us know.

Thanks for reporting the issue!

Olivier Febwin (febcrash) wrote :

Okay, I'll wait the fix by update-manager.
Thanks for the fix!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 3.12.1-1ubuntu3

---------------
brasero (3.12.1-1ubuntu3) yakkety; urgency=medium

  * debian/patches/014_enable_translations.patch:
    - Enable translation support (LP: #1574090).

 -- Gunnar Hjalmarsson <email address hidden> Sat, 23 Apr 2016 23:05:00 +0200

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
tomtomtom (tomtomtom) wrote :

Well, this is inconsistent behavior.

The language file was located in /usr/share/locale-langpack/*/LC_MESSAGES/brasero.mo and belongend to the packages language-pack-gnome-*-base.

Because of the usbekian and lower german translations file are still in the language packs but the "new" translations comes with brasero-common instead of language-pack-gnome-*-base in yakkety we are having the translation for nds in two packages at two different places.

Translation for lower german in yakkety

/usr/share/locale-langpack/nds/LC_MESSAGES/brasero.mo in package language-pack-gnome-de-base AND /usr/share/locale/nds/LC_MESSAGES/brasero.mo in package brasero-common

The uzbekian translation is only at /usr/share/locale-langpack/uz/LC_MESSAGES/brasero.mo in package language-pack-gnome-uz-base and does not exist in package brasero-common.

Gunnar Hjalmarsson (gunnarhj) wrote :

@tomtomtom:

brasero has been moved from main to universe, and the brasero.mo files will be available in /usr/share/locale going forward.

The -base language packs for uz and nds were not included in the Xenial build on 2016-04-15, probably because the translation coverage was too low. If you think this is wrong, please file a new bug to the langpack-o-matic project.

The brasero.mo files for uz and nds you see in /usr/share/locale-langpack are consequently leftovers from a previous language pack build in the Xenial development cycle. The duplication does not make the translations unavailable when running brasero.

The translations which are provided by brasero-common are the upstream ones, and currently there is no Usbek translation upstream. To change that, you may want to upload the Uzbek translation to <https://l10n.gnome.org/module/brasero/>.

Jean-Marc (m-balthazar) on 2016-04-29
summary: - not translated at all on ubuntu 16.04
+ Brasero not translated at all on ubuntu 16.04
Sebastien Bacher (seb128) wrote :

Thanks Gunnar, that patch is not needed since USE_NLS is defined by AM_GLIB_GNU_GETTEXT, what was needed is to have a rebuild so translations are not removed from the binary.

I'm doing a SRU with another fix that should fix that as well.

Note that for yakkety we might want to add "X-Ubuntu-Use-Langpack: yes" to debian/control and use langpack again, that would allow launchpad translators to contribute to the translations (we can't easily do that in xenial, or we would need to coordinate with a new langpacks landing adding back the domain)

Changed in brasero:
status: Confirmed → Unknown
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for pointing out my mistake, Sebastien. Assigning the Xenial task to you then.

Changed in brasero (Ubuntu Xenial):
assignee: Gunnar Hjalmarsson (gunnarhj) → Sebastien Bacher (seb128)

Hello Olivier, or anyone else affected,

Accepted brasero into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/brasero/3.12.1-1ubuntu3~16.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in brasero (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Olivier Febwin (febcrash) wrote :

Now is OK with 3.12.1-1ubuntu3~16.04 but it lacks "Copy a Disc"
See attachment

Сергей (carvinss) wrote :

Fully confirms the words of Olivier Febwin (febcrash). The problem can be considered solved.

affects: brasero → ubuntu-translations
Changed in ubuntu-translations:
importance: High → Undecided
status: Unknown → New
no longer affects: ubuntu-translations
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 3.12.1-1ubuntu3~16.04

---------------
brasero (3.12.1-1ubuntu3~16.04) xenial; urgency=medium

  * Rebuild in universe to have translations included (lp: #1574090)
  * debian/patches/01_current_libdvdcss_symbol.patch:
    - don't try to load a libdvdcss symbol which is not in the current
      version, that made the plugin fail to be enabled
      (lp: #1577268)

 -- Sebastien Bacher <email address hidden> Thu, 12 May 2016 08:19:33 +0200

Changed in brasero (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for brasero has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers