Ubuntu

package branding-ubuntu 0.5 failed to install/upgrade: trying to overwrite '/usr/share/gnome-games/quadrapassel/pixmaps/quadrapassel.svg', which is also in package quadrapassel 1:2.32.1-0ubuntu3

Reported by Darrell Waldron on 2011-04-07
946
This bug affects 142 people
Affects Status Importance Assigned to Milestone
Y PPA Manager
Undecided
Unassigned
branding-ubuntu (Ubuntu)
High
Martin Pitt

Bug Description

Binary package hint: branding-ubuntu

(Reading database ... 347301 files and directories currently installed.)

Preparing to replace branding-ubuntu 0.5 (using .../branding-ubuntu_0.6_all.deb) ...

Unpacking replacement branding-ubuntu ...

dpkg: error processing /var/cache/apt/archives/branding-ubuntu_0.6_all.deb (--unpack):

 trying to overwrite '/usr/share/gnome-games/quadrapassel/pixmaps/quadrapassel.svg', which is also in package quadrapassel 1:2.32.1-0ubuntu3

Errors were encountered while processing:

 /var/cache/apt/archives/branding-ubuntu_0.6_all.deb

This happened when I downloaded the update and it tried to install.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: branding-ubuntu 0.5
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
AptOrdering:
 branding-ubuntu: Install
 branding-ubuntu: Configure
Architecture: i386
Date: Thu Apr 7 08:16:32 2011
Dependencies:

DpkgTerminalLog:
 Preparing to replace branding-ubuntu 0.5 (using .../branding-ubuntu_0.6_all.deb) ...
 Unpacking replacement branding-ubuntu ...
 dpkg: error processing /var/cache/apt/archives/branding-ubuntu_0.6_all.deb (--unpack):
  trying to overwrite '/usr/share/gnome-games/quadrapassel/pixmaps/quadrapassel.svg', which is also in package quadrapassel 1:2.32.1-0ubuntu3
ErrorMessage: trying to overwrite '/usr/share/gnome-games/quadrapassel/pixmaps/quadrapassel.svg', which is also in package quadrapassel 1:2.32.1-0ubuntu3
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
SourcePackage: branding-ubuntu
Title: package branding-ubuntu 0.5 failed to install/upgrade: trying to overwrite '/usr/share/gnome-games/quadrapassel/pixmaps/quadrapassel.svg', which is also in package quadrapassel 1:2.32.1-0ubuntu3
UpgradeStatus: Upgraded to natty on 2011-04-06 (1 days ago)

Darrell Waldron (hittite85) wrote :
Changed in branding-ubuntu (Ubuntu):
importance: Undecided → High
status: New → Triaged
Scott Ritchie (scottritchie) wrote :

Hmm, it's supposed to divert it

joopbraak (joopbraak) wrote :

Interesting info at the end of the log:

Errors were encountered while processing:
 /var/cache/apt/archives/branding-ubuntu_0.6_all.deb
etn ppto-pdeo 04+z640bnu)..Stigu nm-etnsdeo 23.-uut1)..Stigu rcs(:..-0bnu)..pop tpwiigStigu pdeo-aa(.1br1-uut2 .
etn pattasothts(..32bnu)..Stigu iue0(6-uut3 .
etn ppto-pdeo.t3igt 04+z640bnu)..Stigu opzpuismi 094br01460bnu)..Stigu yhnatamngkigt 04+z640bnu)..Stigu opzfso-lgn-an(..+z2100-uut1 .
etn patamn(.1br1-uut2 .
etn ppto-pdeo-t 04+z640bnu)..Stigu p-tl 081.uut2 .
etn pue 170bnu)..ue tr/unn,poes58
eoig'ieso f/bnueamt si/dvd.prd yfk-dv
paeiirms eern pae(rge ciae)Stigu igdv100(:6-uut3 .
etn pceko 01.)..Stigu nteddugae 07uut1 .
ntlignwvrino ofgfl ecatatcn./0nteddugae .
rcsigtigr o yhncnrl..Stigu hcbxgk(.13 .
rcsigtigr o eu..Poesn rgesfrlb-i .
dofgdfre rcsignwtkn lc
rcsigtigr o ntaf-ol .
paeiirms eeaig/otiir.m-..88gnrcPoesn rgesfrpto-eta

WTF?

Joshua R. Poulson (jrp) wrote :

That sort of corruption does not appear in the logs I submitted to LP bug #753492

Martin Pitt (pitti) on 2011-04-07
Changed in branding-ubuntu (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → In Progress
DaleEMoore (daleemoore) wrote :

sudo apt-get remove quadrapassel

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package branding-ubuntu - 0.7

---------------
branding-ubuntu (0.7) natty; urgency=low

  * debian/branding-ubuntu.{preinst,postrm}: Fix diversion handling to not
    only apply to past versions. (LP: #753449)
 -- Martin Pitt <email address hidden> Thu, 07 Apr 2011 19:44:19 +0200

Changed in branding-ubuntu (Ubuntu):
status: In Progress → Fix Released

I removed quadrapassel, using "apt-get remove", as you suggested, and
then the branding-ubuntu 0.5 package did install properly.

Thanks

Darrell

-------
On Thu, 2011-04-07 at 17:47 +0000, DaleEMoore wrote:
> sudo apt-get remove quadrapassel
>

Darrell Waldron (hittite85) wrote :

Opps. It was the branding-ubuntu_0.6 that did install properly, not the
0.5 one. The 0.5 one was the one trying to be updated.

Darrell
--------------------------
On Thu, 2011-04-07 at 14:08 -0400, Darrell Waldron wrote:
> I removed quadrapassel, using "apt-get remove", as you suggested, and
> then the branding-ubuntu 0.5 package did install properly.
>
> Thanks
>
> Darrell
>
> -------
> On Thu, 2011-04-07 at 17:47 +0000, DaleEMoore wrote:
> > sudo apt-get remove quadrapassel
> >
>

William Lehotz (william64134) wrote :

Thanks Darrell. --- running sudo apt-get remove quadrapassel in the terminal window fixed it and allowed for the install.

Sense Egbert Hofstede (sense) wrote :

This bug had quite some consequences for some people, causing bugs #753853 and #741370, making the system unbootable until dpkg --configure -a was run in a chroot to finish the configuration of udev and the new kernel. The update process of both was interrupted when aptd crashed as a result of this bug.

Sylvestra (blackcatw) wrote :

sudo apt-get upgrade still gives

Vorbereitung zum Ersetzen von branding-ubuntu 0.5 (durch .../branding-ubuntu_0.6_all.deb) ...
Ersatz für branding-ubuntu wird entpackt ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/branding-ubuntu_0.6_all.deb (--unpack):
 Versuch, »/usr/share/gnome-games/quadrapassel/pixmaps/quadrapassel.svg« zu überschreiben, welches auch in Paket quadrapassel 1:2.32.1-0ubuntu4 ist
Es wurde kein Apport-Bericht verfasst, da das Limit MaxReports bereits erreicht ist
   Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/branding-ubuntu_0.6_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

(sorry it's in german...)

On Thu, 2011-04-07 at 17:47 +0000, DaleEMoore wrote:
> sudo apt-get remove quadrapassel

this doesnt sound like a proper solution to me...

> sudo apt-get upgrade still gives
>
> Vorbereitung zum Ersetzen von branding-ubuntu 0.5 (durch .../branding-ubuntu_0.6_all.deb) ...

Obviously. As the previous messages state, the fix is in 0.7, not in
0.6, so you have to wait till your local mirror gets the updated package.

joopbraak (joopbraak) wrote :

@Sense Hofstede
This package has nothing to do with udev or kernel whatsoever so it couldn't have caused these kind of severe problems.

Joshua R. Poulson (jrp) wrote :

It didn't cause the problem, per se, but it did happen at the same time as a udev update that led to unbootable systems because udev's install could not complete.

Changed in y-ppa-manager:
status: New → Invalid
John D Wilson (john-wilsonet) wrote :

I forced Update Manager to check for new updates on a daily basis. In each case, the "Branding" package would fail to install while the other updates seemed to install ok. After about two iterations of this, the branding package seemed to install ok. That lasted a couple of days, but just started popping up as an error again immediately after I cold start and log in.

joopbraak (joopbraak) wrote :

@ Joshua R. Poulson
That things are happening at the same time doesn’t mean there is a logical link.
http://en.wikipedia.org/wiki/Post_hoc_ergo_propter_hoc

Andreas Moog (amoog) wrote :

Joopbrack, in this specific case the broken branding-ubuntu package DID cause real breakage due to the way dpkg installs and configures packages.

joopbraak (joopbraak) wrote :

But dpkg continues to install packages even if one fails, so how can that be, how can dpkg crash during the installation of a package when the former package failed to install? I don't see that.
Or it must be a bug in dpkg or apt and I haven't seen that being mentioned anywhere.

joopbraak (joopbraak) wrote :

OK, must have been blind. (LP: #741370). Sorry.

As someone mentioned in this thread, Ubuntu fails to boot after this
broken upgrade. So I had to drop to maintenance shell, remount / as
rw, run apt-get remove ubuntu-branding, and after a lot of post
processing it was booting up the next time..

New comers who did this upgrade would definitely feel lost..

On Mon, Apr 11, 2011 at 5:22 AM, joopbraak <email address hidden> wrote:
> OK, must have been blind. (LP: #741370). Sorry.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (753665).
> https://bugs.launchpad.net/bugs/753449
>
> Title:
>  package branding-ubuntu 0.5 failed to install/upgrade: trying to
>  overwrite '/usr/share/gnome-
>  games/quadrapassel/pixmaps/quadrapassel.svg', which is also in package
>  quadrapassel 1:2.32.1-0ubuntu3
>
> Status in Y PPA Manager:
>  Invalid
> Status in “branding-ubuntu” package in Ubuntu:
>  Fix Released
>
> Bug description:
>  Binary package hint: branding-ubuntu
>
>  (Reading database ... 347301 files and directories currently
>  installed.)
>
>  Preparing to replace branding-ubuntu 0.5 (using .../branding-
>  ubuntu_0.6_all.deb) ...
>
>  Unpacking replacement branding-ubuntu ...
>
>  dpkg: error processing /var/cache/apt/archives/branding-
>  ubuntu_0.6_all.deb (--unpack):
>
>   trying to overwrite '/usr/share/gnome-
>  games/quadrapassel/pixmaps/quadrapassel.svg', which is also in package
>  quadrapassel 1:2.32.1-0ubuntu3
>
>  Errors were encountered while processing:
>
>   /var/cache/apt/archives/branding-ubuntu_0.6_all.deb
>
>
>  This happened when I downloaded the update and it tried to install.
>
>  ProblemType: Package
>  DistroRelease: Ubuntu 11.04
>  Package: branding-ubuntu 0.5
>  ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
>  Uname: Linux 2.6.38-8-generic i686
>  NonfreeKernelModules: nvidia
>  AptOrdering:
>   branding-ubuntu: Install
>   branding-ubuntu: Configure
>  Architecture: i386
>  Date: Thu Apr  7 08:16:32 2011
>  Dependencies:
>
>  DpkgTerminalLog:
>   Preparing to replace branding-ubuntu 0.5 (using .../branding-ubuntu_0.6_all.deb) ...
>   Unpacking replacement branding-ubuntu ...
>   dpkg: error processing /var/cache/apt/archives/branding-ubuntu_0.6_all.deb (--unpack):
>    trying to overwrite '/usr/share/gnome-games/quadrapassel/pixmaps/quadrapassel.svg', which is also in package quadrapassel 1:2.32.1-0ubuntu3
>  ErrorMessage: trying to overwrite '/usr/share/gnome-games/quadrapassel/pixmaps/quadrapassel.svg', which is also in package quadrapassel 1:2.32.1-0ubuntu3
>  InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
>  PackageArchitecture: all
>  SourcePackage: branding-ubuntu
>  Title: package branding-ubuntu 0.5 failed to install/upgrade: trying to overwrite '/usr/share/gnome-games/quadrapassel/pixmaps/quadrapassel.svg', which is also in package quadrapassel 1:2.32.1-0ubuntu3
>  UpgradeStatus: Upgraded to natty on 2011-04-06 (1 days ago)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/y-ppa-manager/+bug/753449/+subscribe
>

--
<Jaiber John>

Jim Leinweber (jiml-mail) wrote :

I didn't have any problem with booting; I got it around the time of running update-manager for beta1 -> beta2.

E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_natty_main_i18n_Translation-en, E:The package lists or status file could not be parsed or opened.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments