package branding-ubuntu (not installed) failed to install/upgrade:

Bug #578206 reported by maedox on 2010-05-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
branding-ubuntu (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: branding-ubuntu

1) Got this error message when upgrading from Ubuntu 9.10 to 10.04. It asked me to report it so I did. Not sure what to write here. Let me know what kind of information is needed.

2) It said ubuntu-branding-0.4.0 or something like that, so it's probably version 0.4.0.

3) Upgrade successful

4) Upgrade successful with this exception, which probably (luckily) does not matter.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: branding-ubuntu (not installed)
ProcVersionSignature: Ubuntu 2.6.31-21.59-generic-pae
Uname: Linux 2.6.31-21-generic-pae i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Mon May 10 12:37:53 2010
ErrorMessage:
 ErrorMessage: no package named `branding-ubuntu' is installed, cannot configure
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
SourcePackage: branding-ubuntu
Title: package branding-ubuntu (not installed) failed to install/upgrade:

maedox (paal-nilsen) wrote :
Scott Ritchie (scottritchie) wrote :

Adding `diversion of /usr/share/gnome-games-common/cards/gnomangelo_bitmap.svg to /usr/share/gnome-games-common/cards/gnomangelo_bitmap.svg.unbranded by branding-ubuntu'
dpkg-divert: rename involves overwriting `/usr/share/gnome-games-common/cards/gnomangelo_bitmap.svg.unbranded' with
  different file `/usr/share/gnome-games-common/cards/gnomangelo_bitmap.svg', not allowed
dpkg: error processing /var/cache/apt/archives/branding-ubuntu_0.4-0ubuntu1_all.deb (--unpack):
 subprocess new pre-installation script returned error exit status 2

Did you already have a /usr/share/gnome-games-common/cards/gnomangelo_bitmap.svg.unbranded file? You may have gotten it by following an instructional script to install the branded cards experimentally long ago, I saw something like that on the forums.

Please post the output of: ls /usr/share/gnome-games-common/cards/

Thank you

maedox (paal-nilsen) wrote :

It seems I already had a gnomeangelo_bitmap.svg, but there is no .unbranded in the name. I didn't bother messing with the upgrade anymore so I reinstalled (easy peasy when my /home is on another partition). I do have a full backup from right before starting the upgrade though. Here is the output of `ls -l usr/share/gnome-games-common/cards/`

-rw-r--r-- 1 root root 529535 2009-09-22 11:23 usr/share/gnome-games-common/cards/gnomangelo_bitmap.svg

I have no idea why I would have that file if it's not supposed to be there. This is my work computer so I am at least sure I didn't install any games other that the ones that are included by default in the install.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers