remove svg to png conversion for bootchart

Bug #204186 reported by David Gaarenstroom on 2008-03-20
6
Affects Status Importance Assigned to Milestone
bootchart (Ubuntu)
Wishlist
Unassigned
Declined for Gutsy by Scott James Remnant (Canonical)
Nominated for Jaunty by Justin Dugger

Bug Description

Binary package hint: bootchart

0) Severity: Nice-to-have
1) Release info:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=7.10
DISTRIB_CODENAME=gutsy
DISTRIB_DESCRIPTION="Ubuntu 7.10"
2) Source package:
bootchart 0.9-0ubuntu7
3) Package info:
bootchart 0.9-0ubuntu7

Report:
---------
At the moment, in /etc/init.d/stop-bootchart a PNG chart is generated from the generated SVG file. I also assumed this made sense at first, but the SVG image consumes much less space, and it can be viewed by most image viewers preinstalled for most Ubuntu flavors. Perhaps in the past, this used to be a problem...

Proposal:
------------
- I'd like to propose to remove the 'rsvg' step and thus remove the dependency to librsvg2-bin (and the whole bunch of dependencies it has).
- Instead of removing the dependency, It could be moved to "recommended". Then I'd like to see the dependency to be changed to "librsvg2-bin|imagemagick", because like rsvg, the imagemagicks convert can do the same...

xtknight (xt-knight) wrote :

Subscribed ubuntu-sru so they can take a look at your request.

xtknight (xt-knight) wrote :

Please make sure you have followed all steps at https://wiki.ubuntu.com/StableReleaseUpdates

Absolutely unsuitable for a Stable Release Update since it would invalidate documentation (most importantly that for debugging and triage) for that release.

This can be considered for a future Ubuntu release.

Changed in bootchart:
importance: Undecided → Wishlist
status: New → Confirmed

FWIW, I never intended it to be included for a stable release update. However, if one would change the dependency on librsvg2-bin to "librsvg2-bin|imagemagick", it wouldn't invalidate the documentation, so "absolutely unsuitable" seems a bit rush...

Stable Release Updates are really for only critical bugs or significant bug fixes. Someone had nominated this for a gutsy SRU, I declined that and simply explained why.

You can now use "bootchart=svg"

Changed in bootchart:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers